Need a new search?

If you didn't find what you were looking for, try a new search!

Viewing 35 results - 106 through 140 (of 1,077 total)
  • Author
    Search Results
  • jeffdamann
    Participant
    Post count: 52

    Try pressing select+y and going into input settings. Then change your hotkey button to something other than select.

    Select being the hotkey button causes issues in some MAME games, so maybe that is the culprit here as well.

    worryface
    Participant
    Post count: 3

    I just installed rp 3.3.1-rpi2 on a RP2B+. I connected 2 identical iBuffalo USB SNES joypads and configured the first through the emulation station startup configuration menu.

    Both controllers work for the NES emulator. All buttons and the D-pad for the first joypad work – including hot keys – and control player 1. All buttons and the D-pad for the second joypad work – *excluding* hotkeys – and control player 2.

    The problem is mame4all. I’ve configured the controllers through the mame UI. The mame UI correctly identifies the controller and input in that when I press a button on the second joy pad the mame UI reads and correctly assigns the button as J2 Button 0+,0-,7, or whatever. But the player 2 controller doesn’t work correctly. Mame correctly identifies and executes as assigned the input from the [select] and [start] buttons of the second joypad, but it doesn’t use the D-pad or other buttons to control player 2. The D-pad and buttons from joypad 1 control the second player.

    I’ve tried hard coding the input through retroarch.cfg. I get the same behavior. Any help would be appreciated. Thanks.

    mw99
    Participant
    Post count: 20

    The other day I installed the 3.3 Jessie (BETA) version of RetroPie on my Raspberry Pi model B. It worked fairly well, I had some issues with WiFi and my controller, but was able to play a few games. I tried “Super Mario World – SNES” and it worked quite well.

    Today I decided to try the stable 3.3.1 Wheezy version, so I installed it and my WiFi/controller issues were gone. Everything is working pretty well so far, except for the SNES emulator. Now, Super Mario World is blurrier, laggier, and the audio is horrible. I did some searching around and a lot of people said to switch to PiSNES. I changed the default SNES emulator from “lr-pocketsnes” to PiSNES, and the performance was much, much better and the audio was good too. However, the controls do not match what I configured via EmulationStation (I’m using a XBox 360 controller), the hotkeys (EX: Start+Select to exit the rom) don’t work, and I’m not even able to exit the game by pressing the Esc key. The only way to exit the game is by either unplugging the Pi or pressing Ctrl+Alt+Del. I switched back to lr-pocketsnes, but the overall lag is very frustrating.

    If I could get some help that would be great!

    helpman
    Participant
    Post count: 37

    So here’s a though one, or at least I couldn’t figure it out.
    I have my retropie on an arcade control panel, so you can plug it and enjoy it on any tv… and that’s the problem.

    If I set some shader to look nice as scanlines on hdtv, then it sucks when connected to rca.
    If I disable any shader and connect to a hdtv, then it sucks too, although it looks nice on smaller tvs with rca…

    Is there any way to enable/disable shaders when it is connected through rca or hdmi? or a hotkey to enable/disable them that I could remap to a button combination?

    I’ve found how to assign next/back shader as hotkeys, but I just have the player’s buttones, so I would need something like “1p+coin” or “2p+coin” (as example) to just enable or disable shaders

    catrinisin
    Participant
    Post count: 35

    Hi all,

    Just wanted to share my latest project based on the awesomeness that is Retropie.
    I built this for my kids (myself mostly, don’t tell my wife) for Christmas this year. I was somehow able to do this in about 4 weeks total thanks to the plethora of info available on this forum and the rest of the internet.

    This was built from one 4′ x 8′ sheet of 1/2″ birch plywood. 1″ x 2″ braces are glued and screwed from the inside on all joints. You can see in one pic where I placed all the pieces using scotch tape temporarily. I then drew lines on the inside where the 1×2 braces were placed.

    This is running a Raspberry Pi 2 with Retropie 3.3.

    The screen is a 19″ TV which I mounted in such a way to use the built in speakers on the bottom and project them forward to the holes you see and small wood box under each speaker. HDMI is used for both video and audio from the Pi. The screen is connected to the frame using it’s own mounting holes where the stand used to be. I drilled holes in a couple aluminum bars and screwed it down to the wood, and used the TV’s own screws that used to hold the stand. Then one more piece of 1×2 wood on top of the tv to hold it in place. I ended up having to force the Pi into HDMI mode and specify the resolution in the config.txt file to keep the TV from switching inputs when powered on. There was a timing issue where the TV took too long to power up and the Pi didn’t detect anything in the HDMI port and then didn’t output HDMI. (unless rebooted while the TV was already on) Also the TV would switch to another input when it didn’t detect an HDMI signal. So forcing the output settings with config.txt fixed all this. I also had to hard set the audio to HDMI instead of Auto in the Raspi-config script.

    The buttons and 8 way joysticks are wired to an iPac2 controller and connected to the Pi via USB. The iPac is running in keyboard mode.

    I’ve customized certain things such as volume control using the option button + player 2 joystick up and down. Save and Load state buttons, Pause, etc.
    The “shift” button you see in the pics (player 2 select button) is the iPac shift key. This allows me to navigate config menus that require tab, enter, F4, etc. (These aren’t labeled; they are just for me)
    The “Option” button in the middle, is the RetroArch hotkey button. It’s the escape key for all non-RetroArch emulators such as MAME. So players can hold “Option” while pressing pause, exit, save, load, and adjusting volume. Save slots are adjusted with option + left and right on player 1 joystick.

    For power, I used a standard IEC power connector with switch built in. This way I can use any standard PC power cable, and get one as long as needed wherever this thing is moved to. The back is removable using a mailbox key. The back of the IEC power connector goes into an electrical outlet box on the inside of the cabinet and is wired to a standard outlet. Then a power strip is connected where the Pi, TV, and LED light power supply all plug in. The buttons and marquee are all lit with LEDs.

    The marquee graphic isn’t tall enough, my own dumb fault, so I will replace that sometime soon. You can see the white bars above and below it for now. People tell me it looks good that way, but it bothers me, lol.

    Finally, I’m still waiting on two small 2 inch speakers grill covers for the front.

    All in all, I’m happy with this and it was a really fun project. I’m still tweaking things on the software side. I think the software stuff took twice as long as making the cabinet.

    [attachment file=”113809″]

    jmaxime89
    Participant
    Post count: 35

    UPDATE : I just realised that whatever I have in

    /opt/retropie/configs/all/retroarch-joypads/

    Retroarch never reads it.

    When I have emulationstation’s mapping and naming(sony entertainment wireless controller) R3 is select (which is my hotkey enable also)

    When I use retroarch mapping and naming (PS4 controller) the outcome is exactly the same all buttons messed up; R3 = select.

    When I use a file I found on github named Sony-Playstation4-DualShock4-Controller the outcome is once again the same, R3 = select for instance

    When this folder is empty my controller still have the same mapping in game…

    I see there is a variance in emulationstation and retroarch naming of the buttons (Retroarch Start = 6 emulationstation Start = 9)

    Thanks once again ! I hope one of who will see this and take the time to help me.

    dustloop
    Participant
    Post count: 22

    I remap the hotkey instead of select. I use a PS4 controller and remap the hotkey to 12 which is the guide button.

    From what I remember you go into command by F4 then type;

    jstest

    I think it is that. I’m sure someone will correct me. With that command you can see what number buttons are being pressed.

    baxtex
    Participant
    Post count: 10

    So i recently installed Retropie and got it working with my 360 controllers. I love it. Especially that I have assigned a hotkey enabler when pressing select. Then I assigned 2 buttons, one for saving and one for loading. This works fine for the SNES games that I play the most, but it does not work for any of my other two emulators, NES and Mega drive. Whenever I try to save or load I get a message saying that it could not find the file. for example: “Failed to save/load state from /home/RetroPie/roms/nes/best roms/batman.state The other emulators get the command that I want to save or load so the hotkeys are working. Anyone know of a fix? I’ve tried setting the persmission to read and write with this command: sudo chmod 777 /home/pi/RetroPie/roms but that did not change anything.

    Would appreciate some help regarding this matter, I’m quite new with the Raspberry and Linux in general.

    jmaxime89
    Participant
    Post count: 35

    Hi ! Long time user here and everytime I had issues with something this forum had been a great help.

    Yesterday I freshly started on my Pi2 the latest image of retropie wheezy

    I transfered my roms and everything works fine with my SNES controller.

    However when I map my WIRED PS4 controller either the buttons are all wrong OR I map it in retroarch and the controls are fine minus D-pad RIGHT which strangely never register in retroarch and no hot keys at all works when I modify my config file here :

    /opt/retropie/configs/all/retroarch-joypads

    Strangely my config file for the PS4 controller is either called

    PS4 Controller (when I manually map it in retroarch)
    or
    Sony Computer Entertainment Wireless Controller (when mapped in emulationstation)

    I did try this :

    https://github.com/libretro/retroarch-joypad-autoconfig/blob/master/udev/Sony-PlayStation4-DualShock4-Controller.cfg

    But it doesn’t work, all of the buttons are wrong and when I map it correctly and restart the pi it seems like it doesn’t refer to that file at all as all of the buttons are wrong again.
    The only two files I have here /opt/retropie/configs/all/retroarch-joypads
    is RetroUSB.comSNESRetroPort.cfg
    and
    PS4 Controller.cfg

    Sorry for the long post and probably bad english. All in all what I want is :

    To be able to play with my SNES controller and exiting the roms with my hotkeys
    And when I want to play playstation games I want to be able to plus my dualshock 4 and play the game while still be able to exit said game using mapped hotkeys for this controller.

    Thanks so much guys

    jeffdamann
    Participant
    Post count: 52
    #113521 In reply to: Quitting an emulator |

    if you have a joypad mapped correctly, it’s select+start.

    Default Hotkeys

    jmaxime89
    Participant
    Post count: 35

    Hi all,

    I searched the forum and I found an answer to my issue however it doesn’t work.

    I try to play emulators with a WIRED PS4 controller. It seems that emulationstation screw with retroarch autoconfig.

    When I remap the controller in retroarch it works but I can’t assign hotkeys like I do with my SNES controller.

    Also it is worth noting that retroarch and emulationstation are naming the two config files differently

    I know I can bind hotkeys in retroarch but my snes buttons combination will stop working then.

    I use the newest image of retropie wheezy

    Thanks in advance,
    Jmax

    petrockblog
    Keymaster
    Post count: 1828
    #113517 In reply to: Fba issue with coin |

    if your controller maps to keypresses you can do

    input_enable_hotkey = (leaving off the _btn etc)

    clbxr100
    Participant
    Post count: 2

    I setup the config for fba the start and select. I use an ipac2 so my start is 1 and my select is coin 1 wich is 5 but I seem to get nothing? I seen in a video something about the hotkey takes over 1st and wont allow the select to work? can anyone help?

    Floob
    Member
    Post count: 1629

    This
    input_enable_hotkey = q

    should read

    input_enable_hotkey = rshift

    on the assumption your arcade stick sends a right shift single on the button you want to use as the enable hotkey.

    Then pressing x on your arcade stick (The A button?) should save the game.

    The hotkey enable for your usb PS3 controller will be held in the controller config file, so that parts separate. /opt/retropie/configs/all/retroarch-joypads/

    Here is a (slightly outdated) video on hotkeys

    josh
    Participant
    Post count: 4

    Me and my Dad have had another look at the config file.
    Firstly, we were originally editing /opt/retropie/emulators/retroarch/retroarch.cfg however it seems like we were editing the wrong directory…
    This is the correct directory:
    /opt/retropie/configs/all/retroarch.cfg
    These are the lines of code that we used:
    # Saves state.
    input_enable_hotkey = q
    input_save_state = x
    # Loads state.
    input_load_state = z

    My Super Pi Boy project is now complete!
    Also, make sure that you uncomment the input_load_state = z line.

    Thank you so very much Floob for helping me with this issue. I hope that this post will help everyone who needs to overcome this problem.

    Thanks again,
    Josh

    Floob
    Member
    Post count: 1629

    This line should only exist once in the whole file
    input_enable_hotkey = rshift

    Can you post your retroarch.cfg to pastebin.com and I’ll check it.

    If possible, can you tell me what keyboard keys each of your buttons map to?

    josh
    Participant
    Post count: 4

    Hi Floob,
    Thanks for the quick reply! I have tried this for save but it appears that just RShift alone (Select Button) saves the game and when I used the same code to load the game (changing x to z) nothing happens. No hotkeys are mapped to X however, because we are using the Gameboy buttons, it is not possible to create a dedicated save and load button and all of the buttons are used. Start + Select work fine to exit a game. However, Select (RShift) and A (Z) together don’t work to load the game at all.
    Here’s the code:
    # Saves state.
    input_save_state = x
    input_enable_hotkey = rshift
    # Loads state
    input_load_state = z
    input_enable_hotkey = rshift

    Thanks again,
    Josh

    Floob
    Member
    Post count: 1629

    The lines you edited above can only have a single key.

    The hotkey enable would be here:
    input_enable_hotkey =

    So you hold your enable hotkey down then tap the hotkey

    input_save_state = x
    input_enable_hotkey = rshift

    would mean holding Right Shift and tapping x would save the game, assuming no other hotkeys or functions are mapped to x.

    josh
    Participant
    Post count: 4

    Using a Save and Load Hotkey
    I have looked up many sources but simply cannot find the answer to my question.
    How can I set up a Save and Load Hotkey using Keyboard Input?
    I know how I might be able to use this with a controller but don’t know how to do it with a keyboard. I am making a product much like the PiGRRL and I am using Adafruit’s Retro Game program to convert the GPIO signals to Keyboard Input. This all works fine for games but I simply can’t get it to work with keyboard hotkeys.
    I tried changing these lines:
    # Saves state.
    #input_save_state = x
    # Loads state.
    #input_load_state = z
    to
    # Saves state.
    input_save_state = x + rshift
    # Loads state.
    input_load_state = z + rshift
    This did not seem to work however. I would be very grateful for a response and will mention the name of who replied in an upcoming blog on how I made my Super Pi Boy…

    Thanks again,
    Josh

    stahl80
    Participant
    Post count: 5

    Hi!

    just installed a bluetoothmodule and dual 8bitdo NES30pro controllers.
    Got the bluetooth part working quick thanks to all the available guides.
    Using one controller works perfect. But when connecting the other for two player games thing starting to act weird. The games works but trying to exit an emulator with my default hotkeys select+start suddenly stopped working. tried on both controllers, one time it worked but then nothing. rebooting and with just one bluetooth controller on everything os fine agin.

    Mostly i followed this guide, https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-up-a-Bluetooth-controller.

    In this step i added the second controller also:
    Edit this startup file
    sudo nano /etc/rc.local
    above the line “exit 0” add
    bluez-test-input connect XX:XX:XX:XX:XX:XX
    bluez-test-input connect “second-controller”

    Did i miss something or to i have to make additional editing for the hotkeys or something?

    grateful for any help!

    Anonymous
    Inactive
    Post count: 2

    Hello Steve,

    I’am Jorrit from Holland and im using youre dualboot image V8 for Raspberry pi. Im new with the raspberri and i have some questions. I hope you dont mind..

    I want to change the “gpu_mem=100 to 128. Normaly you can change this in Open/boot/config.txt. But i cant find it in your image. Can you tell me where i can find it? I also ant to overclock my rasp, i think that this setting is also in boot/config.txt.

    In Retro pi/emulationstation i use an old xboxcontroller. I want to exit the games with a hotkey. So i added this line in retroarch.cfg:

    input_enable_hotkey_btn = 8
    input_exit_emulator_btn = 9

    now you should exit the game with select/start button. It worked for me for 1 time, but after a reboot, i could not exit the games anymore. Do you know if there is more i have to configure to make this possible?

    I hope you can help me. Thanks for the nice build you made!
    I hope to hear from you.

    grz joergan

    SwissPi
    Participant
    Post count: 5

    Sometimes a running Programm can takeover all keys, then the hotkey cannot reach the Emulator System. I want to avoid this by using a Port of the Raspberry GPIO Header, an attached Button shall stop the Emulator System (and it will restart in 5 Seconds), it works to trigger the reboot Sequence, now I’m looking for an interface to the Emulator System, a “killall emulationstation” does not work well :-(

    flourpowder
    Participant
    Post count: 19

    I would like to set all my emulators to be that hitting the guide button exits the emulator, no button combo for it. But I also want to keep the hotkey buttons so I can open the RGUI, save states, etc. Is there a way to set it so the enable hotkey button is set to two buttons? So, I would have it equal button 8 as well as the exit button to 8 (which I currently have set up) but also button 6 is enable hotkey? I have tried ‘6/8’, ‘6,8’, and two separate enable hotkey lines for each number in the /configs/all/retroarch.cfg file. Anyway to do this?

    fastfalcon94
    Participant
    Post count: 3

    Glad it helped you. My buttons on the 360 controller do the same thing. I just know not to touch them. You may be able to modify the config file in the /nes/retroarch-joypads folder and set the Y and B buttons on the controller to blank (“”). You wouldn’t want to do this for any of the hotkey buttons though. SO right elbow/left elbow which are used to “save” and “load” states. Don’t wipe those out.

    side note: I just bought some nes usb controllers off ebay. I configured one and it created a usbgamepad.cfg file. I only set the up/down/left/right/a/b/select/start buttons and left the rest blank (by holding a button to skip the button assignment). The nes controllers work great now that I copied the usbgamepad.cfg into /nes/retroarch-joypads folder. So now that the nes controllers work I probably won’t be using the xbox one for nes games. The controllers do feel too light though. I’m going to open them up and hot glue some washers inside to make them feel more like original.

    minimonk347
    Participant
    Post count: 13

    I’m sorry, and kind of bummed out, that no one has responded to your post, because I am having a similar problem; some psx roms respond to input, and some don’t, aside from hotkey commands. I haven’t tried removing the bios because those games worked just fine at one point with it, then they just stopped responding.

    I found my problem reported on Github about 6 months ago, a few months before it happened to me, and have recently posted on there, but it seems that no progress has been made on it. I am sure you have moved on from it, but in case you haven’t, I’ll post the link.

    https://github.com/RetroPie/RetroPie-Setup/issues/867

    giangi72
    Participant
    Post count: 6

    Yes, hotkeys are possible but
    – when I press Save/Load I have to choose the slot but only using the controller it is not possible.
    – if I press the hotkey for coin nothing happen, but if I press the exit hotkey and then the Continue option a coin is inserted

    herbfargus
    Member
    Post count: 1858

    I can’t remember, but I think it may be possible to do button combinations, if not you may just need to have a controller with enough extra buttons to be your dedicated hotkeys for saving, exiting etc.

    I honestly haven’t touched mame in months so take my advice with a grain of salt

    Floob
    Member
    Post count: 1629

    Your controller file with the hotkeys set, for retroarch emulators, should be in
    /opt/retropie/configs/all/retroarch-joypads/

    herbfargus
    Member
    Post count: 1858

    Please use pastebin for large config files, it keeps the forum cleaner and easier to read.

    As far as your hotkey predicament advmame and mame4all are not libretro cores (i.e. they don’t have a retroarch config file and thus dont follow the same hotkey configurations)

    Use tab on a keyboard to configure controls.

    It’s in the documentation:
    https://github.com/RetroPie/RetroPie-Setup/wiki/mame

    giangi72
    Participant
    Post count: 6

    Hi all,
    I’m new in this forum but I think I have read quite everything about hotkeys and mame emulators.
    I did some tests using:
    – Raspberry Pi B+
    – RetroPie 3.2.1 built from SD Image
    – 2 x SNES USB controllers https://cloud.githubusercontent.com/assets/10035308/7110174/0f2fdb54-e16a-11e4-8f3d-37bdca8f1ddf.png

    I tested
    – advmame 0.94 hotkeys no working
    – advmame 1.2 hotkeys no working
    – advmame 1.4 hotkeys no working
    – libreto hotkeys working but annoying copyright message asking for OK click (simulated using Left+Right click)
    – mame4all hotkeys no working
    – lr-imame4all hotkeys working, (temporary installed) keyboard not working but annoying copyright message asking for Left+Right click and after another message (CPU, screen resolution, …) asking for any key pressing

    So,
    – the best working solution seems to be the libreto emulator but the copyright message could be very annoying for my children (the final users of my system).
    – the best NOT working solution seems to be the advmame or mame4all

    So my questions are:
    1) is it possible to let the hotkeys working in advmame or mame4all emulators?
    2) otherwise, is it possible to get rid of copyright message in libreto or lr-imame4all emulators?

    Many thanks in advance for your help.
    Giangi

    My retroarch.cfg file is http://pastebin.com/raw/NSPkGRem

    My USBgamepad.cfg file is

    input_device = "USB gamepad           "
    input_driver = "udev"
    input_r_btn = "5"
    input_save_state_btn = "5"
    input_start_btn = "9"
    input_exit_emulator_btn = "9"
    input_l_btn = "4"
    input_load_state_btn = "4"
    input_up_axis = "-1"
    input_a_btn = "1"
    input_b_btn = "2"
    input_reset_btn = "2"
    input_down_axis = "+1"
    input_right_axis = "+0"
    input_state_slot_increase_axis = "+0"
    input_x_btn = "0"
    input_menu_toggle_btn = "0"
    input_select_btn = "8"
    input_enable_hotkey_btn = "8"
    input_y_btn = "3"
    input_left_axis = "-0"
    input_state_slot_decrease_axis = "-0"
    

    In each emulator’s folder I have a retroarch.cfg file like this

    # Settings made here will only override settings in the global retroarch.cfg if placed above the #include line
    
    input_remapping_directory = /opt/retropie/configs/mame-advmame/
    input_enable_hotkey_btn = "8"
    
    #include "/opt/retropie/configs/all/retroarch.cfg"
    
    tossy
    Participant
    Post count: 9

    [quote=111570]Any help to make the L and R buttons as hotkeys, for instance, save and load save games?

    [/quote]

    For me with my SNES30, R-Select and L-Select work fine, but I have to press R or L first. Pressing Select first doesn’t work.

    Omnija
    Participant
    Post count: 155

    These hotkeys

    input_enable_hotkey_btn = 8
    input_exit_emulator_btn = 9

    are only usable for retroarch emulators, all other emulators such as vice,dosbox,n64 (etc) have other methods or quitting/stopping emulators.

    I’m also assuming the capital resetting you are pulling the plug? You could always ssh and send a reboot command to not short circuit it.

    If using a keyboard backspace and enter are can quit retroarch emulators or in some cases esc.

    alexxx
    Participant
    Post count: 5

    Hi!
    I just installed it on top of raspbian,
    but I have a huge problem: everything works ok, but I’m completely unable to exit from whichever rom I’m using (tested up to now with c64 and zx) – without RESETTING completely my raspberry – my sd card is crying…

    I checked the /opt/retropie/configs/all/retroarch.cfg file, and I have the lines:
    input_enable_hotkey_btn = 8
    input_exit_emulator_btn = 9
    that should allow me to exit by select+start…

    (BTW, in half of the ‘net those are mentioned as “8” and “9” … anyway I tested both with and without doublequotes – no difference)

    Possibly it’s due to the fact that my controller is simply the keyboard?
    I mapped start to enter, and select to rshift …

    Any help will be deeply appreciated by my SD card !!!

    alessandro

    fastfalcon94
    Participant
    Post count: 3

    The problem is a lot of the information and youtube videos on controller configs are dated. Everything seems to work differently in 3.3. This is the best thing you can do for setting up a pi…

    1. grab the 3.3 flash and start with that
    2. On first startup don’t have your controller plugged in, just use a keyboard. emulstation will want you to configure it which is fine. You really only need to input the up/down/left/right a and b buttons. skip the rest
    3. Then go the retroarch emulator and into the settings. Here you can enable the xbox 360 driver. Now shut it down and plug in the controller
    4. When it restarts all the xbox lights in the center should be blinking until ES loads. Then it will show one light. Go into the controller config from the start menu and go through the button presses.
    5. At this point the controller should be usable but you should take it a step further…

    6. Using winscp go to /opt/retropie/configs/all/retroarch-joypads. You should see an XboxGamepad(userspacedriver).cfg file. This was created when you installed the 360 driver. The buttons in this file were programmed in step 4. You can see what they are mapped to. But it’s not going to be obvious to you that input_r3_btn = “12” is the right joystick being pressed down or that input_r_btn = “5” is the right elbow button above the trigger. So let’s fix that.

    7. Keep the config file open in winscp. On the keyboard plugged into the pi press f4 and then any key to go to the command prompt. go to root directory and into /dev/input. You should see a js0 or js1 or js2 or js3 depending on where your controller is plugged into. Type in: jstest js1
    Now press some buttons on the controller. Do you see anything going from off to on? If not ctrl+c and try a different joypad (ex jstest js2). You are trying to find the right js number for your pad. Once you find it you can go through the mappings. For instance you press the right elbow button on the controller and you see 5: off go to 5: on. Now in your config file you can put a comment next to that line.

    input_r_btn = “5” #Right elbow button

    For the analog thumbsticks those are a little confusing at first. For instance the right thumbstick, move it to the right. You will see a big number on the screen like 2: 32342343. Now move it to the left and you’ll see a big negative number like 2:-34324322 This means that +2 is the right thumb stick moved to the right and that -2 is the right thumbstick moved to the left. Now go put the comments in your config file. You can re-arrange the buttons in the config file to so that they are grouped together to make more sense. As you comment the file, you’ll end up with stuff you don’t have a button for. These are hotkeys. You can put these at the bottom. Here is my config file all commented and organized:

    input_device = “Xbox Gamepad (userspace driver)”
    input_driver = “udev”
    input_r_x_plus_axis = “+2” #Right Thumb Right
    input_r_x_minus_axis = “-2” #Right Thumb left
    input_r_y_minus_axis = “-3” #Right Thumb down
    input_r_y_plus_axis = “+3” #Right Thumb up

    input_l_y_plus_axis = “+1” #Left Thumb up
    input_l_y_minus_axis = “-1” #Left Thumb down
    input_l_x_minus_axis = “-0” #Left Thumb Left
    input_l_x_plus_axis = “+0” #Left Thumb right

    input_up_btn = “h0up” #Dpad up
    input_left_btn = “h0left”#Dpad left
    input_down_btn = “h0down” #Dpad down
    input_right_btn = “h0right” #Dpad right
    input_l2_btn = “6” #Left Trigger
    input_r2_btn = “7” #Right Trigger
    input_r3_btn = “12” #Right Thumb down
    input_l3_btn = “11” #Left Thumb down
    input_r_btn = “5” #Right elbow button
    input_l_btn = “4” #Left elbow button
    input_select_btn = “8” #select button
    input_start_btn = “9” #Start button
    input_a_btn = “0” #A button on controller
    input_b_btn = “1” #B button on controller
    input_y_btn = “3” #Y button on controller
    input_x_btn = “2” #X button on controller

    #hotkey stuff
    input_enable_hotkey_btn = “8”
    input_save_state_btn = “5”
    input_exit_emulator_btn = “9”
    input_load_state_btn = “4”
    input_reset_btn = “0”
    input_menu_toggle_btn = “3”
    input_state_slot_decrease_btn = “h0left”
    input_state_slot_increase_btn = “h0right”

    8. So now this works great. But in the nes emulator you are trying to play mario and the A/B button seems reversed because on the nes controller B is to the left of the A button, but on the 360 controller B is to the right of the A button. It would be better if these could be reversed for just the nes emulator. Even better the X button seems more natural to push as B. So let’s make the X button on the 360 controller equivalent to the B button on the nes controller. The A button can stay the same.

    You would think you just have to copy/paste/change the button config into /opt/retropie/configs/nes/retroarch.cfg. But that would be wrong. You have to mimic how it works in the configs/all directory.

    So go to /opt/retropie/configs/nes and create a “retroarch-joypads” folder. Now copy the “XboxGamepad(userspacedriver).cfg file from /opt/retropie/configs/all/retroarch-joypads and place it into the folder you just created. Now open the file and swap the number values between B and X. This will be easy as you’ve already commented every button and know exactly what they are. I like to expand on the comment if it’s custom so that if I open it up later I’ll know what I did).

    input_a_btn = “0” #A button on controller
    input_b_btn = “2” #B button on controller (Swapped with x button)
    input_y_btn = “3” #Y button on controller
    input_x_btn = “1” #X button on controller (swapped with b button)

    Now save this config file. Now we need to tell the nes emulator to use this file instead of the one in the all directory. Open up /opt/retropie/configs/nes/retroarch.cfg. Add this line above the bottom #include. When the nes emulator starts it will look at joypads specifically configured for the nes before checking the all directory. Since it’s a first fine/first use logic, it will use the config you just customized.

    joypad_autoconfig_dir = /opt/retropie/configs/nes/retroarch-joypads/

    9. Go enjoy mario. You may also need to repeat this process for other nintendo systems like super nintendo or gameboy.

    This is as far as I’ve got so far. I haven’t dealt with multiple controllers yet. I have some usb nes and usb snes controllers coming next week that I’ll be playing with. I’m hoping I can get it so that I can unplug/plug in new controllers for different emulators and it will just work. In an ideal world I could have 20 controllers plugged in and the emulator would just know what ones to use based on what one I opened the game with. Or have a little screen that says “press any key on the controller you want to use”

    flourpowder
    Participant
    Post count: 19

    N64: (1) No matter how hard I try, I can’t seem to get the right settings to open the RGUI in game to set the controls using this. I have it so I can close the game using the hotkey, but I’m not sure what I am missing/need to be able to open this. The controls are slightly off after ES default config and I would like to fix it using that like all the others. Pretty much resolved, needed to edit both the mupen64plus.cfg and InputAutoCfg.ini files together to fix controller issues, no luck on RGUI to open, but this works for now

    (2) Also, I will file this under the N64 header only because that’s where the issue arises. I only have two controllers plugged in at most, but the “Configure Input” in ES says there are three gamepads detected. Most likely due to the USB keyboard I have hooked up from time to time. Even when only one controller is hooked up though, it says there are three detected. The issue comes up when trying to play Star Fox 64. It auto detects how many controllers are hooked up and sets that as the amount of players playing. How do I disconnect the third controller, or at least disable it if it isn’t plugged in? Resolved. Issue was my keyboard was considered a “plugged in controller” since n64 auto detects those. Once I set it so it was false for “plugged in”, this was resolved.

    Dreamcast/Reicast: (1) I also can’t get the RGUI to pop up for this one, but I’m pretty sure it’s because I haven’t put it in the config file, not sure what needs to go in there. But there was an earlier post on here that helped me get it so my controls worked for the dreamcast, using the HEX value for the buttons, however, the exit button that’s default should be select. I tried the 0x13a and 0x137, both do not work for me. In fact, it seems that a lot of my controls don’t work. Resolved. Source based installation of reicast, retyped in the hex values with select/quit being 0x13a and it works now.

    I am still fairly new to all this, so, I apologize if this is simple stuff. I have searched and tried A LOT of stuff and none of it has worked thus far. I can post whatever is needed, but I’m also not sure the best way to do that besides copy and paste…

    Thanks in advance for any assistance.

Viewing 35 results - 106 through 140 (of 1,077 total)