Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • baxtex
    Participant
    Post count: 10

    So i recently installed Retropie and got it working with my 360 controllers. I love it. Especially that I have assigned a hotkey enabler when pressing select. Then I assigned 2 buttons, one for saving and one for loading. This works fine for the SNES games that I play the most, but it does not work for any of my other two emulators, NES and Mega drive. Whenever I try to save or load I get a message saying that it could not find the file. for example: “Failed to save/load state from /home/RetroPie/roms/nes/best roms/batman.state The other emulators get the command that I want to save or load so the hotkeys are working. Anyone know of a fix? I’ve tried setting the persmission to read and write with this command: sudo chmod 777 /home/pi/RetroPie/roms but that did not change anything.

    Would appreciate some help regarding this matter, I’m quite new with the Raspberry and Linux in general.

    adid4s
    Participant
    Post count: 94

    Are your roms running from a usb?

    baxtex
    Participant
    Post count: 10

    [quote=113606]Are your roms running from a usb?

    [/quote]

    No, I got them in the roms folder on the SD Card.

    EDIT:

    I got it working, i’l post the solution here, perhaps it might help somebody else.

    I simply went into the Retropie setup and choose advanced and then choose fix permissions. Although I’m sure I’ve done it before but it was all that I needed to do.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.