Forum Replies Created

Viewing 35 posts - 1 through 35 (of 87 total)
  • Author
    Posts
  • meneerjansen
    Participant
    Post count: 97
    in reply to: Wi-fi on Pi3 #122514

    [quote=122507]Well, it’s back to not connecting again. I’m not sure what the deal is but perhaps the Wi-Fi is just spotty on the pi3 with Retropie and I’ll have to wait for more updates. Bummer, but I’ll just have to tether for now.

    P.S. I’m on channel 6…
    [/quote]
    I don’t know how the experiences from other users are, but I find the Pi is underpowered, no matter what power adapter I use. When I use a WiFi dongle it disconnects all the time. The connectiosn via WiFi is quirky. I was hoping this was different for the Pi3 with its on-board WiFi chip.

    If I were you I’d consult a Raspb. Pi forum or try the best power adapter (some adapters say they are 2.1 Ampere, but hey appear not to be) you can find, and connect almost nothing to your Pi’s USB ports.

    Or do the middle ages thing…: connect an UTP cable…

    meneerjansen
    Participant
    Post count: 97
    in reply to: Wi-fi on Pi3 #122498

    That good news! And interesting to know for other Pi3 users that one had better set the WiFi chip’s power management off for optimal results.

    In my experience you preferably connect via SSH to a Linux machine by using its IP address. Using its hostname (i.e. ‘retropie’) doesn’t work as well. If your Linux machine (i.e. the Pi) is connected to a network then determine its IP address w/:

    ifconfig
    Then, in Windows, use Putty to connect to the Pi. When one uses Linux and a terminal do:

    ssh pi@192.168.0.xxx
    where 192.168.0.xxx is the Pi’s IP address. If all is well you will be asked for the Pi’s password which is “raspberry”. Dunno exactly haw that works in Windows/Putty.

    Good luck!

    meneerjansen
    Participant
    Post count: 97
    in reply to: Wi-fi on Pi3 #122460

    [quote=122456]

    I wouldn’t fiddle w/ that. It sets your locales for currency, language, time and date format, etc. That too is better set via the wizard in RetroPie.

    I’d say, fiddle all you want, that’s what the Pi is for IMO. The entry in rc.local is indeed to make it stick. You should try it from the command line first, to see if this solves your issue.

    [/quote]
    Off course. The Pi’s for fiddling. However, I always try to solve one problem at the time. The locale has nothing tot do w/ WiFi AFAIK.

    meneerjansen
    Participant
    Post count: 97
    in reply to: Wi-fi on Pi3 #122454

    [quote=122451]What does the rc.locale thing do? Is that so that when I reboot it keeps that setting? I’m guessing that power setting is temporary if I run it from the command line…

    [/quote]
    I wouldn’t fiddle w/ that. It sets your locales for currency, language, time and date format, etc. That too is better set via the wizard in RetroPie.

    If I were you I’d place my Pi next to my router, set the channel not to 11 (as advised by someone else) and run the blue MS-DOS like wizard. To test if it all works. Then go further from that. Good luck :)

    meneerjansen
    Participant
    Post count: 97

    This thing is GREAT! where did you buy the joysticks and buttons?

    meneerjansen
    Participant
    Post count: 97
    in reply to: Wi-fi on Pi3 #122374

    [quote=122286]Why is only my neighbor’s endpoint showing up?
    [/quote]
    Maybe because his wireless signal is stronger. The blue MS-DOS like wizard should work, and considering that it lists SSID’s proves that is does. I wouldn’t mess around on the command line if I were you.

    Try to move your Pi around and seee if you router shows up. BTW, if your router’s SSID is hidden then you’ve set that. Un-set it.

    Good luck :)

    meneerjansen
    Participant
    Post count: 97

    [quote=122296]Thanks again, but I already tried removing sixad as mentioned in my original post.

    I just tried it again, but it makes no difference in the behavior of Register and Connect, I just get the blinking cursor in the lower left and nothing happens. I waited a good five minutes just to see if anything would happen.

    To describe what I did, I ran
    sudo apt-get --purge remove sixad

    Then I ran set-up, Updated scripts, rebooted, and went back Register and Connect Bluetooth Device, and it’s still not doing anything.

    Also tested “bluetoothctl” again after removing sixad, and it made no change there either. Still behaves as described in OP.

    Still wondering if anyone can solve this, or tell me if it’s time to reinstall retroPie or update to most recent version (I have no idea if that would help or just complicate things further). Would really like to get this 8bitdo controller working.

    [/quote]
    Again, I’m awfully sorry for not reading the OP well enough. It might be better to re-install RetroPie all together. Do you have a spare SD card on which you can install a fresh RetroPie?

    In the troubleshooting section of the mentioned RetroPie Wiki there are some more tips on the 8bitdo SFC30 controller (press Start + R; remove and add device in bluez). You might try them?

    meneerjansen
    Participant
    Post count: 97

    [quote=122239]Pressing the button on the bluetooth device does nothing.
    I can see the bluetooth device paired with name “gamepad” inside the retropie configuration script.
    In shell I can see the j0 in /dev/input/.
    [/quote]
    My tips and questions:

    Install the package ‘joystick’ w/ the Linux command on the command line:

    sudo apt-get install joystick
    Now test your joystick(s) w/:

    jstest /dev/input/js0
    And press some buttons on the controller. You should see some reaction. Remember: if you’ve got more than one controller the bluetooth controller may be js1 or js2.

    If ‘jstest’ proves that the output of the BT controller is actually received by the Pi then register the controller in Emulationstation w/ the procedure I described above. Realize that a BT connection my be quirky. Sometimes a BT connection stops and starts in my experience.

    meneerjansen
    Participant
    Post count: 97

    If your controller is paired then you might be able to configure it “the regular way”:

    – Make sure you’ve got a keyboard or controller connected that Retropie “has recognized”
    – Press: “Start” (or Enter on the keyboard if that’s configured to work as a controller)
    – Go to: “Configure input > press “A” on the controller (or X on a keyboard)”.
    – Follow instructions on screen, i.e. hold a button on the BT controller to configure it.
    – If RetroPie does nothing after pressing a button on your controller then it might not be not be registered as a controller or input device via bluetooth.

    meneerjansen
    Participant
    Post count: 97

    I configured a keyboard to test bluetoothctl and it reconnects at boot. See for instance this topic. Summary:

    1. bluetootlctl
    2. agent on
    3. devices
    4. pair 11:22:33:AA:BB:CC
    5. Enter PIN
    6. trust 11:22:33:AA:BB:CC
    7. connect 11:22:33:AA:BB:CC
    meneerjansen
    Participant
    Post count: 97

    [quote=122134]Thanks so much for trying to help. As stated in my original post, I have tried bluetoothctl, but it doesn’t seem to be working as it’s supposed to.

    I get the [bluetooth]# prompt, but it’s not blue even when my device is in pairing mode, and I can’t type anything at the prompt. There is a flashing cursor, but typing does nothing. I can only type command C to restore the command line.

    Hopefully somebody can find a clue in all of this. Again, my BT dongle does work, and I have a PS3 controller working just fine via BT. However, I’m trying to connect an 8bitdo controller and my system’s Register and Connect is not working (as described in OP), and I can’t utilize bluetoothctl as described here and in the OP.
    [/quote]
    Aha. I didn’t read your top post well enough. Anyway, I just couldn’t understand why bluetoothctl won’t respond. And then I read the RetroPie site you mentioned on ‘Setting up a bluetooth controller‘. And lo and behold. Scoll down that page to the section “Troubleshooting”. And indeed, the software needed to get the PS3 controler working is messing up the “standard” bluetooth Linux utilities (or drivers?).

    Your problem is “sixad” which is needed to get the PS3 controller working. For all it$ money the PS3 controller is probably not stadard BT compliant (why would it need special software then). Unfortunately you have to choose between the PS3 controller or other BT devices. The following is said to solve tour BT probs but disabled the PS3 controller:

    sudo apt-get --purge remove sixad
    

    Good luck! :)

    P.S. Wanna have an extra controller w/ some more buttons and sticks other than your SNES30 8bitdo? I know it aint no PS3 controller but its cheap and works without drivers. The Thrustmaster T Wireless. See for instance Amazon.co.uk.

    meneerjansen
    Participant
    Post count: 97

    [quote=122034]Thanks for the reply. I’m running into a problem with this method.

    I ran sudo apt-get install bluez and rebooted.

    Upon reboot, I found the address of my BT dongle and of my controller as you indicated.

    But when I attempt to run bluez-simple-agent hci0 AA:BB:CC:00:11:22 (where the address is what returned for my gamepad) I get -bash: bluez-simple-agent: command not found

    Any advice?
    [/quote]
    Bluez is a very quirky indeed.

    Some Linux talk now (sorry). My tutorial is so old that it only works for Bluez 4. Ubuntu 14.04 “Trusty Thar” (and Linux Mint) still use Bluez 4. Ubuntu and Mint are based on GNU Linux Debian. But the Debian 8 (code name “Jessie”) version that is on my Pi (i.e. Raspbian) already uses Bluez 5. In Bluez 5 things work radically different. The application ‘bluez-simple-agent’ and other utilities that I referred to in my HowTo do not exist any more and are replaced by ‘bluetoothctl’.

    My new personal HowTo:

    ____________________________________________________________________
    o=========o
    – Bluez 5 –
    o=========o
    Ubuntu 14.04 still uses Bluez 4 (see below). Debian 8 ‘Jessie’ uses ver. 5.

    1. Use the utility ‘bluetoothctl’ for everything. Once this program is started then it changes your prompt to:

    [bluetooth]#

    2. If it “sees” a BT controller or device then the prompt is blue. Type “help” for a list of commands.

    4. Get MAC address of bluetooth keyboard or other device. Set your device in pairing mode (!) and type:

    devices

    Example of output:

    Device 11:22:33:AA:BB:CC Bluetooth 3.0 Keyboard

    Tip: put dongle in device discovery mode with “scan on” command if device is not yet on the list.

    5. Set “agent on”!

    6. Type “pair 11:22:33:AA:BB:CC” (TAB completion works).

    7. If you’ve set the agent on then it should ask you to type a PIN code on the keyboard and to press enter on it afterwards.

    8. Then trust, connect etc.

    9. Type “quit”. Your keyboard should be connected now.

    10. I don’t know how or why, but its autoconnected at boot. If not, check the references.

    11. Troubleshooting:
    – To list BT dongles and their MAC address type “list” (not necessary if you’ve got only one). Example of output:
    [bluetooth]# list
    Controller XX:YY:ZZ:11:22:33 raspberrypi [default]
    – Set your dongle on w/: “power on”.

    12. References:
    [1] https://wiki.archlinux.org/index.php/bluetooth#Bluetoothctl

    [2] https://wiki.archlinux.org/index.php/bluetooth_keyboard
    ______________________________________________________________________

    Good luck :)

    P.S. To make things more complicated: in my RetroPie installation the old Bluez 4 scripts still exist. There are in:

    ‘/home/pi/RetroPie-Setup/scriptmodules/supplementary/bluetooth/’
    I don’t know if they are still functional, but I think they are not there for nothing.

    meneerjansen
    Participant
    Post count: 97

    P.S. You can install hcitool etc. by installing the package ‘bluez’:

    
    sudo apt-get install bluez
    meneerjansen
    Participant
    Post count: 97

    I don’t like to configure BT viathe command line but if I really have to I follow this HowTo that I wrote. Good luck! :)

    o================o
    | – Bluetooth – |
    o================o
    At the time of writing (dec. 2013) Bluetooth in Linux is a mess. Bluez 5.5 seems to have solved the probs, but Debian Stable (7.0, Wheezy) still uses version 4.

    List bluetooth dongles:

    hcitool dev

    Example of output:

    hci0 AA:BB:CC:00:11:22

    Get MAC address of bluetooth keyboard or other device. Set device in pairing mode!:

    hcitool scan

    Example of output:

    Scanning …
    AA:BB:CC:00:11:22 Wireless Keyboard

    Pair said device:

    bluez-simple-agent hci0 AA:BB:CC:00:11:22

    It will ask for a confirmation code to be made up by you (I’d choose 0000). Then you must type it in on the on the BT-keyboard and press Enter. Sometimes the standard code used is 0000.

    If the following error code is returned then you’ve already successfully paired said device:

    Connecting device failed: org.bluez.Error.AlreadyExists: Already Exists

    Trust device:

    bluez-test-device trusted AA:BB:CC:00:11:22 yes

    Connect device (this is where it always goes wrong!!!):

    bluez-test-input connect AA:BB:CC:00:11:22 yes

    Example of connect errors:

    org.bluez.Error.Failed Connection refused (111)
    org.bluez.Error.ConnectionAttemptFailed: Host is down (112)

    And then what???

    o=======================o
    | – Trouble shooting – |
    o=======================o
    Restart bluetooth (choose the one that fits you system):

    su -c “service bluetooth restart” (Debian 7 Wheezy)
    sudo /etc/init.d/bluetooth restart (Ubuntu 10.04)

    Remove a paired device?

    bluez-simple-agent hci0 AA:BB:CC:00:11:22 remove

    In Ubuntu 10.04 the bluez Python scripts called ‘simple-agent’, ‘test-device’ etc. reside in (!!):

    /usr/share/doc/bluez/examples/simple-agent

    Error: “Creating device failed: org.bluez.Error.AlreadyExists: Bonding already exists”. Solve by: ??

    meneerjansen
    Participant
    Post count: 97

    [quote=121907]That almost worked, but when I get to the wizard it does not register the controller button as keyboard key
    [/quote]
    Try to test on the command line (press F4 and Enter) if the controller indeed behaves like a keyboard. Letters etc. should appear on the command line when you move the stick or press buttons. Return to Emulationstation by typing “emulationstation” on the command line and press Enter.

    If you’re absolutely definitely super duper sure the controller/keyboard actually does send output to the Pi then disconnect everything but the Neo Geo controller/keyboard (and a temporary USB controller to navigate through the Wizard). At first it didn’t work for the person either in the other topic because the Pi only reacted to the input of the “real” keyboard that was connected.

    If need be: reboot your Pi and make sure NO other keyboard is connected to the Pi.

    After setting up the Neo Geo X Arcade joysick make sure no other joysticks, controllers and what have you not are connected to play games.

    Good luck :)

    meneerjansen
    Participant
    Post count: 97

    The update thing might work best… Anyway, considering that you used “Method 2” from the Retropie Wifi Wiki you might also consider to reset the /etc/network/interfaces file to what I have and what works for me w/ Method 1 (i.e. use the dialog wizard from Retropie):

    auto lo
    iface lo inet loopback
    
    iface eth0 inet manual
    
    allow-hotplug wlan0
    iface wlan0 inet manual
        wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    
    allow-hotplug wlan1
    iface wlan1 inet manual
        wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    

    Good luck! :)

    meneerjansen
    Participant
    Post count: 97

    Wait a minute. Are we talking about the same controller as in this topic? If so it, indeed, “behaves” like a keyboard and not as a game controller. To use it do:

    Make sure no keyboard is connected to your Pi (other than the X Arcade Stick), connect a controller to navigate through RetroPie’s menus and:

    1. In RetroPie/Emulationstation go to: “RetroPie (the config menu) –> RetroPie setup –> Setup/configuration (to be used post install) –> Configure Retroarch controller –> Configure keyboard for use with RetroArch”.
    2. It should pop up a wizard that asks you to press keys on your keyboard (to use instead of a controller).
    3. Then press keys on your ‘AES stick’.

    Now remove the temporary controller and use the X Arcade Stick to play.

    meneerjansen
    Participant
    Post count: 97

    [quote=121780]Been trying to get this to work for about a year and like other have fond it seems to work like a keyboard. But how can we reverse this and actually use it.

    [/quote]
    Make sure no keyboard is connected to your Pi (other than the X Arcade Stick), connect a controller to navigate through RetroPie’s menus and:

    1. In RetroPie/Emulationstation go to: “RetroPie (the config menu) –> RetroPie setup –> Setup/configuration (to be used post install) –> Configure Retroarch controller –> Configure keyboard for use with RetroArch”.
    2. It should pop up a wizard that asks you to press keys on your keyboard (to use instead of a controller).
    3. Then press keys on your ‘AES stick’.

    Now remove the temporary controller and use the X Arcade Stick to play.

    meneerjansen
    Participant
    Post count: 97

    [quote=121674]Hi,

    I’ve gone through that Wiki page before and I had successfully set up the wireless connection. I was able to update the versions and get a load of roms on. It’s only after a few reboots and a few days passing, no wireless interface anymore.
    [/quote]
    Which of the 4 methods described there did you use?

    meneerjansen
    Participant
    Post count: 97
    in reply to: Spam #121694

    I got this spam mail too, of course. Didn’t know this topic existed. What I don’t get is why the mail itself got deleted in the (double) post that I created. Because now that e-mail can be used time in time again to fool poor people on the internet that actually believe this sort of nonsense to steel your money.

    I’d rather have all these pathetic standard mails published on the internet so their con cannot be used again. Realize that a con or magic trick only works if you’ve never seen it before.

    My apologies for the double post.

    meneerjansen
    Participant
    Post count: 97

    What you might try:

    In Emulationstation/RetroPie go to: Retropie (i.e. the setup menu) –> Configure WiWi –> choose ‘Connect to WiFi network’

    You’ve probably done that already and apparently it won’t work. Unfortunately for you is that this dialog screen already does “every Linux trick” in the book to connect.

    Since successfully connecting to your beloved Pi the first time: did you change something w/ regard to hardware? Like connecting other USB devices? An USB hub? In my experience WiFi can eat a lot of power and due to extra hardware your Pi might be under powered now.

    P.S. The way I force my Pi to connect to WiFi is:

    sudo ifconfig wlan0 up
    And then wait a minute.

    Check IP address and if your connection is up w/:

    ifconfig
    Good luck! :)

    P.S. Thanks to Buzz I corrected the typo in wlan0.

    meneerjansen
    Participant
    Post count: 97

    Managed to run it on Raspbian! My Pi runs Raspbian and I installed RetroPie on it via the script. These are my personal HowTo notes on Jedi Outcast and QJoypad:

    ______________________________________________________________________
    o============o
    | A. Summary |
    o============o
    This is a tutorial on how to play Star Wars Jedi Knight II – Jedi Outcast on the Raspberry Pi model B. It needs Rasbian and some incarnation of X (like the default LXDE desktop). In short one needs to:
    – download the Pi executable
    – install some packages on the Pi
    – create a folder on the Pi w/ the original game files
    – update to version 1.04 of the game (!)
    – config the Pi for sound to work in JK2

    o============o
    | B. Install |
    o============o
    1. Create a folder called, for instance, “JK2” on the Pi in your home dir.
    2. Copy the game files from the dir called “base” to it (from the CD-ROM or your Windows instalation). They are the files: assets0.pk3 and assets1.pk3.
    3. Update the game to version 1.04. If you do not do this then the game will NOT run. You need to download the executable “JKIIUp104.exe” (see ref. [3]). This can only be run if you’ve got the game installed in Windows or Wine.
    4. The 1.04 update will create two extra files you in the “base” dir on your hard disk (c:/program files/LucasArts/Star Wars JK II Jedi Outcast/GameDate/base/) called: assets2.pk3 and assets5.pk3. You need them!
    5. Download the executable and the library for the Pi from:

    http://www.allt2.se/henrik_e/sw/Outcast_Compiled.tar.gz

    Extract the library and the executable to the dir “JK2”. Overwrite or rename the Windows ececutable.

    6. Create the file:

    JK2/base/jk2config.cfg

    Put the following contents in it:

    seta s_UseOpenAL “1”

    You need this to get sound.

    7. Start an X session (if you aren’t in X already) by typing on the command line:

    startx

    8. Open a terminal cd to the JK2 dir and type:

    jk2sp

    9. The game should start now, with sound an all. If it doesn’t surf to ref. [1] follow all its instructions (install the openal packages and libs etc.) and pray it does work now.

    o======================o
    | C. Use of controller |
    o======================o
    JK2 does not support the use of a joystick or game controller in Linux (i.e. on the Pi). Use a little program called “qjoypad” to let your controller emulate the mouse and keyboard. See separate ‘Tips and Hints’ file for usage of QJoypad.

    o===============o
    | D. References |
    o===============o
    [1] Website of the port to Linux:
    https://github.com/xLAva/JediOutcastLinux

    [2] For the Raspberry Pi:
    https://m.reddit.com/r/raspberry_pi/comments/333722/jedi_knight_jedi_outcast_on_raspberry_pi_2/

    [3] Update to ver. 1.04 of JK2:
    http://help.starwars.com/articles/en_US/FAQ/Where-do-I-find-the-latest-patch-for-Jedi-Knight-II-Jedi-Outcast

    [4] Forum w/ the Pi executable and some info:
    https://www.raspberrypi.org/forums/viewtopic.php?f=78&t=50021&start=50
    __________________________________________________-

    And to map mouse and keyboard to your controller w/ QJoypad:

    ______________________________________________________________
    It’s old, runs in the system tray (which isn’t there anymore in modern Linux desktops), very vague to configure and isn’t maintained anymore. Especially since the documentation on its website isn’t all that great. But it does the job and is still in the standard repo’s.

    o===========o
    |A. General |
    o===========o
    1. Install: sudo apt-get install qjoypad

    2. To run type: qjoypad. Click “add” and add a new profile for your gamepad. I called mine “Thrustmaster”. Click on “update” to save your config.

    3. An icon should appear in the system tray. If it doesn’t one can run the program w/ the option “–notray”.

    4. Make sure your controller is recognized by Linux by installing the package “joystick” and run on the command line:

    jstest /dev/input/js0

    5. Click on the sys. tray icon. It’s dialog screen should pop up.

    6. A lot of ‘axis’ and ‘button’ setting buttons are shown. My Thrustmaster controller, for instance, has 6 axis. That’s because each of the three directional pads or sticks has two axis: X and Y (i.e. up/down is an axis and left/right is an axis).

    o==============o
    | B. The mouse |
    o==============o
    1. I want my right analog stick to act as the mouse (i.e. free look in an FPS). My right analog stick has two axis: axis 3 and 4 (i.e. up/down and left/right). Click on the button in QJoypad’s dialog called “Axis 3”. A new dialog window should pop up.

    2. In this dialog click on the word “keyboard” and change it into “mouse (horizontal)”. Move the analog stick from left to right a few times and notice that the indicators react to the movement of your stick!

    3. You might set some additional recommend settings. For instance: tick “gradient”, set “speed” from 100 to 10, set the gradient to “lineair” etc. Click “okay”.

    4. Click “Update” to save your config.

    o=================o
    | C. The keyboard |
    o=================o
    1. I want the D-pad of my controller to act like strafe and walk. In my favourite FPS (Jedi Outcast) these are standard mapped to W,S,A,D. The D-pad of my Thrustmaster controller is called “xis 5 and 6” in QJoypad

    2. Click on “Axis 5”. Check if the D-pad actually IS axis 5 & 6 by moving the D-pad around. The indicators on the left and right should red.

    3. Click the left button that says “[no key]”. Press the letter key “A”. Now the left side of the D-pad is mapped to the letter A, which is ‘strafe to the left’ in my favorite game.

    4. Do this for all buttons on your controller.

    o================o
    | D. Test it all |
    o================o
    1. Open a terminal window (or a text editor).

    2. Press some buttons and axis on your game controller. The letters that you mapped to your D-pad should appear (i.e. w,s, a and d) and the mouse pointer should move when you move the right analog stick.
    _________________________________________________________________

    Is it possible for the people that do not run RetroPie to install LXDE from the command line?

    meneerjansen
    Participant
    Post count: 97

    Tried to run the Linux executable of JK2 on my Linux PC. The game started but the graphics were all garbled. Ninety percent of the textures didn’t load. I saw only black, apart from the sky. So I’m curious how it’ll run on the Pi. Do we have to compile a version for each Pi model because they differ in platform?

    Sure hope this wil work. I love seeing how smooth Quake III runs on the Pi but I have no fun in playing it alone (against the computer). JK2 is a masterful single player game based on the same engine. I loved throwing stormtroopers around with the force push and force grip! It was tons of fun!

    meneerjansen
    Participant
    Post count: 97

    P.S. One last thing you might try: disconnect your keyboard and connect only the Neo Geo controller and a “real” USB controller. Reboot the Pi and operate the Pi w/ said controller. Then try to set up a keyboard again. Maybe the NeoGeo controller will be selected now…

    meneerjansen
    Participant
    Post count: 97

    [quote=121524] @meneerjansen Thank you for your time

    The Retroarch keyboard configuration doesnt detect my AES stick, only my wireless keyboard… [/quote]
    That is very unfortunate. Then it might behave like a mouse… Any way if you’re certain that it is detected by Linux (use ‘lsusb’) then my magician’s high hat is empty now.

    I’ve seen the controller you mention on Amazon and it is pretty amazing! Pity it don’t work in Linux. Good luck in finding another controller you like. :)

    meneerjansen
    Participant
    Post count: 97

    [quote=121506] @meneerjansen the manufacturer is TOMMO (last item):

    Exclusive Products

    <iframe class=”wp-embedded-content” sandbox=”allow-scripts” security=”restricted” src=”http://tommo.com/exclusive-products/embed/#?secret=IvXCJlDG3j&#8221; data-secret=”IvXCJlDG3j” width=”600″ height=”338″ title=”Embedded WordPress Post” frameborder=”0″ marginwidth=”0″ marginheight=”0″ scrolling=”no”></iframe>
    But I didnt see any driver support… Searching on Google, I didnt find any good answer to my problem.[/quote]

    See the “P.S.” which I wrote while you wrote your reply. I seems to me that the “manufacturer” of your “Neo Geo system” is victim of some “controversy” according to Wikipedia which probably means that there is no proper website of the manufacturer as it might be some sort of exotic piece of hardware that is no longer officially supported. Quote from Wiki:

    […] due to the low manufacturing standards employed by Tommo, in 2013 October, SNK [the company that made the “real” original Neo Geo] Playmore has publicly ordered Tommo to cease not only manufacture of the Neo Geo X, but to pull all existing stock from store shelves

    So accepting that it is barely supported and that it probably behaves like a keyboard and not like a game controller might be the best place to start to get this thing working.

    meneerjansen
    Participant
    Post count: 97

    [quote=121498]will need some[/quote]

    [quote=121498]Thank you again @meneerjansen

    I have installed the Joystick package, but i have the newest version. Then, with th jstest /dev/input/js0 command, I dont see my gamepad (when I connect the SNES USB Pad yes), but I dont have any error only the following message:

    jstest: No such file or directory

    Then, I think that I will need some driver…
    [/quote]
    The error message “No such file or directory” means that there is no “js0”, that is: there is no game controller detected. Indeed, this means that you need a driver specific for this controller. It may be already have been developed by the Linux community, it may have been released by the manufacturer of your controller. Which manufacturer is it, which type is it and what’s the support page of the manufacturer? Said Linux driver should be downloadable from there. If it’s not… Well, then I think it is marketed very much towards Windows or special (Windows) software that comes with the hardware.

    P.S. From the top post: in Windows, you (only) seem to be able to play games w/ your ‘AES stick’ from your ‘NeoGeo X Gold system’ w/ a piece of software called “Xpadder”. From the Xpadder website: “Xpadder allows you to map keyboard keys and mouse button actions to your game controller buttons”. This means that Windows does NOT recognize this controller as a game device (i.e. not as a joystick or controller) but as a keyboard. That’s a bummer. But, I can play games fairly well in Emulationstation w/ a keyboard. What you have to do to operate Emulationstation (and therefore your Pi) w/ a keyboard is:

    1. In RetroPie/Emulationstation go to: “RetroPie (the config menu) –> RetroPie setup –> Setup/configuration (to be used post install) –> Configure Retroarch controller –> Configure keyboarc for use with RetroArch”.
    2. It should pop up a wizard that asks you to press keys on your keyboard (to use instead of a controller).
    3. Then press keys on your ‘AES stick’. Realize that RetroPie probably “thinks” that your controller actually is a keyboard.

    Good luck :)

    meneerjansen
    Participant
    Post count: 97

    [quote=121457] @meneerjansen thank you!!!

    Here, people says that Win detects the stick as a POV switch instead of a X and Y axis.

    And here there are more info, but I dont undertand very well

    http://www.neo-geo.com/forums/showthread.php?259552-Neo-Geo-X-Controller-on-Raspberry-Pi&highlight=Raspberry
    [/quote]
    1. I’m fairly experienced Linux user but even I don’t get what some of the forum users are babbling about in the links you posted. They may not know what the hell they’re talking about or they’re simply not giving enough info.

    2. In one of the links somebody used the same test utility that I recommended.

    Remember: many controllers behave according to the harware USB standard set by engineers a and will be recognized by your operating system (Android, Linux, Windows, etc.) automatically! If your manufacturer did not abide to said standard it is a gamble if the controller will work or not. Microsoft Windows tends to come out of the box with some drivers for exotic hardware because Windows is so popular the the manufacturers make sure their stuff works, even though its exotic and weird.

    On Android, Linux or MacOS you might not be that lucky. And again: the ONLY one that knows is the manufacturer of your hardware! So check its forum or website to find out if it needs a special driver or not.

    In my experience it doesn’t matter if the controller says that it is a POV (one of my faux SNES USB controllers is like that). You can solve that w/ the controller config screen in RetroPie/Emulation station. What DOES matter is if Linux can “see” your controller and if it recognizes that it is a Game Controller. Again, test w/:

    jstest /dev/input/js0
    Additionally you might want to check if the controller is connected properly with the command:

    lsusb
    That will list all connected USB devices, if it has a driver loaded or not.

    Good luck :)

    meneerjansen
    Participant
    Post count: 97

    Thank you for your post/tutorial. I think that the Steam controller might become quite popular since Stream is big in game land. Good to know how to get it working.

    meneerjansen
    Participant
    Post count: 97

    If I were you I’d spend my time and energy on finding a good power supply first. Very strange inexplicable things happen on an under-powered Pi. I have some adapters that say “2 Ampère” but they don’t work w/ the Pi. Those USB power adapters are pretty cheap on DealExtreme etc. Buy another.

    Succes. :)

    meneerjansen
    Participant
    Post count: 97
    1. Can you provide us w/ a link to the website of the manufacturer and the support page of this particular stick?
    2. It is important that the stick’s hardware or chip sends a signal via USB “saying” to the operating system (i.e. Windows or Linux) that it actually is a joysick (as opposed to a keyboard, a mouse or …).

    If, and only if, this joystick “behaves” like any normal USB game device (i.e. does NOT need any special proprietary drivers to work (see website of manufacturer) then you can test on the Command Line Interface (CLI) of your Pi if it is detected. Do:

    1. Make sure you’ve connected only the joystick you want to test: directly to the Pi, not via an USB hub.
    2. Install the package ‘Joystick’ w/: “sudo apt-get install joystick”.
    3. Test joystick/determine numbers of your buttons etc.: jstest /dev/input/js0.

    If you do not see a lot of ‘axis’ and ‘button’ messages but an error message then your stick is not detected by Linux (RetroPie is a Linux application).

    If your joystick needs a driver (see website of manufacturer!!!) then you’d better pray that there is a Linux driver that is easily compiled from source code. The Pi runs an ARM platform and most computers are Intel/AMD based. So most “easy to install” drivers (read: pre-compiled binary drivers) are for that platform. However, sometimes a driver or special software does not need to be downloaded from the manufacturers website because the Linux community compiled a driver for it (open source driver or by reverse engineering etc. like the Soundblaster Live audio cards etc.). Then you might be able to install the necessary diver and utility w/ apt-get install driver_name_of_your_joystick. Anyway only the manufacturer can make things clear for us!!

    Succes. :)

    meneerjansen
    Participant
    Post count: 97

    This RetroPie webpage should explain how to setup controllers for the various SNES emulators. They appear not to have an “in game” menu (like Mame when you press TAB on the keyboard).

    If I were you I’d choose an emu that “obeys” the standard key mappings which on my Pi 1 are:

    
    ____________________________________
    Hotkeys        |  Action
    _______________|____________________
    Select+Start   | Exit  (avoid!)
    Select+B       | Reset (avoid!)
    Select+R2      | Save!
    Select+L2      | Load
    Select+Right   | State slot
                   |   increase
    Select+Left    | State slot
                   |    decrease
    Select+X       | Retroarch menu
    _______________|____________________

    Some emulators exit when I press ‘Start’ or don’t start at all w/ certain ROMs. I have to fiddle w/ emulators for each game. Select your emu of choice by pressing left/right a lot when the emu starts up. You see a dialog screen then which lets you select an emulator of choice.

    Good luck! :)

    meneerjansen
    Participant
    Post count: 97

    Thanks for the tip about JK2 running on the Pi!!! I loved that game. Considering the fact that ‘Quake III Arena’ runs amazingly perfect on the Pi 1 it wouldn’t surprise me if JK2 runs smooth as well. JK2 is based on the same engine as QIII.

    Anyway, I’ve got RetroPie installed via a script on top of Raspbian. So I can re-install the lightweight desktop, which I uninstalled, to test this. But I can’t find proper instructions on how to run JK2 on Linux and X.

    The reason that it won’t run without X is probably that it needs OpenGL for the 3D engine. What amazes me it how they’ve gotten QIII te work without an X environment! developed that? I don’t think the RetroPie guys did that…

    A shell script to start X, JK2 and to return to Emulationstation when you’re done playing JK2 shouldn’t be too hard to do I think. But using the executable that one made to play JK2 in an X environment can’t be used without X. I should be compiled the same way that they compiled the QIII executable. QIII did not have software rendering as an option anymore like QII had. So you need GL.

    meneerjansen
    Participant
    Post count: 97

    That’s strange. I have a Pi 1 so I can’t say that it’ll work on a Pi 3 but recently somebody else started a similar topic like yours (WiFi on Pi 3). Maybe there are some tips in that topic that’ll help you. Or maybe the Pi 3 needs some sort of update for the WiFi to work properly. See:

    http://www.petrockblock.com/forums/topic/i-have-given-up-with-file-transfering/#post-121065

    Succes. :)

    meneerjansen
    Participant
    Post count: 97

    May depend on the emulator you’re using to play (SNES?) games. In some emulators I still have to set up my controller via the setup menu of the emulator itself.

    Can you give an example of a game and emulator (read: console) that doesn’t work?

Viewing 35 posts - 1 through 35 (of 87 total)