Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • orgem
    Participant
    Post count: 2

    I swear I really, REALLY tried abolutely everything about it before even asking for help. I don’t know what to do about FTP that I haven’t done before, Samba-Shares also fails and USB works (roms transfering is perfect) but for the things I want to do (inserting BIOS and art boxes) USB transfering is not an option.

    -Im actually using Retropie 3.6 in Raspberry Pi 3.

    -This was the result of trying Shamba:

    -This was the result of trying FTP with WinSCP:

    It looks like the Raspberry is not connected to Wifi but…

    …it is. Because it clearly show it here. And the tutorial I was following said if both PC and Raspberry were connected to the same network would work (without the use of programs or installing anything on the Raspberry)

    I don’t know how to properly set Firewalls, making pings or things like that because im not into the computing thing, but ill try to make things step by step.

    Please help.

    darksavior
    Participant
    Post count: 27

    I transfer my files with an sftp program like flashfxp. winscp will work too i think.
    I need full write support so i login with root using the pi’s IP address along with login/password.
    If you want root, you’ll have to enable it and edit sshd_config to allow root.
    https://github.com/retropie/RetroPie-Setup/wiki/FAQ#why-cant-i-ssh-as-root-anymore

    I don’t use samba or network shares so I’m not sure about that.

    InsecureSpike
    Participant
    Post count: 571

    FileZilla is probably the easiest to set up, it’s available for both PC & Mac. get that the find a YouTube video to show you how to set it up and how to start moving files

    shoothere
    Participant
    Post count: 131

    I would totally second using Filezilla (you can find the IP adress in your retropie menu in emulationstation and log in with user: pi and password: raspberry).

    Much more reliable once the initial hurdle of finding out the IP is overcome.

    orgem
    Participant
    Post count: 2

    I don’t understand what Darksavior said because i don’t have any idea of using Raspberry commands to do things.

    To all you guys who recommended me Filezilla:

    This is the result using client and its the same with both protocols (FTP and SFTP). I even used Filezilla server in my desperation.

    I deleted everything and started from zero. I installed the retropie 3.6 img in my raspberry pi 3, connected to same Wi-Fi in raspberry and PC and installed diferent progams in the pc to transfer files, one by one. Filezilla dont connect, WinSCP dont connect.

    The same results happen if my Raspberry is off, so it looks its not connected to Wi-Fi, weird thing because I was able of downloading themes and look at the 3rd image, it’s already set. What im doing wrong?

    gamesfan
    Participant
    Post count: 29

    Use a cat5 cable, connect the RP3 right to your firewall.

    rdhanded2
    Participant
    Post count: 132

    did you try adding port 22?

    rdhanded2
    Participant
    Post count: 132

    Can you log in with putty? If so go to

    /etc/ssh/sshd_config

    sudo nano

    change the bottom to the following to allow access if you are blocked.

    # Authentication:
    LoginGraceTime 120
    #PermitRootLogin without-password
    PermitRootLogin yes
    StrictModes yes

    Also, I always add a root password by entering the following and typing a password

    sudo passwd root

    then when I use Filezilla I use root for username and the password I entered for full access.

    InsecureSpike
    Participant
    Post count: 571

    and, 192.168.1.129 is definitely the right IP address for your Pi?

    meneerjansen
    Participant
    Post count: 97

    I never transfer files to my Pi via WiFi. Its so slow and buggy that it’s practically unworkable. Take out the SD card and transfer files to it directly or connect your Pi to your network with an UTP cable.

    Succes! :)

    InsecureSpike
    Participant
    Post count: 571

    i use wifi and never had an issue

    senkun
    Participant
    Post count: 35

    [quote=120906]I swear I really, REALLY tried abolutely everything about it before even asking for help.

    -Im actually using Retropie 3.6 in Raspberry Pi 3.

    It looks like the Raspberry is not connected to Wifi but…

    …it is. Because it clearly show it here.
    [/quote]

    New install? Did you update Jessie after install? If not then your wifi connects but there’s a bug with power management that drops wifi after a couple of seconds. It will still show that you’re connected.

    More here:
    http://www.petrockblock.com/forums/topic/raspberry-pi-3-wifi-temporary-fix/#post-120408

    Before updating, try this quick fix and see if it works to get you connected. Open up terminal and type:

    sudo iwconfig wlan0 power off

    meneerjansen
    Participant
    Post count: 97

    Ooops. Just read that the topic starter has a Pi 3. That one has WiFi on chip. That should be a LOT better than the USB dongle I have in my Pi 1 and wrote about.

    Anyway after reading the first post there might be some other thing that you might try. I see that you are trying to connect to your Pi using the Pi’s “host name” which should be “retropie” according to you.

    1. I dunno how it’s on your Pi and your RetroPie version, but my Retropie hostname is ‘raspberrypi‘. You can see what the host name of a Linux machine is on the command line interface (CLI). Go to the CLI by pressing F4 in Emulation Station (that is, RetropPie). Then type the word “hostname” on the CLI and press Enter. It will echo the hostname of your machine. Or have a look at hte prompt of the CLI. You might notice that the prompt is of the format ‘user@hostname‘.
    2. You might want to connect to a Linux machine (RetroPie is Linux) using it’s IP address instead of its host name. In your case the IP address of your Pi is: 192.168.1.129
    3. Bear in mind that Linux (i.e. RetroPie) is very picky on which user can acces (that is, read or write to-) which folder. As far as I know you (that is: the user named “pi”) have only the rights to write files (that is, copy to) your home dir which is /home/pi.

    If your Pi has an IP address, in the WIFi dialog screen that you posted, then it is connected to your network. No need to reinstall RetroPi I think.

    Another tip: a console application for Windows with which you can connect to Linux machines via ssh is Putty I think (I haven’t used Windows for 10 years). Try to download and install that. Why? Because you can log into the CLI of your Pi from Putty. That way you do not have to walk to your Pi to “do things” on the CLI. You can remotely operate your Pi (if you speak a little Linux that is).

    In Putty try:

    ssh pi@192.168.1.129
    It will probably ask for user “pi” his password which is “raspberry”.

    Good luck! :)

Viewing 13 posts - 1 through 13 (of 13 total)
  • The forum ‘New to RetroPie? Start Here!’ is closed to new topics and replies.