Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • fistwielder
    Participant
    Post count: 38

    I’ve been having WiFi instability issues on multiple Raspberry Pi 3s running RetroPie 3.6

    I found a temporary solution. If I run the following command it fixes the Wifi issue until the next boot:
    sudo iwconfig wlan0 power off

    Is there a permanent solution?
    If not, how do I create a script that will run this automatically every time it boots up? Or is there an existing script I can add this to?

    senkun
    Participant
    Post count: 35

    [quote=120397]Is there a permanent solution?
    If not, how do I create a script that will run this automatically every time it boots up? Or is there an existing script I can add this to?[/quote]

    easiest way is to just add the line

    sudo iwconfig wlan0 power off

    to

    /etc/rc.local

    make sure it’s added above exit 0

    dankcushions
    Participant
    Post count: 432

    thanks for this! finally i have stable wifi :)

    fistwielder
    Participant
    Post count: 38

    Thank you senkun!
    This seems to be a Raspbian bug. Hopefully they will put out a permanently fix soon.

    petrockblog
    Keymaster
    Post count: 1827

    I believe it is already fixed in the latest packaged kernel

    
    sudo apt-get update; sudo apt-get dist-upgrade
    
    dankcushions
    Participant
    Post count: 432

    seems to work without the etc/rc.local line after an apt update/upgrade, so even better! :)

    fistwielder
    Participant
    Post count: 38

    Thanks buzz!
    Setting this to resolved.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.