Viewing 11 posts - 176 through 186 (of 186 total)
  • Author
  • cooky069
    Post count: 15

    Iv been using a tronsmart Mars go1 pad. I was a little apprehensive at first but it’s turned out to be a really good controller . Comes with a wireless dongle and built in rechargeable battery which lasts ages . It has an xbox mode which connects flawlessly every time with the xbox driver installed. Iv used it on most of the Nintendo and sega systems also psx, amiga and pc engine with no problems.
    I also have an 8bitdo nes30 pro but iv been unable to get it to work so far

    Edit: nes30 pro now working. turns out I just needed to update the setup script and now it works perfectly

    Post count: 1
    Post count: 76

    I’ve been using a ps4 pad which I think is excellent. I’ve also finally managed to just about get a sega Saturn pad and virtua stick working too – the arcade stick is excellent for beam-em-ups.

    I did use a pair of Xbox one pads too with previous builds of RetroPie but they’ve not worked since a firmware update. The latest update to xboxdrv does not seems to fix the issue sadly…

    Post count: 97

    Well, bought this one from Amazon (the ‘Buffalo Classic USB Gamepad’ that looks like a SNES controller). Like the reviewers said there, it doesn’t feel as cheap as you’d think. It’s D-pad is reasonably suited for Mame (i.e. 4-way, not 8-way!). But this one too tends to let Pac-Man go up or down when you press too hard on left or right. That is: it almost supports 8-way. Maybe a keyboard is still the best way to go…

    Buffalo classic SNES gamepad

    Post count: 10

    I want to use a Xbox one afterglow prismatic controller but the Xboxdrv is all weird right now.

    Post count: 1

    Using original console gamepads for each emulator, usb modified or with adapter.
    For mame i’m using SFIV Tournament Edition Arcade Stick or the Mad Catz SFIV gamepad

    Post count: 32

    Right now I’m not using nothing fancy, an old GameStop (MadCatz) 360 wired controller with a 10′ long usb extension cable. But I bought one of the new steam controllers and would love to get that working. Haven’t found a good step-by-step guide on how to get it going yet though. Please let me know if anyone knows of one.

    Post count: 97

    [quote=120925][snip]But I bought one of the new steam controllers and would love to get that working. Haven’t found a good step-by-step guide on how to get it going yet though. Please let me know if anyone knows of one.
    On the Steam site it says “USB 2.0 via Micro USB port (cable included)”. The word “compatible” is missing here!

    Anyway, I did some googling and indeed this thing is not the most PC friendly device on earth. It even appears not to work on Mac and people get “coupons” from Valve/Steam to make up for this until there’s a firmware upgrade to fix this. Yeah, right.

    Considering the fact that its intended platform (Steam Box) is based on Linux it is pretty pathetic that it doesn’t work out of the box on Linux. There are two posts of interest here:

    1. Steam admitting it doesn’t work out of the box and giving instructions on how to achieve Linux compatibility:
    2. Same thing from a user’s perspective:

    They say you must create the file /lib/udev/rules.d/99-steam-controller-perms.rules and put hte following contents in it:

    #USB devices
    SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", MODE="0666"
    # Oculus HID Sensor naming and permissioning
    KERNEL=="hidraw*", SUBSYSTEM=="hidraw", ATTRS{idVendor}=="2833", MODE="0666"

    I’d recommend connecting only the Steam Controller after this and to test if RetroPie “found” the device with ye’ old:

    jstest /dev/input/js0
    (Install the joystick package in Linux w/: “sudo apt-get install joystick”)

    Good luck :)

    Post count: 32

    I’m backing-up my SD card now to give this a shot. I’ve been drinking tonight so I know I’m much smarter than a few hours ago – I bet you nothing I get this working :)
    But I’ll let you know.
    Thanks for the help!

    Post count: 32

    -Wireless Only Portion
    Well, kind of good news for those with the steam controller. It appears that the mouse pad portion of the steam controller works with retropie – bad news is emulation station doesn’t use a mouse :)

    When in retropie and over wireless, if you run your finger over the right d-pad area it lightly vibrates just like on a desktop and these files show up in /dev/input/by-id:

    I did add the /lib/udev/rules.d/99-steam-controller-perms.rules file and contents, rebooted, and plugged in the steam wireless stick on reboot.
    However, js0 or any js* for that matter doesn’t exist when only the steam controller is plugged in.

    -Wired Only Portion
    So, after messing around with the wireless and getting no where, I plugged it in using a micro usb to usb cable and rebooted again. Once in emulation station I went to configure input it found the device….but as a keyboard….the ONLY buttons and pads/sticks that seem to work for me right now are:
    A Button
    Start Button
    Select Button
    Left D-Pad (I think you can also configure the stick as the same…kind of a clone thing between the stick and left d-pad)
    And that’s it….no B button….give me at least the B button so I can play NES roms :)

    FYI – I’m running a Pi3 with keyboard and built-in wifi enabled, can’t promise good performance on a Pi2 with the stuff below per the URL below.

    So I found this tid-bit URL

    Hoped on putty and performed a sudo pip install libusb1 (I don’t know what version of php I have or came on the retropie 3.6 image, but giving it a go anyways…remember I backed up! *My install is fairly clean, I did install the Descent I & II ports, updated RP scripts, and that’s about it (aside from adding my roms)

    Next, in my home directory I did a wget

    tar xf master.tar.gz
    cd steamcontroller-master
    sudo python install

    sudo nano /etc/udev/rules.d/99-steam-controller.rules
    and added the following inside the empty file

    # replace game group by a valid group on your system
    # Steam controller keyboard/mouse mode
    SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", GROUP="games", MODE="0660"
    # Steam controller gamepad mode
    KERNEL=="uinput", MODE="0660", GROUP="games", OPTIONS+="static_node=uinput"

    Then reloaded udev
    sudo udevadm control --reload


    cd /steamcontroller-master/scripts start

    But got a bunch of errors with a lot of “enum” words in it, so I felt lucky and installed the part of the website (above) that listed “enum” in it:
    sudo pip install enum34
    It said something about the requirement already being satisfied, so I figured I was s***-out-of-luck. But for giggles I did the following:

    sudo udevadm control --reload start

    and low-and-behold no messages…looking good so far…didn’t think I’d get this far.
    So, the thing is I’ve got a 70″ screen mounted to the wall with no media center underneath, everything I use is either HD antenna, PLEX, or Roku, I cut the cable years ago and prefer a clean look. So, I’m not keen on having a keyboard hanging off the Pi3 mounted behing the TV, so my next step (after testing) is to setup the python script to auto-start. So, I’m going to edit my rc.local file
    sudo nano /etc/rc.local
    and add the following (change your paths if needed) after all the commented lines but BEFORE the exit 0 line.
    /home/pi/steamcontroller-master/scripts/ start
    after saving the file I stopped the process I kicked off earlier and tested the rc.local file by: stop

    Just to make sure no errors popped up, kept the steam controller plugged in (hardwire) and I’m ready for a reboot to see if it started.
    Wow, now when I go to Configure Input in emulation station I get a “1 gamepad detected”, I hold “A” on the joystick and it see’s it as a XBOX 360 Gamepad…that’s what I call progress.
    The controller is VERY touch sensitive, and I can’t seem to get the right bottom trigger or left thumb press to be defined.
    I’ll work on it a bit tomorrow, see if I’m doing something wrong and take a look at the python script…I’m a bit of a script kiddie (is that saying even still used?).
    Played a quick level in Super Mario on the NES (still wired joystick), exited with start-select like normal, then unplugged joystick and plugged the wireless stick in…this is where you get all warm and creamy….even without a reboot…the joystick works great and immediately over wireless…just need to turn the controller back on after unplugging the usb cable.
    I’m sooo thrilled and taken waaayy to much room in this forum…hope this helps someone.

    I’m thinking of writing a script to make this process much faster, I’m not the coder of the “steamcontroller-master” app, kudos to that person for making my life easier, but I can certainly make setting up a Steam Controller on a RPi much faster (I think).

    Here’s my config file, all buttons working and configured to use the thumbstick instead of the left d-pad for moving (I don’t like the sensitivity of the pads, so I swapped the d-pad for the thumbstick), just backup and overwrite your sudo nano /opt/retropie/configs/all/retroarch-joypads/MicrosoftX-Box360pad.cfg with this info:

    input_device = "Microsoft X-Box 360 pad"
    input_driver = "udev"
    input_r_y_plus_axis = "+4"
    input_l3_btn = "9"
    input_r_x_minus_axis = "-3"
    input_r_axis = "+5"
    input_save_state_axis = "+5"
    input_l2_btn = "4"
    input_start_btn = "7"
    input_exit_emulator_btn = "7"
    input_l_y_minus_btn = "h0leftanalogup"
    input_l_axis = "+2"
    input_load_state_axis = "+2"
    input_up_axis = "-1"
    input_r_y_minus_axis = "-4"
    input_a_btn = "0"
    input_b_btn = "1"
    input_reset_btn = "1"
    input_down_axis = "+1"
    input_r2_btn = "5"
    input_l_x_plus_btn = "h0leftanalogright"
    input_l_y_plus_btn = "h0leftanalogdown"
    input_right_axis = "+0"
    input_state_slot_increase_axis = "+0"
    input_x_btn = "2"
    input_menu_toggle_btn = "2"
    input_select_btn = "6"
    input_enable_hotkey_btn = "6"
    input_l_x_minus_btn = "h0leftanalogleft"
    input_y_btn = "3"
    input_left_axis = "-0"
    input_state_slot_decrease_axis = "-0"
    input_r_x_plus_axis = "+3"
    Post count: 97

    Thank you for your post/tutorial. I think that the Steam controller might become quite popular since Stream is big in game land. Good to know how to get it working.

Viewing 11 posts - 176 through 186 (of 186 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.