Forum Replies Created

Viewing 35 posts - 71 through 105 (of 149 total)
  • Author
    Posts
  • patrickm
    Participant
    Post count: 171

    Are you using video smoothing? That should be disabled. Not sure why the image in the OP isn’t working for you. Did you set overlay_fullscreen to true in the .cfg for the overlay? Here are direct links to the files. It sounds like maybe you downloaded a preview image instead of the fully zoomed version, or something, and that it’s getting scaled improperly and thus blurring the lines together.

    https://www.dropbox.com/s/3e9x8bpu2u0iyug/scanlines1920x1080.png?dl=0
    https://www.dropbox.com/s/88bj4jqgeqzx1c6/scanlines1920x1080-5x.png?dl=0

    patrickm
    Participant
    Post count: 171

    [quote=98183]Check your Retrench render resolution.
    When you load a rom press “x”, select point “8”
    (Select Retroarch render res for xxx)
    in the menu select point 5
    (Use video Output resolution)

    And be ensure that your display is a 1080p display.
    Otherwise scanline overlay image of patrickm will be downscaled, the scaliness itself blurred and only darken the whole image.

    [/quote]

    yep, I just tested an overlay that is larger than my screen resolution and it just darkened the whole screen. Render resolution, screen resolution and overlay resolution need to match.

    patrickm
    Participant
    Post count: 171

    [quote=98163]I tried your scanline overlay but the picture (scanlines) was not show. The overlay only darkened the picture. Could you please upload the two pictures in a .zip file instead, they might have been modified during upload or something?

    [/quote]

    Are you sure that your video is rendering correctly? The retropie does bilinear filtering when it upscales, which could be causing the scanlines to blur together. Make sure you follow the instructions for getting proper video rendering, which I linked to in the OP.

    patrickm
    Participant
    Post count: 171

    [quote=98036]There is no upscaling if display and render resolutions are equal. Be aware your display resolution could be some pixels smaller if overscan (config.txt) is enabled. So if render resolution is 1920×1080 and your display resolution is 1910×1070 (overscan) there could be scaling artifacts.

    If performance is ok i would recommend render = display resolution. If performance is to low (shaders, emulation speed) a mix of hardware upscaling and lower render resolutions should be used. Hardware upscaling is for free and needs no processing power.

    I have not seen any input lag with hardware upscaling. Thought threaded video causes a small input lag.

    [/quote]

    I’ve noticed additional input lag setting the render resolution to 960×720 on my 1080p monitor, although it is slight. I’m playing a lot of fast-twitch games, though, so it might not be noticeable in most situations.

    Logically, there is going to be an extra delay due to the additional processing that the gpu has to do. Whether or not this is noticeable depends largely on the individual and the game being played.

    I wasn’t aware of the performance limitations of the raspberry pi 1, I can see now that the default video settings make sense.

    I thought it might make sense to add something like “video profiles” to the launch menu, sort of like preconfigured video modes, but then I realized that each system would need its own custom resolution, and the idea started to seem too complicated.

    patrickm
    Participant
    Post count: 171

    Did you try using the retropie setup utility to configure controllers?

    patrickm
    Participant
    Post count: 171

    Bump. Any help with this?

    patrickm
    Participant
    Post count: 171

    [quote=98068]so do you guys have any suggestions for a better picture quality for MAME and finalburn ALpha?

    [/quote]

    I haven’t used those, but I believe you can use an overlay to get scanlines in MAME in a similar way.

    patrickm
    Participant
    Post count: 171

    [quote=98054]

    A key reason for using the existing retroarch.cfg files is the internal reference to the overarching retroarch.cfg in the /all folder – which in turn pulls in the autoconfig controller files.

    I’ll hopefully have time this weekend to do a guide.
    If you want to give me a specific shader or scanline setting example to try I’ll base the video on that.

    It seems like in an older version of the script, the internal references were carried over to the core-specific config when it was saved. Maybe that isn’t the case any more?

    Would it be possible to bypass needing to edit config files by doing the following under general settings:
    -configuration per core: ON
    -configuration save on exit: ON

    Would this work?

    A video explaining the following would be excellent:
    -how to get proper integer video scaling and set a custom ratio (needed to get proper scanlines)
    -how to properly set the scanline overlays in the OP (both the 4x version and the 5x version)
    -how to apply the dotmask shader
    -how to save these settings

    Couldn’t say it better myself. All the steps you listed would be great in a vid. Also if you can add what I good shader might be for the megadrive or genesis. All look horrible in my part. thanks for the help both of you.

    [/quote]

    I just use the 5x scanline overlay at 100% with integer scaling at 5x (vertical) on pretty much everything. This crops the video on some systems but it never crops more than the overscan area.

    I wouldn’t recommend most shaders, personally, unless you have a 720p native display. The dotmask shader is an exception because it’s lightweight enough to run at 1080p without causing performance problems. Personally, I like the look of just scanlines without the dotmask.

    patrickm
    Participant
    Post count: 171

    [quote=98048]A key reason for using the existing retroarch.cfg files is the internal reference to the overarching retroarch.cfg in the /all folder – which in turn pulls in the autoconfig controller files.

    I’ll hopefully have time this weekend to do a guide.
    If you want to give me a specific shader or scanline setting example to try I’ll base the video on that.

    [/quote]

    It seems like in an older version of the script, the internal references were carried over to the core-specific config when it was saved. Maybe that isn’t the case any more?

    Would it be possible to bypass needing to edit config files by doing the following under general settings:
    -configuration per core: ON
    -configuration save on exit: ON

    Would this work?

    A video explaining the following would be excellent:
    -how to get proper integer video scaling and set a custom ratio (needed to get proper scanlines)
    -how to properly set the scanline overlays in the OP (both the 4x version and the 5x version)
    -how to apply the dotmask shader
    -how to save these settings

    patrickm
    Participant
    Post count: 171

    [quote=98046]

    Yep as soon as I apply the scanlines the screen darkens, so I know I did that right.
    But like said earlier I’m still having the problem of redoing everything after I change games or exit out of the emulator.

    [/quote]

    You know, the easiest way to so this might be to select “configuration per core ON” and “configuration save on Exit ON”. Both are in general settings.

    Although I have not personally tested this.

    You can also rename the core-specific config in the opt/retropie/configs/emulatorfolder to “retroarch.cfg”. If you do this, be sure to name the existing .cfg in that same folder to “retroarch.cfg.bk” or something, so you can revert to it if something goes wrong.

    That, or wait for Floob’s video that makes this easy to understand :)

    patrickm
    Participant
    Post count: 171

    [quote=98041]

    Add the extra lines into the existing system retroarch.cfg (at the top), dont rename one to be retroarch.cfg.

    I’ll try to do a video soon.

    Yeah I didn’t rename one. Which lines do I add to the existing file? I went over your vid on how to setup shaders for the snes, but I want to do exactly what patrickm is doing in his original. I follow all the steps, but I can’t seem to make the changes reload when I restart the emulator. I have to go through the steps all over again every time I want to play a game. If possible can you make a video on how to do all the steps that patrickm wrote. Plus adding the dotmask shader I can’t seem to make this one work. So Scanlines plus dotmask shader. Thanks I apreciate all you guys help.

    [/quote]

    The dotmask shader is very very subtle, you have to have your nose pressed to the screen to see the mask. If you are able to get other shaders working than this one is probably working, too. The most immediately noticeable effect is that it darkens the screen somewhat.

    Yeah, some videos would be nice :)

    I don’t really have the means to record quality video.

    patrickm
    Participant
    Post count: 171

    [quote=98033]Add the extra lines into the existing system retroarch.cfg (at the top), dont rename one to be retroarch.cfg.

    I’ll try to do a video soon.

    [/quote]

    You have to do a separate config for each emulator to get the correct resolution and scaling.

    I’m not sure what the exact difference is between renaming configs vs adding lines to retroarch.cfg, but your method is probably safer as you can just delete the added lines if something goes wrong.

    patrickm
    Participant
    Post count: 171

    [quote=98032]

    bump; added 5x scale scanline overlay (1920×1080). Also added step-by-step instructions.

    How do I make the changes permanent. I try to go back on the RGUI and hit on the save new config option and nothing happens. Once I restart the emulator it goes back to the old settings.
    By mistake I change on the RGUI the configurations to the retroarch.cfg file is that ok? How do I change back to the old libreto field

    You can make settings stick by navigating to the right config file in /opt/retropie/configs/ and find the right emulator folder. Within each emulator folder there is a “retroarch.cfg” which has settings which overwrite the global settings. Any settings which you wish to make permanent should be added there. There should also be an “emulator-name.cfg” in each emulator folder. You can rename this to “retroarch.cfg” and it will be loaded next time you launch RA.

    well yeah I know how to do that. I set a permanent shader for my snes emulator. What I want to know is that why when I follow your steps I save it in the RGUI and once I exit out of any particular emulator my previous settings of adding the scanlines, filters and scaling are erase. Once I start the emulator again I have to go and go through your steps once again. Do you happen to know the code that I have to write in the retroarch.cfg file to make the steps from your original post permanent for my nes, snes, and megadrive. Also when I apply your scanline file on the RGUI I don’t see a difference on the nes or snes emulator. Also how do you apply the dotmask filter plus the scanline file that you provided together. If I go to options and filters I don’t see that particular filter. All your help is appreciated, thanks.

    [/quote]

    To set the overlay, put the .png and .cfg (for the overlay) in the appropriate overlay folder, then select the .cfg in retroarch. Settings -> overlay settings, set the overlay preset and be sure “overlay enable” is on

    To set the shader go to options -> shader options -> shader passes, set to 1. Then under shader 0 select the dotmask shader in the /shader/CRT/ directory. The hit apply shader settings.

    Make sure SNES and NES are set to render at the correct resolution, also. Scaling can cause overlays to not work correctly. Also make sure overlay opacity is set higher than 0 :)

    patrickm
    Participant
    Post count: 171

    [quote=98024]You can set “any” vertical resolution (0-1080) in your retroarch.cfg. For example you could set something like 1080/2=540 or 1080/4=270 to get integer scaling. If the aspect ratio of your render resolution differs from your display resolution horizontal resolution will be recalculated. You can try to get the best fit for performance and visual appearence. Render resolution upscaling is for free (hardware). If render and display resolution is equal software integer scaling is used (performance penalty). It is also possible to modify the hardware upscaler to your needs: https://github.com/raspberrypi/firmware/issues/104

    As i have said default visual settings are not optimized for rpi2 at the moment. If we find better defaults we can at them.

    [/quote]

    Ah, good to know- wasn’t aware of the hardware upscaling being configurable.

    I’m a little confused, though- I thought if render resolution matched display resolution, no upscaling occurred. Is this incorrect?

    So, are you saying that rather than setting display and render resolution to match, I should instead set my render resolution differently so that the GPU handles scaling? when I try setting render resolution to 960×720, for example, and display res at 1080p, there is noticeably more input lag vs. leaving both display and render res at 1920×1080. I assumed this was due to the additional upscaling.

    patrickm
    Participant
    Post count: 171

    Bump. Need someone to confirm the existence of problems 2 and 3 above.

    patrickm
    Participant
    Post count: 171

    [quote=98008]Hello,

    I’ve built a cocktail cabinet with the intent on playing MAME games on it but I also really like the idea of playing with friends using the NES emulator. For games like super mario I’d need to be able to flip the screen between players.

    Checking out the basic options in the NES emulator this does not appear to possible. Does anyone have any ideas?

    I searched the forum but did not find anything related but I apologize if this has been asked before.

    Thank you.

    [/quote]

    I think there’s a rotate screen option in video settings.

    patrickm
    Participant
    Post count: 171

    [quote=98021]

    bump; added 5x scale scanline overlay (1920×1080). Also added step-by-step instructions.

    How do I make the changes permanent. I try to go back on the RGUI and hit on the save new config option and nothing happens. Once I restart the emulator it goes back to the old settings.
    By mistake I change on the RGUI the configurations to the retroarch.cfg file is that ok? How do I change back to the old libreto field

    [/quote]

    You can make settings stick by navigating to the right config file in /opt/retropie/configs/ and find the right emulator folder. Within each emulator folder there is a “retroarch.cfg” which has settings which overwrite the global settings. Any settings which you wish to make permanent should be added there. There should also be an “emulator-name.cfg” in each emulator folder. You can rename this to “retroarch.cfg” and it will be loaded next time you launch RA.

    patrickm
    Participant
    Post count: 171

    [quote=97985]640×480 default is set because higher resolutions will slow down rpi1s. In the past display resolution was switched which caused flickering and was not compatible with all screens. Rpi2 and 1080p should be fast enough if you use no shaders. Rpi1 and two share the same default configuration at the moment.

    If you have a 16:9 screen resolution and 640×480 render resolution retroarch will increase your horizontal resolution to 853×480. So there should be no unequal pixels since Retropie 2.6 or 3.0.

    [/quote]

    The first statement makes sense, but I’m unclear on the second statement. A resolution of 853×480 is still going to be scaled to the native resolution of the display (either 1920×1080 or 1280×720), which will cause scaling artifacts on both axes. I’m definitely still seeing unequal pixels on my display with the default settings. Upscaling from a lower res to the native res will also cause input lag.

    I was thinking, maybe it would be helpful to have “video profiles” so that one doesn’t have to mess about with RGUI so much. For example, I would hold “x” or “m” as a game launched to bring up the launch menu. I would scroll to “video profiles,” select “5x” and hit apply. The 5x profile would apply integer scale, crop overscan (if the core needs it for perfect scaling) and a custom aspect ratio for the system being played (since resolution is core-specific), at 5x vertical scale (so, 6×5 for NES, SNES, 5×5 for Genesis, etc.). You could also have 4x profile, 3x for 720p displays, etc.

    currently there are a lot of settings for the user to configure and they are likely to get something wrong, causing problems. I’m just trying to think of ways that the configuration process could be streamlined/ made easier.

    patrickm
    Participant
    Post count: 171

    [quote=97920]Hi there, sorry for my english.
    I setup a retropie 3.0 and attached a full HD Display via HDMI.

    it is installed in an old arcade cabinet, turned 90 degrees so the short side (1080) is above, the wide side is left/right (1920).

    1. how can i say retropie to use the display 90 degrees turned ?

    2. how can i say the amiga emulator that he has to use the dissplay, that a “window” in the middle of the screen is used to display the emulation ?

    thanks for your held

    Nick

    [/quote]

    1. access RGUI (F1 by default) settings -> video settings -> rotation or something like that.

    2. not sure what you’re asking here; are you referring to black bars at the top/bottom of the screen?

    patrickm
    Participant
    Post count: 171

    double post

    patrickm
    Participant
    Post count: 171

    [quote=97840]

    As they mention, sticking to an arbitrary 4:3 for the sake of it isnt really that relevant, with the goal really being to get close to each systems native output resolution.
    [/quote]

    I read over that thread and actually posted in it as Nesguy.

    That thread has very different goals than this thread. They want to display games in their native resolution, which is incorrect IMO. It isn’t how the games were displayed nor how they were meant to be displayed.

    This thread is about getting perfect video scaling, which is related to but a separate issue from aspect ratio.

    You can accomplish what that other thread is describing by just selected the 1:1 PAR option under video aspect ratio. This will result in perfect scaling, but will also make the picture appear in a small pillarboxed square, wasting a lot of screen space and making the graphics appear squished.

    To keep the perfect scaling with a more authentic and aesthetic aspect ratio, follow the instructions in this thread.

    I provided some example shots below of NES and SNES at 6×5 integer scale. As you can see, what gets cropped off corresponds to the overscan area. On SNES it’s very minimal. If you zoom in you will see that each pixel is the exact same shape and size. This is identical to the output using an XRGB Mini with the 5x profile.

    (Be sure to click enlarge for proper viewing)
    http://s1309.photobucket.com/user/Patrick_McCleery/media/image.jpg2_zpsuohwoiid.jpg.html

    http://s1309.photobucket.com/user/Patrick_McCleery/media/image.jpg1_zpssotkgues.jpg.html

    patrickm
    Participant
    Post count: 171

    [quote=97830]Hello!
    I am new to Retropie so all this is alien for me.
    My problem is that i cant change my resolution for my snes games i have an 720p widescreen computer monitor.

    I have tried to push down X at start up when i load games.
    “1 Select default video mode for emulator/port”
    I have tried to change to almost every DTM-xx whit 4:3 ratio.
    Also the ntcs and pal 4:3 options at the bottom.

    /opt/RetroPie/configs/all/retroarch.cfg
    I have changed to this

    video_aspect_ratio = 1.33
    #1.333333 (4:3) Traditional SDTV
    #1.56 (14:9) 4:3/16:9 Compromise aspect ratio
    #1.6667 (5:3 Super 16mm)
    #1.77 (16:9) HDTV US standard 
    #1.78 (16:9) HDTV US standard alternate
    #1.6 (16:10) Common computer screen ratio
    #1.6667 (5:3) Common European widescreen standard
    #1.85 Common US widescreen cinema
    #2.39 Current widescreen cinema alternate
    #2.40 Current widescreen cinema alternate

    And the /opt/retropie/configs/snes

    # All settings made here will override the global settings for the current emulator core
    
    video_shader = /opt/retropie/emulators/retroarch/shader/snes_phosphor.glslp
    video_shader_enable = false
    video_smooth = false
    video_aspect_ratio = 1.33
    #1.333333 (4:3) Traditional SDTV
    #1.56 (14:9) 4:3/16:9 Compromise aspect ratio
    #1.6667 (5:3 Super 16mm)
    #1.77 (16:9) HDTV US standard 
    #1.78 (16:9) HDTV US standard alternate
    #1.6 (16:10) Common computer screen ratio
    #1.6667 (5:3) Common European widescreen standard
    #1.85 Common US widescreen cinema
    #2.39 Current widescreen cinema alternate
    #2.40 Current widescreen cinema alternate
    input_enable_hotkey = nul
    aspect_ratio_index = "6"
    video_scale_integer = true
    rgui_show_start_screen = false

    I have been working at this problem for many days right now and i have been done many changes in different files, i have done almost every tip from my google searches :/

    One more problem is that form some guides from google i my folder index do not look like others sometime. i have installed the RetroPie SD-card Image, but i don’t know the version number, only Emulationstation v2.0.0-rc1.

    Thanx for the help!
    /Fredrik

    [/quote]

    You have to choose your monitor’s native resolution as the video output resolution. Retroarch render resolution should match this. The native res is the maximum res your display is capable of.

    You cannot get a perfect 4:3 aspect ratio without scaling artifacts using a fixed-pixel display. Well, there are some exceptions, but SNES isn’t one of them. Your best bet is to use 5x integer scaling on the Y axis and set the X axis accordingly. This will result in a slightly wider than 4:3 aspect with the top and bottom cropped off, but with the original pixel aspect preserved. See “how to get perfect video scaling”

    It is highly recommended that you not set video output to anything other than your native res, as this will cause input lag and scaling problems.

    EDIT : I see you are using a 720p display. In that case, just follow the instructions for setting integer scale. You can usually get close to a 4:3 aspect ratio. I think 4×3 integer scale gets you close to a 4:3 aspect ratio with NES for example.

    patrickm
    Participant
    Post count: 171

    bump; added 5x scale scanline overlay (1920×1080). Also added step-by-step instructions.

    patrickm
    Participant
    Post count: 171

    [quote=97686]hello
    It’s the good resolutioon i think ?

    [/quote]

    You will get scaling artifacts with that setup if using a 1080p display.

    See “list of recommended resolutions” and “how to get scanlines”

    Sorry for contradicting myself, but I’ve learned recently that shaders aren’t optimal for the pi.

    patrickm
    Participant
    Post count: 171

    [quote=97726]Hi guys,

    I just figured out how to automatically load a shader at snes startup. I use snes9x. My retroarch.cfg for snes looks like this

    video_shader = /opt/retropie/emulators/retroarch/shader/sabr/sabr-v3.0.glsl
    video_shader_enable = true
    

    But how can I set the “shader scale” to “1” and the “shader filter” to “nearest”. When I press F1 in retroarch menu I can set these two values. But I don’t know how to set it in the cfg. Do you know how to configure it?

    [/quote]

    I wouldn’t recommend shaders on the pi as they tend to cause performance issues. I would instead opt for overlays – see “how to get scanlines.”

    If you insist, though:

    Main menu -> options -> video options -> shader
    There you will find “shader scale” and “shader filter.”

    patrickm
    Participant
    Post count: 171

    I solved this; turns out the problem was not with integer scale but with my scanline overlay.

    I made a new overlay with slightly thinner scanlines that works at 5x integer scale, see “scanline overlays.”

    patrickm
    Participant
    Post count: 171

    [quote=97705]Hi

    When I set any overlay option in Retroarch.cfg games wont run, PSX games do run but overlays are not displayed and if I try to change any overlay option in the settings (for example if I try to turn them off or change the scale) in the retroarch menu it crashes the PSX emulator

    Just to be clear, this only happens when I set then by default in Retroarch.cfg if I run the emulator without any overlay option set in retroarch.cfg and then manualy add them in the setting menu of retroarch they do work fine.

    The Retroach.cfg I edited is the one at /opt/retropie/config/all/

    Any idea what could it be? having to add the overlays every time I start a game is a chore :(

    Im using a PI 2 with Retropie 3 beta 2

    Thanks

    [/quote]

    This sounds like something in your config is amiss. I wouldn’t recommend messing with the config in /all/. You have to set a different resolution for each system for the scanlines to look right, anyway. Just set integer scale on (video settings) and then set a custom resolution (options -> video options) to your liking. Then apply the overlay and save the config (main menu -> save new config). You only need to set up each system once. Go to the folder in /opt/retropie/configs/ and open the folder corresponding to the emulator. Rename the “emulatorname.cfg” to “retroarch.cfg.”

    Also, make sure your video output is set up correctly by holding x when the game launches. Your video output should be at your monitor’s native resolution and retroarch render resolution should match this (set to “use video output”).

    Make sure that everything is named correctly – the .png and .cfg for the overlay you’re using should be named the same, and in the .cfg for the overlay it needs to be pointing to the right filename.

    patrickm
    Participant
    Post count: 171

    [quote=97685]You do need to be careful here not to remove the line in the existing retroarch.cfg that pulls in the main retroarch.cfg – unless you want to break that link.

    Maybe we need a new guide/video to explain these retroarch.cfg video config values and where to add them.

    [/quote]

    Some videos would be really helpful. I’m realizing that a lot of this stuff is hard for a beginner who is new to Retroarch to understand. If you want to make some videos explaining “how to get scanlines” and “recommended resolutions,” that would be great.

    I’m noticing a lot of the scanline overlays are broken, so I included a working one for 1080p displays in “how to get scanlines,” and I notified HunterK of Libretro.

    I’m also noticing that retropie could be configured better by default. By default, cores are set to render at 640×480, which causes scaling issues on both 1080p and 720p displays. Both “video output resolution” and “retroarch render resolution” should be set to match the display’s native resolution. “retroarch render resolution” should be set to “use video output.”

    patrickm
    Participant
    Post count: 171

    Bump; would really like to get this addressed. SNES, NES, Genesis, Doom, N64 would all be awesome at 5x integer scale, if I could get it to work without scaling artifacts.

    patrickm
    Participant
    Post count: 171

    [quote=97674]
    I’m sorry to bother you Patrickm, but would it be possible to make a guide on how to add the scalines or have the same setup that you have. I have a 1080P tv too and want the look you would get from the mini XRGB. Is their a way you can do a step by step guide with the commands and all. I see that you have other post on the proper resolution for each system, but I’m confuse as to where to do this changes and if I have to do it for all system or is there a universal way. I’m sorry, I’m new to all this, I barely started messing around with the pi 2 days ago. Also sorry for my bad grammar.

    [/quote]

    It’s no bother at all. I don’t know if I can make things any simpler than my explanation in “how to get scanlines.”

    You have to configure each system’s resolution independently, because they all used different internal resolutions. See “list of recommended resolutions.” You need to download the scanline overlay there and follow the instructions. If you get stuck on something or have a specific question I’d be happy to help.

    the settings you want to change can all be accessed through the RGUI (Retroarch GUI) by pressing F1 while a game is running.

    To save a config, access RGUI and go to the save new config option. You then need to navigate to the right emulator folder in /opt/retropie/configs/ and change “emulatorname.cfg” to “retroarch.cfg,” as the settings in “retroarch.cfg” are the ones that get loaded. For example, save a new config for NES and it will show up in /opt/retropie/configs/nes as “nesotpie_libretro.cfg” (if I used nestopia), and you would change that to “retroarch.cfg.”

    patrickm
    Participant
    Post count: 171

    You can also use a scanline overlay to get scanlines. I posted one in “how to get scanlines”

    patrickm
    Participant
    Post count: 171

    [quote=96166]Hello,

    Can anyone suggest how I can get games to go full screen in Advance Mame and Finalburn Alpha emulators as I have black borders on my 19inch monitor?

    Can’t find any help in this.

    Thanks

    [/quote]

    Check the topic “list of recommended resolutions.”

    Turn on integer scale (video settings)
    set a custom ratio (options – video options)

    Any other method will result in ugly scaling artifacts. You can get the picture to extend beyond the edges of the screen (this works well for many systems such as NES, SNES, Genesis) by settings a custom “fullscreen x” and custom “fullscreen y” in your config file that matches the desired resolution.

    check overscan settings first, though.

    patrickm
    Participant
    Post count: 171

    Updated OP; added “dotmask” shader to recommendations.

    patrickm
    Participant
    Post count: 171

    [quote=97484]I know why there are PAL borders and also the technical reason ?

    You never get a look on a LCD like a real CRT until the screen gets u much higher resolution as it know is (on a Consumer LCD)
    Your settings and look are also much far away from beeing a really realistic look.
    And yes i don’t sit a view inches off the screen and count pixels. I sit there i a realistic distance and want the best appereance. And this not with a blocky sharpness.
    Also i think the designers of these games with this low resolution, designed the graphics to have the best look with the softness of a (consumer) LCD.
    Probably most people think the same about the image quality. This is probably the only reason why shaders and filters exists.

    But Everyone should adjust it as he wants. ?

    [/quote]

    I agree, it will take higher resolution to really replicate the CRT look.

    Again, I’m not going for authenticity, but overall picture quality, and this is a Raspberry Pi forum, so I’m speaking specifically on how to get the best picture quality on the pi while making the fewest compromises. The shaders cause numerous problems on the pi.

    Even back in the days of CRTs, RGB monitors were the gold standard before Sony BVMs came along. Why? Because they had sharper and brighter pictures.

    You seem to be forgetting how dim CRTs were compared to LCDs; I was mistaken earlier (not enough sleep) and was thinking about contrast. An LCD is bright enough that you can add 100% black scanlines (reducing the effective backlight by 50%), and it will still be brighter than a CRT.

    The artists may have designed the game for a crappy ntsc composite tv in some cases, but that doesn’t mean the game won’t look objectively better on a better display. I recognize this is somewhat subjective, but you seem to be conflating picture quality with authenticity, which is also subjective.

    Regarding viewing distance, at the right distance the pixels shouldn’t look overly sharp at all. Maybe you are actually too close. The average crt was about 26″ and people sat 8 ft from it. I’m pretty sure these graphics were designed for a small view angle- maybe 15 degrees.

    I’m not against shaders per se, I think crt-easymode or CRT-royale with the right settings can look good. But neither will run on pi. So I just opt for a clean emulated look with scanlines. You can also add “dotmask” shader on top of this for a very light aperture grill effect.

    I’m happy I solved my overlay issue. :)

    patrickm
    Participant
    Post count: 171

    Well, I finally got what I wanted, simple adjustable scanlines via an overlay :)

    Took me three days to figure out, but it was pretty easy to do in the end, as these things usually are.

    I don’t think there’s an overlay like this included with Retroarch, so I’ve attached it. This will produce perfect looking scanlines at 1080p.

Viewing 35 posts - 71 through 105 (of 149 total)