Tagged: ,

Viewing 35 posts - 36 through 70 (of 119 total)
  • Author
    Posts
  • patrickm
    Participant
    Post count: 171

    Added the following to the OP:

    Another option for getting scanlines:
    -set video output resolution to 1080 or native res and set retroarch render res to the same
    -use the “scanline” overlay preset. In RGUI, go to settings-> overlay settings -> overlay preset -> wii -> scanlines.cfg
    -go to shader options under options -> shader options -> shader passes and set to “1”.
    -under shader 0, select “sharp-bilinear.glsl”
    -under shader 0 filter, select “linear”
    -leave shader 0 scale at “don’t care”
    -select “apply shader changes”

    You can adjust the scanline darkness by adjusting overlay opacity. I like darker scanlines so I set opacity to “1.00” This does make the picture darker, so I also had to crank up the backlight on my display.

    I gotta say, using the scanline overlay actually looks pretty good, and has the advantage of running in 1080p without slowdown. It seems to have slightly less input lag than using shaders as well. It looks pretty comparable to using an XRGB-mini.

    ekdor
    Participant
    Post count: 71

    Can you get shaders like this for advanceMAME? I seem to be having better results with it over Mame4all

    kitchuk
    Participant
    Post count: 207

    A list of recommended shaders, aspect ratio and settings for each system would be useful in the retropie wiki.

    patrickm
    Participant
    Post count: 171

    delete; merged posts

    kitchuk
    Participant
    Post count: 207

    Patrick,

    When playing CPS (MvsC for example) games via FBA-Libretro and having the aspect at 4:3, do you find they are letterboxed with some minor black bars at the top and bottom? I have crop overscan ‘off’ and integer scale to ‘on’. It’s really bugging me. Any ideas?

    patrickm
    Participant
    Post count: 171

    [quote=96313]Patrick,

    When playing CPS (MvsC for example) games via FBA-Libretro and having the aspect at 4:3, do you find they are letterboxed with some minor black bars at the top and bottom? I have crop overscan ‘off’ and integer scale to ‘on’. It’s really bugging me. Any ideas?
    [/quote]

    Cps games used special monitors that put out 224 horizontal lines, I think. That’s why you will always get letterboxing with integer scaling on, because 224 won’t divide evenly into 1080 or 720. You can stretch the image using your TV remote to compensate for this, that’s what I’ve been doing with games that have weird resolutions. You can also cover up the letterboxing with an overlay. I don’t know of a better solution. Turning integer scale off will give you some unequally scaled pixels, but you might not notice with the right shader.

    patrickm
    Participant
    Post count: 171

    At this point, it looks like there might be a bug with crop overscan in the SNES9X Next core. Turning it on results in letterboxing, which is the opposite of what should happen. Turning it off results in uneven pixel scaling.

    Not sure what’s up with PicoDrive- it’s impossible to get even pixel scaling at resolutions higher than 640×480. This is not a huge deal because the Genesis itself doesn’t look any better at higher resolutions, and the scanline overlay works fine at that resolution. However, most of the shaders need HD resolution so they won’t work at that resolution. Also, it looks like crop overscan doesn’t do anything at all with PicoDrive.

    bazola
    Participant
    Post count: 42

    Why don’t you use genesis plus gx instead of picodrive?

    ekdor
    Participant
    Post count: 71

    Where can you get shaders? The crt directory you show doesn’t exist for me “RetroPie 2.6” I looked through the shaders and I didn’t see your recommendations either.

    Just wanted to add that my
    input_shader_prev
    input_shader_next
    tags often cause my emulator to exit. Only tried it with Sega MasterSystem so far. I checked for conflicts and tried different key-maps with no change. Anyone know what this is about?

    ekdor
    Participant
    Post count: 71

    Ahh found shaders converted for Arm here: Common Shaders for ARM

    mccoy
    Participant
    Post count: 2

    patrickm all settings that u have in your post you got from retroarch emulator while runing it? could you also share the settings u have made to your retroarch.cfg in configs/all directory?

    patrickm
    Participant
    Post count: 171

    [quote=96585]patrickm all settings that u have in your post you got from retroarch emulator while runing it? could you also share the settings u have made to your retroarch.cfg in configs/all directory?

    [/quote]

    overlay_directory = “/opt/retropie/emulators/retroarch/overlays”
    input_overlay = “/opt/retropie/emulators/retroarch/overlays/wii/scanlines.cfg”
    input_overlay_enable = “true”
    input_overlay_opacity = “0.700000”
    input_overlay_scale = “1.000000”

    I’m not sure what lines to add to set the sharp-bilinear shader, the config just refers to “retroarch.glslp,” so I think this has to be set through retroarch. Just do the following:

    options -> shader options -> shader passes -> “1”
    shader 0 -> “sharp-bilinear.glsl”
    shader 0 filter -> “linear”
    apply settings.

    I am also pretty sure that all cores are set to a render resolution of 640×480 by default, so you don’t really need to change your resolutions unless something doesn’t look right (i.e., if the scanlines aren’t lining up with the pixels correctly).

    jamesandjome-com
    Participant
    Post count: 46

    Hello based on your feedback I tried the above however I do not have the options of “wii scanlines or “sharp-bilinear.

    Is this because I am on version 2.6 or because I am trying this on the PSX emulator?

    kitchuk
    Participant
    Post count: 207

    Patrick, any luck getting Doom fullscreen with integer on?

    patrickm
    Participant
    Post count: 171

    [quote=96827]Hello based on your feedback I tried the above however I do not have the options of “wii scanlines or “sharp-bilinear.

    Is this because I am on version 2.6 or because I am trying this on the PSX emulator?

    [/quote]

    The latest version installed by the Retropie setup script has the needed files. Or you can follow the link in one of the above posts: https://github.com/gizmo98/common-shaders

    My recommendation is to just use the CRT-Hyllian shader, it’s easier and looks great.

    options -> shader options -> shader passes set to 1
    shader 0 -> CRT-Hyllian
    apply settings.

    Set RA resolution to 960×720.

    If Hyllian is too heavy for your taste, try Caligari. Caligari is closer to a consumer-grade CRT whereas Hyllian is more like a professional-grade CRT. Caligari also has the aperture grill simulation, if you’re into that.

    patrickm
    Participant
    Post count: 171

    [quote=96834]Patrick, any luck getting Doom fullscreen with integer on?

    [/quote]

    Nope, it has the same problem as CPS games, it had a unique resolution. In this case, 320×200. So you’re always going to get letterboxing on a 720p or 1080p display.

    There are some 1080p displays that are 1200 pixels wide, if you could find one of those you could play Doom at fullscreen with integer scaling :)

    edit: scratch what I said about stretching things with your TV remote. This WILL scale your content and result in artifacts, contrary to what I initially thought. It’s just that my TVs scaler does it so well that the artifacts are very slight; they only become noticeable when the screen is scrolling vertically, at which point it’s awful :(

    You just have to live with letterboxing sometimes with a fixed-pixel display with integer scaling on, it seems like.

    patrickm
    Participant
    Post count: 171

    [quote=96368]Why don’t you use genesis plus gx instead of picodrive?

    [/quote]

    This is what I’m doing now in order to get the hyllian shader to work. I’m now recommending that people use Genesis Plus GX, until the scaling issues with picodrive are resolved. Added to the OP. Thanks!

    edit: well, Genesis Plus GX has problems, too. It seems to completely ignore crop overscan setting, and always crops.

    There appears to be a few bugs with crop overscan in many of the cores, and picodrive has problems with even scaling at resolutions above 640×480. I’ll be reporting these issues to the developers.

    InsecureSpike
    Participant
    Post count: 571

    guy’s do you have any shader suggestions for NeoGeo? I’m using lr-fba

    thanks

    Floob
    Member
    Post count: 1629

    [quote=96965]guy’s do you have any shader suggestions for NeoGeo? I’m using lr-fba

    thanks
    [/quote]

    I use the 50% scanline option in gngeo – although I imagine there will be a better option within libretro/retroarch.

    InsecureSpike
    Participant
    Post count: 571

    [quote=96967]

    guy’s do you have any shader suggestions for NeoGeo? I’m using lr-fba

    thanks

    I use the 50% scanline option in gngeo – although I imagine there will be a better option within libretro/retroarch.

    [/quote]

    thank you floob

    kitchuk
    Participant
    Post count: 207

    For lr-Fba I find the crt-Hyllian glow shader looks amazing. Integer on, core provided aspect. It looks like a top notch Sony CRT.

    InsecureSpike
    Participant
    Post count: 571

    thanks kitchuk

    patrickm
    Participant
    Post count: 171

    added another method for getting scanlines to the OP:

    “interlacing.glsl” found in the “misc” folder. This is my new favorite, looks pretty much exactly like a Sony BVM, but better.

    A BVM had 900 lines of horizontal resolution, completely black scanlines, and an almost invisible aperture grill. In other words, using interlacing.glsl on a 1080p display will look almost identical to using a Sony BVM. Since every other line is blanked, you need to crank up the backlight to compensate for the lack of brightness. Enjoy :)

    patrickm
    Participant
    Post count: 171

    [quote=96834]Patrick, any luck getting Doom fullscreen with integer on?

    [/quote]

    I played around with this some more and you can get pretty close to fullscreen if you set your TV/monitor output resolution to 1080p, turn on integer scale and use a custom resolution of 1280×1000. I think you can also choose “core provided” as aspect ratio and this does this same thing. This gets you pretty close to fullscreen- just 40 pixels on the top/bottom on a 1080 display.

    patrickm
    Participant
    Post count: 171

    Bump, completely new method and rationale in OP, everything old was wrong :P

    ekdor
    Participant
    Post count: 71

    Are you referring to your previous post compared to the OP? If not, share.

    I can’t get any of the custom shaders to work in either of my name emulators. I’ve set the x2 horizontal scalene internally. It’s ok but not as nice as what I setup for retroarch.

    patrickm
    Participant
    Post count: 171

    [quote=97474]Are you referring to your previous post compared to the OP? If not, share.

    I can’t get any of the custom shaders to work in either of my name emulators. I’ve set the x2 horizontal scalene internally. It’s ok but not as nice as what I setup for retroarch.

    [/quote]

    I completely replaced the instructions in the OP with a new set of instructions and a new method. I’m now recommending that a scanline overlay be used in lieu of shaders. I provided my rationale in the OP, along with my scanline overlay and instructions for use. This will also work with other emulators and should work at different scales. Enjoy :)

    ekdor
    Participant
    Post count: 71

    Cool, Will check it out.!

    patrickm
    Participant
    Post count: 171

    Updated OP; added “dotmask” shader to recommendations.

    patrickm
    Participant
    Post count: 171

    bump; added 5x scale scanline overlay (1920×1080). Also added step-by-step instructions.

    dragonjab
    Participant
    Post count: 27

    on your first method step 5 you forgot to add retroarch to the subdirectory.
    /opt/retropie/emulators/retroarch/overlays/effects/scanlines

    dragonjab
    Participant
    Post count: 27

    [quote=97759]bump; added 5x scale scanline overlay (1920×1080). Also added step-by-step instructions.

    [/quote]
    How do I make the changes permanent. I try to go back on the RGUI and hit on the save new config option and nothing happens. Once I restart the emulator it goes back to the old settings.
    By mistake I change on the RGUI the configurations to the retroarch.cfg file is that ok? How do I change back to the old libreto field

    patrickm
    Participant
    Post count: 171

    [quote=98021]

    bump; added 5x scale scanline overlay (1920×1080). Also added step-by-step instructions.

    How do I make the changes permanent. I try to go back on the RGUI and hit on the save new config option and nothing happens. Once I restart the emulator it goes back to the old settings.
    By mistake I change on the RGUI the configurations to the retroarch.cfg file is that ok? How do I change back to the old libreto field

    [/quote]

    You can make settings stick by navigating to the right config file in /opt/retropie/configs/ and find the right emulator folder. Within each emulator folder there is a “retroarch.cfg” which has settings which overwrite the global settings. Any settings which you wish to make permanent should be added there. There should also be an “emulator-name.cfg” in each emulator folder. You can rename this to “retroarch.cfg” and it will be loaded next time you launch RA.

    dragonjab
    Participant
    Post count: 27

    [quote=98026]

    bump; added 5x scale scanline overlay (1920×1080). Also added step-by-step instructions.

    How do I make the changes permanent. I try to go back on the RGUI and hit on the save new config option and nothing happens. Once I restart the emulator it goes back to the old settings.
    By mistake I change on the RGUI the configurations to the retroarch.cfg file is that ok? How do I change back to the old libreto field

    You can make settings stick by navigating to the right config file in /opt/retropie/configs/ and find the right emulator folder. Within each emulator folder there is a “retroarch.cfg” which has settings which overwrite the global settings. Any settings which you wish to make permanent should be added there. There should also be an “emulator-name.cfg” in each emulator folder. You can rename this to “retroarch.cfg” and it will be loaded next time you launch RA.

    [/quote]
    well yeah I know how to do that. I set a permanent shader for my snes emulator. What I want to know is that why when I follow your steps I save it in the RGUI and once I exit out of any particular emulator my previous settings of adding the scanlines, filters and scaling are erase. Once I start the emulator again I have to go and go through your steps once again. Do you happen to know the code that I have to write in the retroarch.cfg file to make the steps from your original post permanent for my nes, snes, and megadrive. Also when I apply your scanline file on the RGUI I don’t see a difference on the nes or snes emulator. Also how do you apply the dotmask filter plus the scanline file that you provided together. If I go to options and filters I don’t see that particular filter. All your help is appreciated, thanks.

    Floob
    Member
    Post count: 1629

    Add the extra lines into the existing system retroarch.cfg (at the top), dont rename one to be retroarch.cfg.

    I’ll try to do a video soon.

Viewing 35 posts - 36 through 70 (of 119 total)
  • The forum ‘Video Output on RetroPie’ is closed to new topics and replies.