Forum Replies Created

Viewing 9 posts - 141 through 149 (of 149 total)
  • Author
    Posts
  • patrickm
    Participant
    Post count: 171

    I just tested the recommended settings using the hyllian glow shader with Cave Story and it runs at a perfect 60 fps and looks incredible. :) The fantastic pixel art in this game really benefits from a good CRT shader.

    patrickm
    Participant
    Post count: 171

    [quote=94040]

    <div class=”d4p-bbt-quote-title”>InsecureSpike wrote:</div>
    many thanks to “Patrick” for this post, as I’ve found this real
    oh just a quick question, are shaders set for each individual emulator or universal, one for all?

    I also would like to know the answer to this.

    On a probably-related note, in Floob’s reply, what is the purpose of the line:

    input_remapping_directory = /opt/retropie/configs/megadrive/

    in the provided configuration file?
    [/quote]

    you can make the video settings universal by holding down “x” or “m” as a game launches from emulationstation to bring up a menu. This gives you a menu of options like “choose default emulator” “choose video resolution” “choose Retroarch output resolution,” etc.

    For the shader settings, by default, if you load a shader in RA and then exit normally it will save your shader settings and these will be applied next time you launch RA. You can set a shader through the RGUI or by editing the config file in text editor.

    You can also manually edit the config in /opt/retropie/configs/all/retroarch.cfg to make the settings universal. If you want to make different settings for each system, then edit the file called “retroarch.cfg” located in the folder for that particular system in /opt/retropie/configs/.

    The easiest way is to just load the shader through the RGUI and then exit RA normally (by default, start + select on the gamepad).

    As far as the line you were asking about, I’m pretty sure that is related to controller input and not video settings.

    patrickm
    Participant
    Post count: 171

    [quote=94021]What i found really interesting from author of this post is that I also found crt caligari and crt hyllian lq best crt shaders for pi.
    Therefore i think they are a little demanding for the systems now, so i switched for scale2x shader. This is a shader i suggest, not heavy and add a little more resolution feeling to games, without blurry them. Give it a try[/quote]

    Actually, I wasn’t referring to crt hyllian lq, although that one is pretty decent.

    You should check out the shader in /shader/crt/hyllian-glow/hyllian.glsl or something like that. There is another shader called “hyllian.glsl” in the main shader directory that causes significant slowdown/stutter, but the one in the /shader/crt/hyllian-glow/ directory looks almost identical and runs perfectly smooth! It’s confusing because both shaders have the same name, but are located in different places and are actually different shaders.

    If I had to rank the shaders, my “top 5” would be:

    1. crt-hyllian-glow
    2. crt-caligari
    3. crt-hyllian-lq
    4. sharp-bilinear-scanlines w/bilinear filter
    5. ntsc-pass-4 w/bilinear filter

    I should mention that I’m running this on a Raspberry Pi 2, but I assumed that this wouldn’t make a difference since it has the same GPU as the Pi 1. I’ve chosen the “Pi 2” overclock setting and set GPU memory to 256mb.

    Personally, I would avoid that scale2x shader as it doesn’t correct scaling on the x axis which means you get inconsistently-shaped pixels, nor does it produce scanlines.

    patrickm
    Participant
    Post count: 171

    [quote=94007]That looks good, I’ll try them out.

    Here is the shader you recommend (I need to sort my TV colour out):

    [/quote]

    I think you’ll be pleased :) If the scanlines are too dark for your taste then I would try caligari next.

    You can often find TV settings on CNET by googling “(model number) picture calibration settings” or something similar. If you can’t find any settings, then I would do the following:

    As far as adjusting color is concerned, the easiest thing to do is to adjust the color temperature and/or gamma.

    If you have a “color detail adjustment” option or something similar, choose the Rec 709 standard. If there’s a “gamma detail adjustment” choose 2.2.

    If there is a “color temperature” adjustment, set it to Warm2 or whatever the warmest setting is.

    To adjust color more finely than that, look up settings on CNET or download free software from the internet. There are sites where you can download free DVDs for this purpose.

    To adjust brightness, put on a dark movie like Batman Begins or something and go to a very dark scene and pause. Set brightness to the lowest level at which all detail is still visible. Now find something with a very bright scene – clouds, snow, and the folds on white curtains or dress shirts work well. You want to set contrast at the highest point at which all the detail is still visible.

    If you have a backlight setting you can adjust this without affecting brightness/contrast, just set it to whatever looks good.

    This might be obvious but you should also turn on your TV’s game mode and also disable all of the so called “enhancements” such as motion smooth, vivid color, noise reduction, etc.

    Hope this helps :)

    patrickm
    Participant
    Post count: 171

    I’m using the “Pi 2” setting on my Pi 2. I don’t think there’s any appreciable difference between this setting and “turbo,” except that turbo is a lot less stable and causes my pi to freeze at startup.

    I think turbo is like 100mhz faster or something. Not really worth it IMO. PSX runs at 100% speed with the hyllian glow shader, I’m a happy camper. :)

    patrickm
    Participant
    Post count: 171

    [quote=92681]I hope it doesn’t, i have it set on 0 with all retroarch based emulators and haven’t noticed anything wrong yet…[/quote]

    just found out from one of the developers that hard gpu sync doesn’t make a difference unless you’re running from within a desktop environment. Otherwise, linux automatically does what hard gpu sync does. Since retropie is set up to run outside of the desktop, hard gpu sync won’t make a difference.

    patrickm
    Participant
    Post count: 171

    [quote=92635]are you using the newest update? The newest update has added functionality to be able to choose an emulator without needing to go through configuration files and whatnot.

    If you update your setup script:

    cd RetroPie-Setup
    sudo ./retropie_setup.sh
    update setup script
    sudo reboot

    Full Binary Install

    
    cd RetroPie-Setup
    sudo ./retropie_setup.sh
    full binary install
    sudo reboot

    Then once it reboots again when you open up into a game you can hold down x or m and there will be a default emulator option- select that and choose the emulator of your preference.

    This video at about 5 minutes shows the new functionality in use.

    <span class=”embed-youtube” style=”text-align:center; display: block;”><div class=”fluid-width-video-wrapper” style=”padding-top: 61.165048543689316%;”>[youtube http://www.youtube.com/watch?v=eM9BB9v9288?version=3&rel=1&fs=1&showsearch=0&showinfo=1&iv_load_policy=1&wmode=transparent%5D</div></span&gt;

    [/quote]

    Got it working, thanks dude! Didn’t even know I had that option.

    patrickm
    Participant
    Post count: 171

    [quote=92634]There are TONS of videos explaining this kind of very simple thing. Keep looking.[/quote]

    sorry man, I spent like an hour on it and I tried a solution that only worked for the old rasp pi, then I gave up and came here :P

    patrickm
    Participant
    Post count: 171

    did you use the retropie setup utility to configure the controller?

    try this

    cd RetroPie-Setup
    chmod +x retropie_setup.sh
    sudo ./retropie_setup.sh

    go to “setup/configuration” and then “register retroarch controller”

Viewing 9 posts - 141 through 149 (of 149 total)