Forum Replies Created

Viewing 35 posts - 106 through 140 (of 149 total)
  • Author
    Posts
  • patrickm
    Participant
    Post count: 171

    [quote=97474]Are you referring to your previous post compared to the OP? If not, share.

    I can’t get any of the custom shaders to work in either of my name emulators. I’ve set the x2 horizontal scalene internally. It’s ok but not as nice as what I setup for retroarch.

    [/quote]

    I completely replaced the instructions in the OP with a new set of instructions and a new method. I’m now recommending that a scanline overlay be used in lieu of shaders. I provided my rationale in the OP, along with my scanline overlay and instructions for use. This will also work with other emulators and should work at different scales. Enjoy :)

    patrickm
    Participant
    Post count: 171

    Bump, completely new method and rationale in OP, everything old was wrong :P

    patrickm
    Participant
    Post count: 171

    [quote=97434]Excuse me if I wrote something that was not meant that way. I’m german and don’t always know the right wording. I did not want to upset you. ?

    You’re right , on the hill , you can see very few emulated pixels that are a little less wide.
    But you have really search for it and you notice it only if you know what to look .

    Also in SNES Zelda the first dungeon.
    But with smooth and my overlay, it falls on even less.

    For you it’s necessary that every pixel look absolutely identical.
    For me it’s necessary that the overall image simply looks good.
    But that’s a matter of opinion, any way he likes.
    Similarly the darkness of the scanlines, to me it looks to darken, no matter how I adjust the brightness.
    With the sharpness of your image there looks to me to blocky.

    You might also right about the high end TV, but i never played any console on a high end TV. Did you?
    99,99% of all people only played on a consumer grade CRT with this “softness”.
    All this is the reason why the overall image of a console like SNES, Genesis… looks more uniform and better on a CRT than on a LCD without filter or shaders ….to me ?
    Sure, there exists better CRT shader as an overlay image, but the pi can’t handle these.

    Actually it was originally indeed about why the whole picture is very dark with your overlay images, it’s because of your resolution settings and the resolution of your overlay image. ?

    Sorry but neither with the sharp-bilinear shader nor with the pixelate shader
    I see any difference, no matter what settings…?
    Maybe you can post a picture on you see the differences?

    I now have my original SNES connected and then I realized that I had totally forgotten about the PAL borders. ?
    Thus, the aspect ratio at all is no longer correct (1.63) and the individual pixels are also wider to see it there.

    More example pictures:
    Example Images Dropbox

    [/quote]

    Don’t worry, you didn’t offend me, it’s just that this whole topic is very contentious and people have a tendency to argue about it for pages and pages :) don’t worry about your English, either- it’s certainly better than my German! This post is going to be long, so I apologize in advance :)

    You say you have to really look for the warped pixels. This might be true if you are sitting far enough from the display/have a small display. The warped pixels look especially bad when objects are scrolling, but you might not notice this on a crappy LCD with a lot of motion blur (as most LCDs have). I have a tendency to really scrutinize images because I’m obsessed with picture quality. Once I see these things, I can’t unsee them, and they become a real distraction.

    Most image purists/ videophiles will agree that scaling artifacts are the cardinal sin, to be avoided at all costs. This is because, aesthetically, it is worse to warp sections of an image by different amounts than it is to warp the entire image by one amount. But you’re right that this is not 100% objective.

    As far as the image appearing too dark, it is probably a problem with your display if it hasn’t been properly calibrated. EDIT If you aren’t used to viewing a calibrated image, than it might appear too dark. Also, you might be forgetting how dim CRTs were. An LCD is more than bright enough to have 100% black scanlines (reducing the effective backlight by 50%) and still be brighter than a CRT was.

    The way scanlines work is that the higher the contrast between the scanline and the “drawn” lines, the greater their effect. Scanlines work like a pointillist painting: at the right distance, the human visual system blends the image and it results in a smoother image than actually exists. This effect is achieved more easily when the “gaps” are more easily recognized as such. I’m fairly certain that this could be confirmed via psychological experiment, if it hasn’t been already.

    Another thing to consider is that each improvement to CRT technology brought images that were sharper, brighter, and had darker scanlines. First you had regular shadow mask CRTs. Then dotmasks came which allowed more light to pass through and had a less noticeable mask. Then you had aperture grills, which allowed even more light to pass through and were even sharper, with an even less noticeable mask. Then you had the king of CRTs, the Sony BVM, which had an almost invisible aperture grill, 900 lines of horizontal resolution (close to today’s 1080p displays), and was even brighter and sharper. The result is those perfect scanlines that die-hards covet.

    The overall point is that CRT quality has always varied very widely, so the graphic artists didn’t have a single use case that they could base their designs on. Sure, most people didn’t have BVMs, but a lot of people had Trinitrons, which were significantly brighter and sharper than standard shadow mask CRTs.

    Another point is that trying to replicate the eccentricities of a CRT on an LCD is just hard to pull off without looking fake. The CRT shaders are computationally demanding and won’t run on the raspberry pi, and they require a lot of tweaking to look right IMO. Even then, they are going to add an amount of input lag dependent on your processor speed.

    I guess I only like scanlines because they filter the image while still looking authentic to me. All the other effects look like an LCD trying to be a CRT and it feels inauthentic. The worst offender in this regard IMO is the screen curvature effect. I played on all kinds of TVs with curved tubes, and I never recall any curvature like what I’ve seen shaders do. This is because a curved CRT was calibrated so that the image looked square/flat when viewed from a normal angle. A lot of the CRT effects look like an artist’s interpretation of a CRT to me.

    Now, back to the original topic (!) :)

    You said the darkening problem with the overlay was due to the size, that’s also what I suspected, so thanks for confirming that.

    I’m sorry, I neglected to mention that when you choose sharp-bilinear you need to set shader filter to “linear” for it to work. Pixellate won’t run on the pi because it is too demanding.

    Yup, PAL games all had those black borders on all systems. This is because PAL TVs were better, having 576 horizontal lines of resolution vs. NTSC’s 480 lines (a 20% higher resolution). The console only puts out 240 lines so everything over 480 winds up as a black border.

    patrickm
    Participant
    Post count: 171

    [quote=97390]You should not set up a Y resolution higher then the screen resolution.
    I use 1080p because then i have 4 pixels for each scanline and additional enough pixel for the TV border itself.
    I still don’t know what you mean with warped pixels on the X axis.
    I can’t see any difference between 1194×896 and 960×720
    You’re right the exact aspect ratio is 1194.66666 in the X axis but with 1194 every emulated pixel is 4,6640625 pixels on screen, not 1, in practice i can’t see the difference, especially with the scanlines[/quote]

    Having spent a LOT of time with this, and talking with various RA devs, I thought I should share what I’ve learned.

    Why should you not set a y resolution higher than the screen resolution? As I said, what gets cropped off is so minimal on SNES or Genesis that it would have been cropped off by a CRT anyway. With NES, it may seem like you’re losing a lot, but actually, the “safe zone” for CRTs was 90% of the total picture. With going to 1200 on the y axis, you lose 120 pixels, which at a scale of 5x translates to 24 NES pixels. The NES put out a total of 240 lines. 240 – 24 = 216, or 90%.

    You might not notice the artifacts on the x axis because they are small at the resolution you’ve chosen, but they are there. Look at the mini map in the upper right of the screen on Super Metroid. You will notice some individual pixels are wider than others. You probably didn’t notice because most of the warping occurs at the edges as you get closer to integer scale. Scaling artifacts completely ruin the image for me, so getting rid of them is my top priority. Or check out the first hill in super Mario bros at the title screen, at the diagonal edge line. You will see inconsistently-sized pixels.

    Would you mind providing a screenshot?

    [quote]Also most shader have either more or less recognizable effects on the emulator speed. For example SNES Yoshis Island first level, first cave.
    The sharp-bilinear.glsl do nothing at least on my tests.
    Instead i use the video_smooth option in the retroarch.cfg.
    The same with the pixellate filter.[/quote]

    The very purpose of the pixelate shader is to allow you to keep your 4:3 aspect ratio while eliminating scaling artifacts. Sharp-bilinear adds a very slight horizontal blur to deal with artifacts on the x axis. You wouldn’t notice them doing anything if you already are not noticing the artifacts in your picture.

    Video smooth should be avoided as it just adds bilinear filter, which causes blurring and a loss of detail. You would need a broken CRT for it to look like the picture with bilinear filter. Most videophile retro gamers will advise you to avoid using it.

    [quote]In my opinion the pixel edges and the scaliness itself in your example looks too sharp and too dark for me, it looks not really realistic.[/quote]

    I don’t want to get into a battle over opinions, if you have found a look that makes you happy, great.

    I don’t really see what you mean by too dark, are you sure your display is properly calibrated? I put the scanlines at 50% for an effective 25% reduction in brightness, so you need to turn the backlight up to 100% on your display for an effective 75% backlight.

    Realistic isn’t really possible without CRT shaders, but even those just wind up looking fake to me most of the time, and most don’t work on the raspberry pi. For the pi, I just go for a clean emulated look with scanlines to soften the edges a bit. Actually, this picture is almost indistinguishable from a high end Sony BVM :) It’s also very similar to using an upscaler with original hardware. The “softness” of a consumer grade CRT was due to flaws in its manufacture. An ideal “perfect” CRT with no manufacturing flaws would indeed look like the above shot, but brighter, and the scanlines would be 100% black and sharp.

    Most of the time when people go for “authentic” it just looks fake and distracting to me. I’m going for overall picture quality over authenticity. I never really understood why people went for authenticity over quality. If you want authentic, why not just play on an old CRT? Can’t get any more authentic than that, and you can get one for free these days. Trying to replicate all the flaws of a CRT on an LCD is silly to me.

    [quote]My TV border isn’t 100% finished yet, it’s a bit too much curved, so in some games too much of important image details are lost, but i like it ?

    Here you can download some fullscreen scanline overlays and another with a TV Border
    https://www.dropbox.com/sh/sicv3m5yp7ztg7u/AAAoJH6AxlKmvWKyAAMGSu8ja?lst

    And here is the Youtube Video:
    https://www.youtube.com/watch?v=Xu5lLfJmJVY

    [/quote]

    Thanks! I’ll check those out, as I’m still having trouble getting my overlay the right size. I figured out how to do transparency, at least.

    patrickm
    Participant
    Post count: 171

    [quote=97345]1. Why? While the aspect ratio is 4:3 all is fine.
    If it’s not exactly a 4:3 aspect ratio without the scanline overlay it may look a bit scrappy, but with the scanlines all looks great.

    2. Here’s a link to my dropbox. Here you can download the overlay.
    Scanline Overlay

    3. You’re right. It depends on the emulator. PAL NES is always 240 lines. NTSC is 224 + 2 x 8 “hidden” lines = 240.

    Currently i upload a video on Youtube.
    I’ll post later a link.

    [/quote]

    I’m curious why you wouldn’t use 1280×960 for NES?

    If you use 896 for Y, then X is 1194.6666… if X and Y are in a 4:3 ratio. This would cause some warped pixels on the X axis, right? I’d rather play with a slightly off aspect ratio than have warped pixels anywhere.

    Edit: Ah, I see you were probably referring to SNES and Genesis. Those systems do look good at 896 on the Y axis. However, you also need to use an integer multiple of the x axis to get perfect scaling. The following resolutions all look good, although none are in a perfect 4:3 aspect ratio.

    Genesis:
    960×896
    1280×896
    1280×1120
    1600×1120

    SNES:
    1024×896
    1280×896
    1280×1120
    1536×1120

    all look good to me, although you lose a little bit of the picture with the y axis at 1120. This isn’t that bad though, because it’s mostly the black bars that you lose. These resolutions will provide perfect pixel scaling on both x and y axes.

    1024 or 1280 on the x axis is good for most NES games, with the Y at 960.

    Some NES games look good at 1280×1200 or even 1536×1200. Castlevania, TMNT II and River City Ransom are examples. Super Mario Bros 3 also looks good at those resolutions, as most of what gets cropped off occurs within what would have been the overscan on a CRT, or close to it (I’ve compared my Sanyo CRT, and it crops a similar amount, which is close to the maximum amount for CRTs). Actually, many nes games look good at these resolutions if you don’t mind cropping slightly more than 100% of the overscan :) I have yet to encounter an NES game that placed in important graphics in the areas that get cropped off at these larger resolutions (6×5 and 5×5).

    Sorry, but I don’t like the TV box effect, I find it distracting. I just want simple scanlines. If I could just figure out this transparency stuff, I think I could do it. I haven’t found anything on the internet that explains this well.

    So, forgive me, but I’m still unclear on two things:

    1. how to turn white to transparency using gimp

    2. what size to make the overlay (example: my monitor is set to 1080p native and my custom viewport is 1280×960)

    as far as I understand it, you will get pixel warping on at least one axis if you disable integer scale. That is why I leave it ON at all times.

    To avoid pixel warping at 1080p, one has to enable integer scale and play with letterboxing (i.e., black bars at the top and bottom). This is at least true of NES, SNES, and Genesis.

    The pixellate shader and sharp-bilinear shader together will allow you to have a 4:3 ratio without pixel warping, but this is too intense for the Pi to run at 1080p.

    So, the only real solution if you want fullscreen (i.e., no letterboxing at top/bottom) AND a 4:3 ratio with these old systems, without any pixel warping, is to use a display that is 720p native (since 240×3 = 720)

    That, or use a machine that is more powerful that the Pi, so you can run pixellate + sharp-bilinear.

    I have provided an example image below (left click thumbnail, then right click and click open image to view at original size). This was achieved with 1280×960 resolution, integer scale on, at 1080p. The “interlacing.glsl” shader was used to make the scanlines, with the scalines strength configured at 50%. I would like to be able to achieve the exact same effect using an overlay, since it would be faster and would be adjustable within the RGUI. Another disadvantage (of the interlacing shader) is that it requires 2x or 4x scale.

    Sorry for the huge wall of text :)

    patrickm
    Participant
    Post count: 171

    [quote=97296]I disable integerscale, instead i calculate the resolution by myself for a 4:3 aspect ratio.
    The X resolution doesn’t matter for the custom_viewport.
    The overlay relolution should be the same as the video_fullscreen until: input_overlay_scale = 1 in the system config,
    overlay0_full_screen = true in the overlay config file.
    Otherwise the number of Y pixels of each scanline for each emulated Y pixel is no longer correct and the whole image looks badly.

    [/quote]

    1. I don’t understand- if you turn integer scale off, you could get pixel warping on one or both axes.

    If you manually adjust custom viewport to 4:3, won’t you get scaling artifacts on the x axis?

    If 896 is the y axis, 4:3 would be 1194.666667: 896; so you will get some warping on the x axis. Or have I misunderstood something?

    2. So, the overlay has to match the resolution of the game/system that is being played. I suck at using graphics programs. I figured out how to tile a .png to make a scanline overlay, but I still can’t figure out how to add transparency. I always wind up with transparent white instead of full transparency.

    3. Are you sure NES is 224 lines wide? I looked up the native res and found 256×240 on Wikipedia. I think it’s 240×224 without padding, but 256×240 with padding, which was cropped by the TV.

    patrickm
    Participant
    Post count: 171

    [quote=97286]Genesis (and PSX, MasterSystem, limited NeoGeo and a view others) have a native resolution of 320×240. That’s a native 4:3 aspect ratio.
    SNES, NES have 256×224, but on a CRT the X axis is stretched to fit a 4:3 aspect ratio.
    So my custom_viewport aspect ratio settings also is 4:3.
    And for each Y pixel of the game image, i have 4 Y pixels for the scanlines image. 224 x 4 = 896
    I also use this settings for all emulators like Genesis and so on, technical it doesn’t fit the resolution of the scanline image because of the TV border, but it also looks really great.
    If you don’t want a TV border, you can also enlarge the resolution to the whole screen of course but the Y Resolution should be a multiple of 3 or 4, so you can use 3 or 4 pixel for each scanline. Then you will have black borders on the Y axis, bit otherwise it looks horrible if you use the whole screen resolution, for example on a Full HD 1080 (/ 240=4,5) because every second scanline have 4 or 5 Pixels.

    [/quote]

    With SNES I set the resolution to 1280×896
    My video output resolution is at 1080p

    Is this the closest I can get to a 4:3 ratio while also using as much of the screen as possible @ 1080p with integer scale on?

    Also, if I’m using 1080p as my output resolution, should I create an overlay for 1920×1080, or should I create an overlay to match the game resolution (1280×896)?

    patrickm
    Participant
    Post count: 171

    [quote=97242]Hello,

    I haven’t testet it yet, but it should be because of the resolution of your scanline images and the screen resolution of the emulation settings (640×480?)
    The best experience for me ist video_fullscreen_x and video_fullscreen_y should be the same as the screen resolution.
    the scanline image also should be the same resolution.

    And the scanlines should be something like this:
    1. line White
    2. line lighter Grey
    3. line darker Grey
    4. line black

    The strength of the opacity could be set up in the overlay setting of retroarch or you can insert an alpha channel to the image.
    Both adjust how dark the screen is at the end.

    Example config with a 16:9 TV border from google but edited by me:
    video_shader_enable = false
    video_fullscreen_x = 1920
    video_fullscreen_y = 1080
    custom_viewport_width = 1194
    custom_viewport_height = 896
    custom_viewport_x = 363
    custom_viewport_y = 87
    aspect_ratio_index = 22
    input_overlay = /opt/retropie/emulators/retroarch/overlays/16-9/TV_16-9.cfg
    input_overlay_enable = true
    input_overlay_opacity = 1.000000
    input_overlay_scale = “1.000000”
    video_smooth = true

    It’s faster then a shader and looks better for me on pie.

    [/quote]

    Awesome, thanks for the info. I’ll give it a shot with an overlay that matches the resolution I’m using.

    I’m curious, have you been able to get even pixel scaling in a 4:3 aspect ratio with NES, Genesis, or SNES? So far, I’ve only been able to get perfect scaling by using a custom resolution that is an integer multiple of the native res, which results in a different AR than 4:3 (because the native res is not 1×1)

    Seems like the only way to deal with artifacts when playing these systems in the original aspect ratio is with a CRT shader like Hyllian. Is this right?

    patrickm
    Participant
    Post count: 171

    [quote=97217]ok what shader do you want this tested with?
    if you wanna make this a controlled test?

    edit: and what system?

    [/quote]

    Shader: none

    System: NES

    It should work at any scale factor, but when I try to use them, they just make the screen darker instead of showing scanlines.

    patrickm
    Participant
    Post count: 171

    bump; is there a person familiar with graphics editing that wants to contribute to the project?

    patrickm
    Participant
    Post count: 171

    [quote=97171]i did not found “Custom Viewport” in retroarch.cfg, any help?

    [/quote]

    custom_viewport_width

    custom_viewport_height

    patrickm
    Participant
    Post count: 171

    [quote=97165]do you know how i set these options directly in the *.cfg files?

    [/quote]

    Look for “integer scale” should be on
    “Crop overscan” should be off
    “Custom viewport” x and y
    “Video fullscreen” x and y

    patrickm
    Participant
    Post count: 171

    [quote=97141]Hello
    Iv’e try to other games, it’s not very good but no lines.
    on tekken 3 and few games, lines always.

    in my retroarch.cfg in “all” :

    
    video_smooth = true
    video_threaded = true
    aspect_ratio_index = 6
    video_scale_integer = true
    rgui_show_start_screen = false
    

    in retroarch in “psx” :

    
    video_shader_enable = true
    rewind_enable = false
    video_smooth = true
    

    Thanks for help

    [/quote]

    What is your video output resolution set to and what is retroarch render resolution set to? Hold down x or m when launching a game to bring up these options.

    patrickm
    Participant
    Post count: 171

    [quote=96990]hello
    in shader, i haven’t CRT path.

    /opt/retropie/emulators/RetroArch/shader/

    it’s right ?

    [/quote]

    It should be there if you used the Retropie setup script. If not, you can download them here:

    https://github.com/gizmo98/common-shaders

    patrickm
    Participant
    Post count: 171

    [quote=96834]Patrick, any luck getting Doom fullscreen with integer on?

    [/quote]

    I played around with this some more and you can get pretty close to fullscreen if you set your TV/monitor output resolution to 1080p, turn on integer scale and use a custom resolution of 1280×1000. I think you can also choose “core provided” as aspect ratio and this does this same thing. This gets you pretty close to fullscreen- just 40 pixels on the top/bottom on a 1080 display.

    patrickm
    Participant
    Post count: 171

    added another method for getting scanlines to the OP:

    “interlacing.glsl” found in the “misc” folder. This is my new favorite, looks pretty much exactly like a Sony BVM, but better.

    A BVM had 900 lines of horizontal resolution, completely black scanlines, and an almost invisible aperture grill. In other words, using interlacing.glsl on a 1080p display will look almost identical to using a Sony BVM. Since every other line is blanked, you need to crank up the backlight to compensate for the lack of brightness. Enjoy :)

    patrickm
    Participant
    Post count: 171

    PSX graphics were very complex and designed to be displayed on a CRT. The sharpness of an LCD can make some of these graphics brutal to look at.

    Not all shaders will work with the Raspberry Pi. Try the “crt-hyllian” shader in /shader/crt/crt-hyllian-glow/hyllian.glsl
    (under options -> shader options)

    make sure your scaling is correct. Set RA render resolution to 960×720 and keep your monitor at its native resolution. Hold “x” when launching from Emulationstation to bring up the menu to change this.

    Set aspect ratio to “core provided” or “4:3”

    set integer scale on (under video settings)

    set crop overscan off (under video settings)

    that should be all you need. If CRT-Hyllian is too heavy for your taste, try CRT-caligari instead.

    also, you might try a different graphics plugin (under options -> core options)

    patrickm
    Participant
    Post count: 171

    [quote=96368]Why don’t you use genesis plus gx instead of picodrive?

    [/quote]

    This is what I’m doing now in order to get the hyllian shader to work. I’m now recommending that people use Genesis Plus GX, until the scaling issues with picodrive are resolved. Added to the OP. Thanks!

    edit: well, Genesis Plus GX has problems, too. It seems to completely ignore crop overscan setting, and always crops.

    There appears to be a few bugs with crop overscan in many of the cores, and picodrive has problems with even scaling at resolutions above 640×480. I’ll be reporting these issues to the developers.

    patrickm
    Participant
    Post count: 171

    [quote=96834]Patrick, any luck getting Doom fullscreen with integer on?

    [/quote]

    Nope, it has the same problem as CPS games, it had a unique resolution. In this case, 320×200. So you’re always going to get letterboxing on a 720p or 1080p display.

    There are some 1080p displays that are 1200 pixels wide, if you could find one of those you could play Doom at fullscreen with integer scaling :)

    edit: scratch what I said about stretching things with your TV remote. This WILL scale your content and result in artifacts, contrary to what I initially thought. It’s just that my TVs scaler does it so well that the artifacts are very slight; they only become noticeable when the screen is scrolling vertically, at which point it’s awful :(

    You just have to live with letterboxing sometimes with a fixed-pixel display with integer scaling on, it seems like.

    patrickm
    Participant
    Post count: 171

    [quote=96827]Hello based on your feedback I tried the above however I do not have the options of “wii scanlines or “sharp-bilinear.

    Is this because I am on version 2.6 or because I am trying this on the PSX emulator?

    [/quote]

    The latest version installed by the Retropie setup script has the needed files. Or you can follow the link in one of the above posts: https://github.com/gizmo98/common-shaders

    My recommendation is to just use the CRT-Hyllian shader, it’s easier and looks great.

    options -> shader options -> shader passes set to 1
    shader 0 -> CRT-Hyllian
    apply settings.

    Set RA resolution to 960×720.

    If Hyllian is too heavy for your taste, try Caligari. Caligari is closer to a consumer-grade CRT whereas Hyllian is more like a professional-grade CRT. Caligari also has the aperture grill simulation, if you’re into that.

    patrickm
    Participant
    Post count: 171

    [quote=96585]patrickm all settings that u have in your post you got from retroarch emulator while runing it? could you also share the settings u have made to your retroarch.cfg in configs/all directory?

    [/quote]

    overlay_directory = “/opt/retropie/emulators/retroarch/overlays”
    input_overlay = “/opt/retropie/emulators/retroarch/overlays/wii/scanlines.cfg”
    input_overlay_enable = “true”
    input_overlay_opacity = “0.700000”
    input_overlay_scale = “1.000000”

    I’m not sure what lines to add to set the sharp-bilinear shader, the config just refers to “retroarch.glslp,” so I think this has to be set through retroarch. Just do the following:

    options -> shader options -> shader passes -> “1”
    shader 0 -> “sharp-bilinear.glsl”
    shader 0 filter -> “linear”
    apply settings.

    I am also pretty sure that all cores are set to a render resolution of 640×480 by default, so you don’t really need to change your resolutions unless something doesn’t look right (i.e., if the scanlines aren’t lining up with the pixels correctly).

    patrickm
    Participant
    Post count: 171

    [quote=96281]Hello all,

    By hitting the hotkey button and F1 in game, you get access to (Retroarch?) menu.

    Going to Options >> Core Options and ensuring “Dynamic Recompiler” is enabled, PSX sound is absoulutley fantastic. Great.

    Now there is another option called “Enhanced Resolution” with a (Slow) warning. When enabled the graphics look absolutely amazing, however the sound then gets terrible.

    So I have everything I want, great sound, great graphics, but they will not work together.

    I have tried an aggressive overclock like this,

    force_turbo=1 #Voids Warranty!!!
    arm_freq=1100
    sdram_freq=500
    core_freq=500
    over_voltage=6
    temp_limit=80 #Will throttle to default clock speed if hit.

    and there was no improvement. Although shaders can be used they have nothing on the “Enhanced Resolution” setting.

    Has anyone figured out how to get both sound and graphics top notch?

    [/quote]

    The very best video output for all systems is IMO achieved by using the default core options with the scanline overlay and sharp-bilinear filter. This will give you a clean image with scanlines, similar to using an XRGB-Mini.

    go to settings -> overlay settings -> effects -> wii -> scanlines.cfg

    go to options -> shader options -> shader passes and select “1”. Go to shader 0 and select “sharp-bilinear.” Go to shader 0 filter and select linear. Select apply settings.

    make sure your scaling is correct! Enable integer scaling if you haven’t. You should immediately be able to tell if scaling is correct by just looking at some small text – some pixels will be warped/distorted as a result of bad scaling. The scanline overlay makes it easy to detect bad scaling, as the scanlines should always line up with pixel edges.

    Enhanced smoothing is the devil, you’re losing detail and introducing artifacts into the image, which is bad :P

    patrickm
    Participant
    Post count: 171

    At this point, it looks like there might be a bug with crop overscan in the SNES9X Next core. Turning it on results in letterboxing, which is the opposite of what should happen. Turning it off results in uneven pixel scaling.

    Not sure what’s up with PicoDrive- it’s impossible to get even pixel scaling at resolutions higher than 640×480. This is not a huge deal because the Genesis itself doesn’t look any better at higher resolutions, and the scanline overlay works fine at that resolution. However, most of the shaders need HD resolution so they won’t work at that resolution. Also, it looks like crop overscan doesn’t do anything at all with PicoDrive.

    patrickm
    Participant
    Post count: 171

    [quote=96313]Patrick,

    When playing CPS (MvsC for example) games via FBA-Libretro and having the aspect at 4:3, do you find they are letterboxed with some minor black bars at the top and bottom? I have crop overscan ‘off’ and integer scale to ‘on’. It’s really bugging me. Any ideas?
    [/quote]

    Cps games used special monitors that put out 224 horizontal lines, I think. That’s why you will always get letterboxing with integer scaling on, because 224 won’t divide evenly into 1080 or 720. You can stretch the image using your TV remote to compensate for this, that’s what I’ve been doing with games that have weird resolutions. You can also cover up the letterboxing with an overlay. I don’t know of a better solution. Turning integer scale off will give you some unequally scaled pixels, but you might not notice with the right shader.

    patrickm
    Participant
    Post count: 171
    patrickm
    Participant
    Post count: 171

    Added the following to the OP:

    Another option for getting scanlines:
    -set video output resolution to 1080 or native res and set retroarch render res to the same
    -use the “scanline” overlay preset. In RGUI, go to settings-> overlay settings -> overlay preset -> wii -> scanlines.cfg
    -go to shader options under options -> shader options -> shader passes and set to “1”.
    -under shader 0, select “sharp-bilinear.glsl”
    -under shader 0 filter, select “linear”
    -leave shader 0 scale at “don’t care”
    -select “apply shader changes”

    You can adjust the scanline darkness by adjusting overlay opacity. I like darker scanlines so I set opacity to “1.00” This does make the picture darker, so I also had to crank up the backlight on my display.

    I gotta say, using the scanline overlay actually looks pretty good, and has the advantage of running in 1080p without slowdown. It seems to have slightly less input lag than using shaders as well. It looks pretty comparable to using an XRGB-mini.

    patrickm
    Participant
    Post count: 171

    [quote=95927]I’ve noticed that when using the recommended settings in the first post, Snes seems to fill the screen whereas master system, megadrive does not. Is there a reason for this?[/quote]

    Sorry, I wasn’t able to replicate the problem on my system. Be sure to double check all settings. Hold “x” or “m” when launching a game to configure the video settings for that emulator – set video output to your monitor’s native resolution and set retroarch render res to 720. This has to be done for each emulator. Then enter the other settings via the retroarch GUI.

    patrickm
    Participant
    Post count: 171

    [quote=95234]

    <div class=”d4p-bbt-quote-title”>patrickm wrote:</div>
    Instead, change “Retroarch render resolution” to 720p.

    I can’t find this setting, is this only available in retropie 3.0?
    [/quote]

    I’m not sure; try holding down “m” or “x” on the keyboard as the game launches from EmulationStation, this should bring up a list of options. If not, then the options are buried in the config file somewhere. Let me know if holding down “x” or “m” when launching from ES doesn’t work.

    patrickm
    Participant
    Post count: 171

    [quote=95087]@all check if your video_fullscreen_x/y settings are 0. Otherwise your resolution will be upscaled. Hardware upscaling should be default enabled for rpi1 performance reasons.

    There will be a performance drop if you use a HD resolution with shaders.
    [/quote]

    Actually, I was wondering about this. I thought that since the RPi1 and RPi2 had the same GPU that they would be able to run the same shaders. Is this not the case, and do you know why not?

    So far I have not had any performance issues with my monitor set to 1080p and Retroarch’s render resolution at 720p on an RPi2.

    patrickm
    Participant
    Post count: 171

    important changes!

    First, keep your monitor in its native resolution! Changing your video output resolution can introduce input lag. I didn’t notice it at first, but when I switched back to 1080p from 720p for my video output resolution, the input lag reduction was noticeable (my monitor is 1080p native resolution).

    Instead, change “Retroarch render resolution” to 720p. This will achieve the same effect without the input lag. Keep “video output resolution” at whatever your display’s native resolution is.

    patrickm
    Participant
    Post count: 171

    [quote=95087]@all check if your video_fullscreen_x/y settings are 0. Otherwise your resolution will be upscaled. Hardware upscaling should be default enabled for rpi1 performance reasons.

    There will be a performance drop if you use a HD resolution with shaders.
    [/quote]

    Ah, I guess I should have made it more clear that I’m using a Rasp Pi model 2! I’d probably just go with “scanline” and a bilinear filter, or “sharp-bilinear-scanlines” (need to set filter to linear) if on the pi 1. I’m not sure the other shaders would look right in low res, but I haven’t tested them to see.

    patrickm
    Participant
    Post count: 171

    [quote=95046]Are you sure that this code is correct ?
    video_shader = /opt/retropie/emulators/retroarch/shader/crt/crt-hyllian-glow/crt-hyllian.glsl

    i guess, we have to use this instead :
    video_shader = /opt/retropie/emulators/retroarch/shader/crt/crt-hyllian-glow/crt-hyllian-glow.glslp

    We need to select the preset, not the shader. No ??
    [/quote]

    nope, just the single pass shader is what you want. The other component doesn’t work on the pi :)

    patrickm
    Participant
    Post count: 171
    patrickm
    Participant
    Post count: 171

    [quote=94999]Hello guys :)

    I’ve just buy a Rasperry pi 2, and it’s fantastic.
    But i try to have a good CRT look, but i have some problems.

    I have put my pi on 720p

    Did i miss something ?

    Thanks for ur help :)
    [/quote]

    edit: see Gizmo’s reply :)

    patrickm
    Participant
    Post count: 171

    [quote=94780]The Moon looks great with the hyllian glow! I like the effect of thicker lines for brighter colors. Having never seen a Sony BVM in real life, I expect that is near to what it should look like. I want to get rid of a “blocky” pixel vision.

    I tried to find your recommended shaders, but they were not on my system (retropie 2.6 image). So I downloaded the common shader set from libretro github, converted them using themaister’s cg2glsl.py script (via Nvidia CG Toolkit), which at least allows my to use the caligari shader now. But the hyllian glow had parse errors and looks far from correct.

    I copied the CRT set from 3.0 beta to my 2.6 shaders, but had the same LEX/PARSE errors with the glow sub shaders. So I’ll stick with caligari.
    [/quote]

    That’s odd – here’s the filepath on my system:

    /opt/retropie/emulators/retroarch/shader/crt/crt-hyllian-glow/crt-hyllian.glsl.

    I did a binary install using the retropie setup script, so maybe it’s not included with the version you used?

    If that doesn’t work, I’ll try uploading the file directly.

Viewing 35 posts - 106 through 140 (of 149 total)