Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • jamesandjome-com
    Participant
    Post count: 46

    Hello all,

    By hitting the hotkey button and F1 in game, you get access to (Retroarch?) menu.

    Going to Options >> Core Options and ensuring “Dynamic Recompiler” is enabled, PSX sound is absoulutley fantastic. Great.

    Now there is another option called “Enhanced Resolution” with a (Slow) warning. When enabled the graphics look absolutely amazing, however the sound then gets terrible.

    So I have everything I want, great sound, great graphics, but they will not work together.

    I have tried an aggressive overclock like this,

    force_turbo=1 #Voids Warranty!!!
    arm_freq=1100
    sdram_freq=500
    core_freq=500
    over_voltage=6
    temp_limit=80 #Will throttle to default clock speed if hit.

    and there was no improvement. Although shaders can be used they have nothing on the “Enhanced Resolution” setting.

    Has anyone figured out how to get both sound and graphics top notch?

    jamesandjome-com
    Participant
    Post count: 46

    An example of the difference between Enhanced Resolution disabled/enabled.

    Sorry about the potato quality.

    jamesandjome-com
    Participant
    Post count: 46

    Does anyone have any input on this?

    Enhanced Resolution looks amazing and I would really appreciate your help to try to get this working smoothly.

    pokeparadox
    Participant
    Post count: 12

    I know for the OpenPandora the HiResolution settings run full speed but this is an Cortex A8 and maybe the Neon instructions run more optimally.

    Additionally The Pandora has auto frameskip. You can only set a constant frameskip value in RetroArch. You can get reasonable performance by setting this to 1 but it’s not perfect as you do see more juddering.

    jamesandjome-com
    Participant
    Post count: 46

    That’s a start for me to tinker with, thank you.

    trixster
    Participant
    Post count: 76

    I can run with high quality sound and the higher quality graphics at the same time, no issue. My pi2 is similarly overclocked as yours. I can’t really help you with your issue though, sorry.

    patrickm
    Participant
    Post count: 171

    [quote=96281]Hello all,

    By hitting the hotkey button and F1 in game, you get access to (Retroarch?) menu.

    Going to Options >> Core Options and ensuring “Dynamic Recompiler” is enabled, PSX sound is absoulutley fantastic. Great.

    Now there is another option called “Enhanced Resolution” with a (Slow) warning. When enabled the graphics look absolutely amazing, however the sound then gets terrible.

    So I have everything I want, great sound, great graphics, but they will not work together.

    I have tried an aggressive overclock like this,

    force_turbo=1 #Voids Warranty!!!
    arm_freq=1100
    sdram_freq=500
    core_freq=500
    over_voltage=6
    temp_limit=80 #Will throttle to default clock speed if hit.

    and there was no improvement. Although shaders can be used they have nothing on the “Enhanced Resolution” setting.

    Has anyone figured out how to get both sound and graphics top notch?

    [/quote]

    The very best video output for all systems is IMO achieved by using the default core options with the scanline overlay and sharp-bilinear filter. This will give you a clean image with scanlines, similar to using an XRGB-Mini.

    go to settings -> overlay settings -> effects -> wii -> scanlines.cfg

    go to options -> shader options -> shader passes and select “1”. Go to shader 0 and select “sharp-bilinear.” Go to shader 0 filter and select linear. Select apply settings.

    make sure your scaling is correct! Enable integer scaling if you haven’t. You should immediately be able to tell if scaling is correct by just looking at some small text – some pixels will be warped/distorted as a result of bad scaling. The scanline overlay makes it easy to detect bad scaling, as the scanlines should always line up with pixel edges.

    Enhanced smoothing is the devil, you’re losing detail and introducing artifacts into the image, which is bad :P

    jamesandjome-com
    Participant
    Post count: 46

    [quote=96464]I can run with high quality sound and the higher quality graphics at the same time, no issue. My pi2 is similarly overclocked as yours. I can’t really help you with your issue though, sorry.[/quote]

    Thats strange, I have 2 of the RPi 2’s and cannot achieve this. Perhaps it is the games I am playing?

    My testing has been done on GT 2, Tenchu 2 and Diablo. If you do think of anything that maybe could help I would appreciate it.

    jamesandjome-com
    Participant
    Post count: 46

    The very best video output for all systems is IMO achieved by using the default core options with the scanline overlay and sharp-bilinear filter. This will give you a clean image with scanlines, similar to using an XRGB-Mini.

    go to settings -> overlay settings -> effects -> wii -> scanlines.cfg

    go to options -> shader options -> shader passes and select “1”. Go to shader 0 and select “sharp-bilinear.” Go to shader 0 filter and select linear. Select apply settings.

    make sure your scaling is correct! Enable integer scaling if you haven’t. You should immediately be able to tell if scaling is correct by just looking at some small text – some pixels will be warped/distorted as a result of bad scaling. The scanline overlay makes it easy to detect bad scaling, as the scanlines should always line up with pixel edges.

    Enhanced smoothing is the devil, you’re losing detail and introducing artifacts into the image, which is bad :P
    [/quote]

    Hello and thank you for this. I will try these settings tonight.

    Your post reminded me also that I changed my config to say Video Smooth =True.
    I’ll ammend this and see if any of the above gives me what I am hoping to achieve.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.