Forum Replies Created

Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • puck6t9
    Participant
    Post count: 20

    Make shure you got the right rom it ran fine on the pi 2 I set up for a friend other than some textures not loading so some walls would be black. I’ll try and find the config file I did make a few changes in it. I’ll post if I find it.

    puck6t9
    Participant
    Post count: 20

    Try making the changes like this

    Start = GPIO(7)
    Z Trig = GPIO(2)
    B Button = GPIO(5)

    and so on. Also make the same changes in the mupen64plus.cfg file.

    puck6t9
    Participant
    Post count: 20

    you do know the autoinput.ini file uses a different layout then the retoarch.cfg. What i did was found a entry in the autoinput.ini that was close to my joy pad. copied that entry pasted it at the bottom then changed the relevant info like name and button maps. also im using the experimental mupen64plus i don’t know if that makes a difference.

    puck6t9
    Participant
    Post count: 20

    Have you tried going to the retopie menu and selecting the config joy stick. After I did that it created a file for my joystick with the name and button configs. This is what I used to edit the auto input.ini file to get mine working.

    puck6t9
    Participant
    Post count: 20

    olapaulakoski what video pluginf are you running. Both of thoes game run fine on my pi. Try doing a script update and install the experimental packages the rice one fixed most of my problems.

    puck6t9
    Participant
    Post count: 20

    i think that the .srm is a savestate. I would just like to know where it saves the memory cards or hoe to enable the 2nd memory card.

    puck6t9
    Participant
    Post count: 20

    so what .cfg file did you put that in because it not working for me. My analog sticks dont work when running a psx game.

    puck6t9
    Participant
    Post count: 20

    [quote=93598]– For N64, I also use the RetroArch emulator in order to get benefit from all the standards (UsbGamepad.cfg). The problem is that Mario Kart M3 (E) ! rom is a mess on that emulator. Even the “press start screen” is buggy. Again, are there some settings that would enhabce the emulation ? I hope so because I never read elsewhere that someone had such an issue with that rom. FYI, this rom plays nicely on other emulators and on other platforms also.[/quote]

    useing the expermintal mupen64plus package fixed that for me. Also if you will just add your controler to the autoinputconfig.ini in the configs/n64 folder it will see your game pad and remap it (with out using retrorarch i understand but it worked better.)

    puck6t9
    Participant
    Post count: 20
    in reply to: Need help with n64 #95225

    just so you know i add the mempack and rumblepack buttons to that useing unused buttons to see if i could turn the rumble on and off and stuff.. but it did not work. oddly enough you have 2 other pads in there form the same maker just my shows with a different name for some reason. i attatched my config file just incase you need it. never mind it wont let me upload it.

    puck6t9
    Participant
    Post count: 20
    in reply to: Need help with n64 #95220

    no this is what i did.. Start the Pi when emulationstatin starts go to retropie then run retropie-setup.

    then do a update retropie setup script.
    then setup / configuration and the update APT packages (dont know if this is needed but i did it.

    then go back a page and do experimental packages.
    then on mine it was the second one “mupen64plus-testing”

    it will then download and build the package. do a reboot when it finishes.

    when emulation station starts back up go to Nintendo 64 click on a rom and as soon as the screen goes black hit X on the keyboard a window will come up where you can change the default emulator or set a emulator for just that rom. I changed the default to the mupen64plus-testing-rice one.

    there is no mupen64plus folder in the beta 2 image. it only uses mupen64plus as far as i can tell so unlike the old one there is no need to install 2 n64 emulators. that’s what worked for me. so that means mupen64plus is already config to use the n64 folder.

    after all that i had the edit the configs/n64/mupen64plus.cfg file to add a button the quit the game and add my joy pad button mapping the the autoinput.ini file in that same folder

    puck6t9
    Participant
    Post count: 20

    i would say some file got messed up.. try deleting the retroroach controller config file. then reboot and let it reset up the controller. if you have another controller trying useing it and see if its just the detection of that one or all controllers.

    puck6t9
    Participant
    Post count: 20
    in reply to: N64 problems… #95218

    try the expermental mupen64plus. you can install it from the retopie setup/source based installs. fix most all gfx problems i have on mine. as for the controller mupen64plus wont see it unless it is in the autoinput.ini file in the configs/n64 folder. i had to take the save file that retroroach made for my controller and add it to that INI file then mupen64plus used it. i had to add this to that file..

    [Jess Tech GGE909 PC Recoil Pad]
    plugged = True
    plugin = 2
    mouse = False
    AnalogDeadzone = 4096,4096
    AnalogPeak = 32768,32768
    DPad R = hat(0 Right)
    DPad L = hat(0 Left)
    DPad D = hat(0 Down)
    DPad U = hat(0 Up)
    Start = button(9)
    Z Trig = button(7)
    B Button = button(0)
    A Button = button(2)
    C Button R = axis(3+)
    C Button L = axis(3-)
    C Button D = axis(2+)
    C Button U = axis(2-)
    R Trig = button(6)
    L Trig = button(4)
    Mempak switch = button(10)
    Rumblepak switch = button(11)
    X Axis = axis(0-,0+)
    Y Axis = axis(1-,1+)

    puck6t9
    Participant
    Post count: 20

    thanks.. i did do the experimental install and it works alot better. Just to add in the NBA jam 99 and NGA jam 2000 roms wont load emulator starts then just kicks back to emulation station.. don’t know whats up with them the roms are good work on computer just not here. also still a few gfx glitches on donkey Kong 64.

    puck6t9
    Participant
    Post count: 20
    in reply to: Need help with n64 #95213

    i got my problems fix… the n64 folder is mupen64plus. they changed it so you can push x or m at rom start to change the plugin used like Rice. more over do a source based install of the mupen64plus experimental packages then use the rice version. it run things a lot better. back up your config file like for your controller it will replace all settings back to default. also it seems that mupen64plus uses it own config file the mupen64plus.cfg i had to edit it i was getting no sound because i was using a HDMI to DVI converter to use a monitor and using the audio jack for audio even tho retro pie was using the jack mupen64plus was still trying to use the HDMI. also had to add my controller to the autoinput.ini file for it to see the joy pad. was alot more work then i thought for setup.

    puck6t9
    Participant
    Post count: 20

    you said you did setting for zelda majoria’s mask i can get it to load but it is missing textures. like the side of the buildings are just black. any idea how to fix it? i have tryed and changed every setting nothing works. here is my current rice settings

    # Control when the screen will be updated (0=ROM default, 1=VI origin update, 2=VI origin change, 3=CI change, 4=first CI change, 5=first primitive draw, 6=before screen clear, 7=after screen drawn)
    ScreenUpdateSetting = 7
    # Frequency to write back the frame buffer (0=every frame, 1=every other frame, etc)
    FrameBufferWriteBackControl = 1
    # If this option is enabled, the plugin will skip every other frame
    SkipFrame = False
    # If this option is enabled, the plugin will only draw every other screen update
    SkipScreenUpdate = True
    # Force to use texture filtering or not (0=auto: n64 choose, 1=force no filtering, 2=force filtering)
    ForceTextureFilter = 2
    # Primary texture enhancement filter (0=None, 1=2X, 2=2XSAI, 3=HQ2X, 4=LQ2X, 5=HQ4X, 6=Sharpen, 7=Sharpen More, 8=External, 9=Mirrored)
    TextureEnhancement = 6
    # Secondary texture enhancement filter (0 = none, 1-4 = filtered)
    TextureEnhancementControl = 0
    # Frame Buffer Emulation (0=ROM default, 1=disable)
    FrameBufferSetting = 0
    # Render-to-texture emulation (0=none, 1=ignore, 2=normal, 3=write back, 4=write back and reload)
    RenderToTexture = 3
    # Force to use normal alpha blender
    NormalAlphaBlender = False
    # Use a faster algorithm to speed up texture loading and CRC computation
    FastTextureLoading = False
    # Use different texture coordinate clamping code
    AccurateTextureMapping = True
    # Force emulated frame buffers to be in N64 native resolution
    InN64Resolution = False
    # Try to reduce Video RAM usage (should never be used)
    SaveVRAM = False
    # Enable this option to have better render-to-texture quality
    DoubleSizeForSmallTxtrBuf = False
    # Force to use normal color combiner
    DefaultCombinerDisable = False
    # Enable game-specific settings from INI file
    EnableHacks = True
    # If enabled, graphics will be drawn in WinFrame mode instead of solid and texture mode
    WinFrameMode = False
    # N64 Texture Memory Full Emulation (may fix some games, may break others)
    FullTMEMEmulation = False
    # Enable vertex clipper for fog operations
    OpenGLVertexClipper = False
    # Enable/Disable SSE optimizations for capable CPUs
    EnableSSE = False
    # Use GPU vertex shader
    EnableVertexShader = True
    # If enabled, texture enhancement will be done only for TxtRect ucode
    TexRectOnly = False
    # If enabled, texture enhancement will be done only for textures width+height<=128
    SmallTextureOnly = False
    # Select hi-resolution textures based only on the CRC and ignore format+size information (Glide64 compatibility)
    LoadHiResCRCOnly = True
    # Enable hi-resolution texture file loading
    LoadHiResTextures = False
    # Enable texture dumping
    DumpTexturesToFiles = False
    # Display On-screen FPS
    ShowFPS = True
    # Use Mipmapping? 0=no, 1=nearest, 2=bilinear, 3=trilinear
    Mipmapping = 2
    # Enable, Disable or Force fog generation (0=Disable, 1=Enable n64 choose, 2=Force Fog)
    FogMethod = 0
    # Color bit depth to use for textures (0=default, 1=32 bits, 2=16 bits)
    TextureQuality = 0
    # Z-buffer depth (only 16 or 32)
    OpenGLDepthBufferSetting = 16
    # Enable/Disable MultiSampling (0=off, 2,4,8,16=quality)
    MultiSampling = 0
    # Color bit depth for rendering window (0=32 bits, 1=16 bits)
    ColorQuality = 0
    # OpenGL level to support (0=auto, 1=OGL_1.1, 2=OGL_1.2, 3=OGL_1.3, 4=OGL_1.4, 5=OGL_1.4_V2, 6=OGL_TNT2, 7=NVIDIA_OGL, 8=OGL_FRAGMENT_PROGRAM)
    OpenGLRenderSetting = 0
    # Enable/Disable Anisotropic Filtering for Mipmapping (0=no filtering, 2-16=quality). This is uneffective if Mipmapping is 0. If the given value is to high to be supported by your graphic card, the value will be the highest value your graphic card can support. Better result with Trilinear filtering
    AnisotropicFiltering = 0

    puck6t9
    Participant
    Post count: 20

    find your joystick config file. the name that come on in yellow writing when starting a emulator. then add that to the inputautocfg.ini file in the /configs/n64 folder. worked for me.

    puck6t9
    Participant
    Post count: 20

    try it like this. Worked with my game pad

    [8Bitdo NES30 GamePad]
    plugged = True
    plugin = 2
    mouse = False
    DPad R = 3
    DPad L = 2
    DPad D = 5
    DPad U = 0
    Start = 22
    Z Trig = 21
    B Button = 12

    and so on.. i had to put the name of the device the same way retropie sees it for it to auto config. for expaple here is mine

    [Jess Tech GGE909 PC Recoil Pad]
    plugged = True
    plugin = 2
    mouse = False
    AnalogDeadzone = 4096,4096
    AnalogPeak = 32768,32768
    DPad R = hat(0 Right)
    DPad L = hat(0 Left)
    DPad D = hat(0 Down)
    DPad U = hat(0 Up)
    Start = button(9)
    Z Trig = button(7)
    B Button = button(0)
    A Button = button(2)
    C Button R = axis(3+)
    C Button L = axis(3-)
    C Button D = axis(2+)
    C Button U = axis(2-)
    R Trig = button(6)
    L Trig = button(4)
    Mempak switch =
    Rumblepak switch =
    X Axis = axis(0-,0+)
    Y Axis = axis(1-,1+)

    puck6t9
    Participant
    Post count: 20

    i fixed the first to by editing the the mupen64plus.cfg file and the InputAutoCfg.ini file in the /opt/retropie/configs/n64.

    just when you edit the inputautocfg.ini file to remap buttons it does it for all games running that profile. just look in the file for the name of the controller your using and remap the keys the same as the retroroach.cfg

    the last im still looking for has to do with changing the mupen64plus.cfg where it says

    # Joystick event string for stopping the emulator
    Joy Mapping Stop = “”

    i like to know if you find what to put there.

Viewing 18 posts - 1 through 18 (of 18 total)