Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #94937

    I just got a pi 2 b and i downloaded RetroPie SD-card Image for Raspberry Pi 2 Version 3.0 BETA 2 put it on a card and got every thing running but n64.

    My problem is this most of the games i run work fine but for example Mario kart 64 with the default stetting (lr-mupen64plus) the game loads controller works but the text on the menus are messed up. with a lot of searching i found that when starting the game if you hit X and change the emulator for the ROM to mupen64plus-gles2rice the menus show right but there is no sound and my controller does not work any more. I have to use a keyboard.

    With Zelda majora’s mask using lr-mupen64plus i see the Nintendo logo but then a black screen. i can hear the game running and if i hit buttons on the controller i here the sounds like starting the game but the screen stays black. If i change it to mupen64plus-gles2rice video is good but i am back to no sound and controller not working.

    same thing with Wave Race 64

    but with Mario 64 every thing works with the default settings

    I have updated the setup script. did a update even did a binary reinstall of mupen64plus. nothing has work.

    Can some one please tell me what i am doing wrong and how to fix it. I have been searching all night and cant see to find anyone having the same problem.

    I have a Pi 2
    with a Philips controller with the same layout as a PS2. it works fine every where but in the mupen64plus-gles2rice emulator.

    If you will just tell me what config files need to be posted or screenshots ill post it.


    I am having similar problems as you’ve stated so maybe a second post will get some more attention. I realized that the beta 2 image actually didn’t have mupen64plus installed, at least for me it didn’t seem that it was as there was no roms folder for it. Did you have a mupen64plus folder or just the n64 folder?

    I tried doing a source based installation of mupen64plus but there is still no roms folder for it. I read through some of the console history and found this:
    UI-Console Error: no ROM filepath given
    So it seems that I should just be able to create my own folder but then I need to somehow tell mupen64plus where it is.


    i got my problems fix… the n64 folder is mupen64plus. they changed it so you can push x or m at rom start to change the plugin used like Rice. more over do a source based install of the mupen64plus experimental packages then use the rice version. it run things a lot better. back up your config file like for your controller it will replace all settings back to default. also it seems that mupen64plus uses it own config file the mupen64plus.cfg i had to edit it i was getting no sound because i was using a HDMI to DVI converter to use a monitor and using the audio jack for audio even tho retro pie was using the jack mupen64plus was still trying to use the HDMI. also had to add my controller to the autoinput.ini file for it to see the joy pad. was alot more work then i thought for setup.


    Did you have to do something special on the source based install to get the experimental packages? When I did my sourced based install I ran the following:
    sudo ./ mupen64plus
    As far as the rom folder goes, did you just create a folder on your own called mupen64plus or was there automatically a folder with that name? I can create a folder easily enough but I don’t know how to tell mupen4plus where that folder is. I have been going through all the configuration files I can find for the emulator but I haven’t found any reference to a rom directory.


    no this is what i did.. Start the Pi when emulationstatin starts go to retropie then run retropie-setup.

    then do a update retropie setup script.
    then setup / configuration and the update APT packages (dont know if this is needed but i did it.

    then go back a page and do experimental packages.
    then on mine it was the second one “mupen64plus-testing”

    it will then download and build the package. do a reboot when it finishes.

    when emulation station starts back up go to Nintendo 64 click on a rom and as soon as the screen goes black hit X on the keyboard a window will come up where you can change the default emulator or set a emulator for just that rom. I changed the default to the mupen64plus-testing-rice one.

    there is no mupen64plus folder in the beta 2 image. it only uses mupen64plus as far as i can tell so unlike the old one there is no need to install 2 n64 emulators. that’s what worked for me. so that means mupen64plus is already config to use the n64 folder.

    after all that i had the edit the configs/n64/mupen64plus.cfg file to add a button the quit the game and add my joy pad button mapping the the autoinput.ini file in that same folder


    Please post your controller config so we can add your controller to the mupen64plus repo. I have seen it on the other thread.


    just so you know i add the mempack and rumblepack buttons to that useing unused buttons to see if i could turn the rumble on and off and stuff.. but it did not work. oddly enough you have 2 other pads in there form the same maker just my shows with a different name for some reason. i attatched my config file just incase you need it. never mind it wont let me upload it.

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.