Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • eymano
    Post count: 8


    I got som big problems N64 emulation on my retropie.
    Im use the newest raspberry pi 2 (1gb) with retropie 3.0.

    My problems:

    1. If im using the emulator N64- mupen64plus everything works great except the controllers because it doesn´t work with retroarch controller settings.

    And if I use the emulator N64 retroarch controller settings works fine, but all games are lagging so bad! I cant start any game or anything.

    So my question is: Can someone help me fix the controller issues for N64mupen or the video problems for N64.

    Im using a USB SNES gamepad (not the best for 64, i know, but it will work for now).

    Plz Help.

    Post count: 20

    try the expermental mupen64plus. you can install it from the retopie setup/source based installs. fix most all gfx problems i have on mine. as for the controller mupen64plus wont see it unless it is in the autoinput.ini file in the configs/n64 folder. i had to take the save file that retroroach made for my controller and add it to that INI file then mupen64plus used it. i had to add this to that file..

    [Jess Tech GGE909 PC Recoil Pad]
    plugged = True
    plugin = 2
    mouse = False
    AnalogDeadzone = 4096,4096
    AnalogPeak = 32768,32768
    DPad R = hat(0 Right)
    DPad L = hat(0 Left)
    DPad D = hat(0 Down)
    DPad U = hat(0 Up)
    Start = button(9)
    Z Trig = button(7)
    B Button = button(0)
    A Button = button(2)
    C Button R = axis(3+)
    C Button L = axis(3-)
    C Button D = axis(2+)
    C Button U = axis(2-)
    R Trig = button(6)
    L Trig = button(4)
    Mempak switch = button(10)
    Rumblepak switch = button(11)
    X Axis = axis(0-,0+)
    Y Axis = axis(1-,1+)

    Post count: 8

    Hi, thx for your reply!:)

    Hm ok, but the gfx problem only apears when im using the N64 emulator namned only N64 (when im extract all Roms in folder N64).
    When im using emulator mupen64plus (add all the Roms to folder mupen64plus) the gfx works fine but then the controller doesnt work..

    Do u think it can help to do the expermentall install anyway?.

    Ok, i have tried both to copy the controller settings il get when im configurate my controller to retroarch (UBS_retroarch.cfg) to autoinput.ini.file.
    Am also try to Add the controller information u wrote, but for my gamepad ofcurse. But nothing works.

    Can anyone show me exactly what i have to add to autoinput.ini.file according to my snes controller? :)

    Post count: 8


    Post count: 35

    First, are you on 3.0 beta 2? because if not, you should update to it.

    Second, you should update your setup script, and install the testing emulators if you are going to run n64 games. I have found the mupen64+ testing glesN64 works well with mario themed games except Yoshi’s Island.

    Third, if your controller is listed in the /n64/InputAuto.cfg file, it should work for you.

    Post count: 8

    Hi, thx for ure reply!

    1. Yes, 3.0 beta 2
    2. Both setupsscript and mupen64 testing are fixed!
    3. My controller is not listed in inputAuto.cfg file. Im using a standard snes usb from retrolink. I want to add the information, but i dont know what to write. I have tried to add the controller information i got from retroarch when im did the configuration but i didnt work.
    As i wrote before, i need to know exactly what information i have to add to inputAuto.cfg.


    Post count: 8

    Unfortunately im only get a black screens with a error message when im trying to start any N64 game. This is after im install mupen64plus testing from setup.

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.