Need a new search?

If you didn't find what you were looking for, try a new search!

Viewing 35 results - 946 through 980 (of 1,077 total)
  • Author
    Search Results
  • Marc
    Guest
    Post count: 908

    Disabling “input_enable_hotkey = escape” in /opt/retropie/configs/all/retroarch.cfg
    worked for me.

    I opened an issue: https://github.com/retropie/RetroPie-Setup/issues/357

    Imrhien
    Guest
    Post count: 908

    Don’t forget to add this to your config afterwards:

    input_enable_hotkey_btn = “6”
    input_exit_emulator_btn = “7”
    input_enable_hotkey_btn = “6”
    input_save_state_btn = “4”
    input_enable_hotkey_btn = “6”
    input_load_state_btn = “5”

    On my controller this adds the following inputs:
    Exit Emulator: Select + Start
    Save State: Select + L1
    Load State: Select + R1

    atimmins
    Participant
    Post count: 59

    Exiting the emulator with the controller has been discussed many times. It works the same in 2.2 as in older versions.

    You have to set up a hot key so that you press select + start. Try adding the following lines to the config file.

    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”

    zsprawl
    Participant
    Post count: 57

    [quote=13103]I’m having a slight issue with accessing the menu from within the emulators. I think people normally access it using F1 on a keyboard.
    [/quote]

    Add this to your config file:

    input_menu_toggle = "f1"
    input_enable_hotkey_btn = "8"
    input_menu_toggle_btn = "9"

    You may need to change button numbers, but the gist of this is, you can either press F1 to enter the menu OR hold select and press start.

    tandre
    Participant
    Post count: 22

    [quote=12756]

    <div class=”d4p-bbt-quote-title”>tandre wrote:</div>
    I dont know why but pressing 0 button, i.e. triangle on ps2 controller, emulators quit.

    Have you tried to set this one to “nul” and see if it still happens?

    input_exit_emulator_btn = “9″
    [/quote]
    It was a stupid problem of quote i.e. “”

    input_enable_hotkey_btn = “8″
    input_exit_emulator_btn = “9″
    input_save_state_btn = “4″
    input_load_state_btn = “5″

    In your post you have differente quotes, change to “”. It’s a text formatting problem ( dont know if i’ve been clear)

    Another problem, when I’m getting out of a ROM I have a black screen and nothing happen… How to return to Emulation Station again? Thanks :)

    smatticus
    Participant
    Post count: 51

    That’s something that I’m looking at too since everything I’ve done still results with the “bios not found” message. But for saving I’ve just been using save states (by using hotkeys on my controller), and that’s worked out alright for me so far. Could work for you in the short term until someone figures this out.

    borlandoflorida
    Participant
    Post count: 34

    I’m having a slight issue with accessing the menu from within the emulators. I think people normally access it using F1 on a keyboard.

    When I press F1, nothing happens. It did work once, before I configured my Xbox360 wireless pad, but now I can’t get it working.

    I’ve looked at the retroarch.cfg file and I presume the button needs to be mapped to the menu input command, but even when I change this to F1, nothing happens. I’ve also tried mapping it to a button on my controller (ideally the home button – 15 I presume) but nothing works. Even if I map it to a known button (ie. A button) I still can’t get the menu to appear.

    Does anybody know how to access the emulator menu in a game using the Xbox360 wireless pad? If so, what does you retroarch.cfg file look like?

    Would be eternally grateful for any help as this seems to be the only problem I have to my otherwise perfect setup…

    EDIT: I have now resolved this issue. I mapped the hotkey to F2 on the keyboard, then held F2 down before pressing F1. This then accessed the GUI from within the emulator and I was then able to assign my own button map using the settings in there. I then saved this as a new config file and replaced the retroarch.cfg one (the autosave feature saves it as a different .cfg file).

    tandre
    Participant
    Post count: 22

    I dont know why but pressing 0 button, i.e. triangle on ps2 controller, emulators quit.

    Also the load/save buttons doesnt work…
    [code]system_directory = /home/pi/RetroPie/roms/../BIOS
    config_save_on_exit = false
    video_aspect_ratio = 1.33
    video_smooth = false
    video_threaded = true
    input_enable_hotkey = escape
    rewind_enable = false
    rewind_buffer_size = 10
    rewind_granularity = 2
    input_rewind = r
    video_gpu_screenshot = true
    input_shader_next = m
    input_shader_prev = n
    video_shader_dir = /opt/retropie/emulators/RetroArch/shader/
    input_player1_a = x
    input_player1_b = z
    input_player1_y = a
    input_player1_x = s
    input_player1_start = enter
    input_player1_select = rshift
    input_player1_l = q
    input_player1_r = w
    input_player1_left = left
    input_player1_right = right
    input_player1_up = up
    input_player1_down = down
    input_autodetect_enable = true
    joypad_autoconfig_dir = /opt/retropie/emulators/RetroArch/configs/
    input_player1_b_btn = “2”
    input_player1_y_btn = “3”
    input_player1_select_btn = “8”
    input_player1_start_btn = “9”
    input_player1_up_axis = “-1”
    input_player1_down_axis = “+1”
    input_player1_left_axis = “-0”
    input_player1_right_axis = “+0”
    input_player1_a_btn = “1”
    input_player1_x_btn = “0”
    input_player1_l_btn = “6”
    input_player1_r_btn = “7”
    input_player1_l2_btn = “4”
    input_player1_r2_btn = “5”
    input_player1_l3_btn = “11”
    input_player1_r3_btn = “10”
    input_player1_l_x_plus_btn = “h0up”
    input_player1_l_x_minus_btn = “h0down”
    input_player1_l_y_plus_btn = “h0right”
    input_player1_l_y_minus_btn = “h0left”
    input_player1_r_x_plus_btn = “+2”
    input_player1_r_x_minus_btn = “-2”
    input_player1_r_y_plus_axis = “+3”
    input_player1_r_y_minus_axis = “-3”
    input_enable_hotkey_btn = “8″
    input_exit_emulator_btn = “9″
    input_save_state_btn = “11″
    input_load_state_btn = “10″
    [/code]

    smatticus
    Participant
    Post count: 51

    Don’t forget you can set a hotkey for the menu if you don’t always want to have a keyboard plugged in

    zsprawl
    Participant
    Post count: 57
    #12376 In reply to: Volume adjustment |

    I added the following to /opt/retropie/configs/all/retroarch.cfg, and now when I hold SELECT (button 8) and press up or down, it adjusts the volume in game for me.

    input_enable_hotkey_btn = "8"
    input_volume_up_axis = "-1"
    input_volume_down_axis = "+1"
    zSprawl
    Guest
    Post count: 908

    Well I see it asked a lot, and I keep notes for myself, so I figured I would share. I’ve updated my build document for version 2.2 and am having a blast playing with the new interface.

    —-

    1) Download the latest version of RetroPie’s SD image. This document is based off version 2.2.

    http://www.petrockblock.com/download/retropie-project-image/

    2) Download and use Win32 Disk Imager to apply the above SD image to a 4 GB or larger SD card. 8 GB is really recommended.

    http://sourceforge.net/projects/win32diskimager/

    3) Boot the SD Image on your Raspberry Pi.

    4) The first time the system boots up into Emulation Station, you will need to setup your joystick.

    5) If this is a new Pi, you’ll probably want to update to the latest firmware and reboot. You may need to use a wired cable even if you plan on using wifi.

    sudo rpi-update
    sudo reboot
    sudo apt-get update && sudo apt-get upgrade -y

    6) I purchased a EW-7811Un USB wifi, which is supported by the Raspberry Pi out of the box. I also have a TL-WN725N, which can be setup as follows:

    http://www.raspberrypi.org/forums/viewtopic.php?p=462982#p462982

    tar -zxvf 8188eu-201xyyzz.tar.gz
    sudo install -p -m 644 8188eu.ko /lib/modules/$(uname -r)/kernel/drivers/net/wireless
    sudo insmod /lib/modules/$(uname -r)/kernel/drivers/net/wireless/8188eu.ko
    sudo depmod -a

    7) Now we need to setup wifi. Edit /etc/network/interfaces to configure wlan0.

    allow-hotplug wlan0
    auto wlan0
    iface wlan0 inet dhcp
    wpa-ssid zInternet
    wpa-psk *******

    8) Before we can move to configuring everything via SSH, we need to configure our joystick for the emulators themselves.

    sudo chown pi /opt/retropie/configs/all/retroarch.cfg
    cd /opt/retropie/emulators/RetroArch/installdir/bin
    sudo ./retroarch-joyconfig -j 1 >> /opt/retropie/configs/all/retroarch.cfg

    9) Grab the IP address and SSH into the device to continue configuration. The default user/password that comes with Raspbian is used: The username is “pi”, the password is “raspberry”.

    10) Let’s setup the player 2 controller for our emulators before we forget.

    cd /opt/retropie/configs/all/
    vi retroarch.cfg

    Copy and paste the entire section that begins with “input_player1_” and change it to “input_player2_”. Don’t forget to change the “input_player_joypad_index” to 1 or 2 as well.

    Note: If you have a keyboard connected, things can be a little odd. You may need to change the joypad index to 0 and 1 if you remove the keyboard, which I’m going to do.

    At the end of the retroarch.cfg file, it is a good idea to add the following to allow you to press select+start to exit the game.

    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”

    I also like to take advantage of the save and load states in emulation, which some people consider cheating. Add the following lines to enable these buttons on your joypad.

    input_save_state_btn = “4”
    input_load_state_btn = “5”

    After this has been done, you can hold select and press the L and R paddles to save and load states respectively.

    11) Run configuration.

    sudo raspi-config

    12) Change password.

    13) Change Memory-split to 384.

    14) Expand root file system to fill entire SD card.

    15) Force audio out of audio jack (instead of HDMI).

    16) Exit from tool and reboot.

    17) SSH back in (if you are using DHCP, the resizing of the file system can cause an IP change).

    18) Now we need to ensure that pisnes is the active emulator in Emulation station. Pisnes has problems playing some of the later games, like Yoshi’s Island, but performs way better than the RetroArch version. It is up to you whether you can handle the lag and broken sound in RetroArch.

    cd /etc/emulationstation
    sudo vi es_systems.cfg

    Change the section for SNES by uncommenting out the line for pisnes, and commenting out the current line. It should look like this when you’re done.

    <system>
    <fullname>Super Nintendo</fullname>
    <name>snes</name>
    <path>~/RetroPie/roms/snes</path>
    <extension>.smc .sfc .fig .swc .SMC .SFC .FIG .SWC</extension>
    <command>/opt/retropie/emulators/pisnes/snes9x %ROM%</command>
    <platform>snes</platform>
    <theme>snes</theme>
    </system>

    You can also edit this file to remove other emulators. I deleted the Apple, Ports, and DOS emulators by commenting out their respective sections.

    19) Now we need to configure the controller for pisnes.

    cd /opt/retropie/emulators/pisnes
    sudo vi snes9x.cfg

    Edit this file to match your controller. Here is my config file:

    [Keyboard]
    # Get codes from /usr/include/SDL/SDL_keysym.h
    A_1=100
    B_1=99
    X_1=115
    Y_1=120
    L_1=97
    R_1=102
    START_1=13
    SELECT_1=9
    LEFT_1=276
    RIGHT_1=275
    UP_1=273
    DOWN_1=274
    QUIT=27
    ACCEL=8

    [Joystick]
    # Get codes from “jstest /dev/input/js0”
    # from package “joystick”
    A_1=1
    B_1=2
    X_1=0
    Y_1=3
    L_1=4
    R_1=5
    START_1=9
    SELECT_1=8
    A_2=1
    B_2=2
    X_2=0
    Y_2=3
    L_2=4
    R_2=5
    START_2=9
    SELECT_2=8
    QUIT=99
    ACCEL=7
    QLOAD=99
    QSAVE=99
    #Joystick axis
    JA_LR=0
    JA_UD=1
    JA_LR_2=0
    JA_UD_2=1

    [Graphics]
    DisplaySmoothStretch=1
    # Display Effect: 0 none, 1 scanlines, 2 phospher
    # NOTE Phospher does not run at full speed
    DisplayEffect=0
    MaintainAspectRatio=1
    DisplayBorder=0
    AutoFrameskip=1
    Frameskip=200
    Transparency=1
    CPUCycles=100

    [Sound]
    APUEnabled=1
    # Sound rates below as index, i.e. 7=44100 (some of these produce static)
    # 0, 8192, 11025, 16000, 22050, 29300, 32000, 44100
    SoundPlaybackRate=7
    InterpolatedSound=0

    20) Now copy your Roms to the SMB shares (ex. \\RaspberryPi\snes is where the Super Nintendo ROMs go).

    21) All done? Reboot and game on.

    sudo reboot

    22) And once you are happy for a few days, go back into “raspi-config” and overclock your pi, if you are feeling daring. It will iron out some of the annoying blips in audio. I purchased a few heat sinks just in case.

    borlandoflorida
    Participant
    Post count: 34

    [quote=12079]
    http://zsprawl.com/iOS/2014/06/playing-old-skool-games-on-a-raspberry-pi/
    [/quote]

    Thanks – I will check this out. I take it I would need to reconfigure some of the scripts to be compatible with ES 2.1?

    So…

    cd ~/RetroPie/emulators/RetroArch/installdir/bin
    ./retroarch-joyconfig -j 1 >> ~/RetroPie/configs/all/retroarch.cfg

    Would become:

    $ cd /opt/retroPie/emulators/RetroArch/installdir/bin
    $ ./retroarch-joyconfig -j >> /opt/retroPie/configs/all/retroarch.cfg

    Also, how do you specify screen resolution in each emulator? Is it easier running the emulator as root, accessing the settings menu to scale them accordingly, or is it something easier done by editing a config file somewhere?

    One other question. If I wanted to access the emulator menu using a control pad (Xbox 360 wireless through the USB wireless receiver), do I need to press the hotkey then press the button assigned to the menu command?

    borlandoflorida
    Participant
    Post count: 34

    Mutex Wrote:
    The mame emulator cannot save the config since you’re running mame as pi user. The config folder in the mame emulator belongs to the root user, so you’re not allowed to make any changes to that folder. The easiest thing would be to run mame one time by hand as root user

    /opt/retropie/emulators/mame4all-pi/mame

    configure your controls by pressing and then restart emulationstation. The pi should now have your new controls saved. The other solution would be to change the ownership of the config file but that is a bit more complicated.

    zSprawl Wrote:
    At the end of the retroarch.cfg file, it is a good idea to add the following to allow you to press select+start to exit the game.

    input_enable_hotkey_btn = “6″
    input_exit_emulator_btn = “7″

    I also like to take advantage of the save and load states in emulation, which some people consider cheating. Add the following lines to enable these buttons on your joypad.

    input_save_state_btn = “8″
    input_load_state_btn = “10″

    Keep in mind, you must hold the “input_enable_hotkey_btn” to trigger the other functions. In other words, using save state would require you to press button 6, and hold it while pressing button 8

    I just saw these in other posts, which could explain the settings not being saved when making changes to the emulator whilst running through ES and setting buttons to exit emulators / access menus etc. I’ll give them a go later and see whether this has any effect.

    Thought I would dump this post in here as it might become useful for others later on…

    Mutex
    Participant
    Post count: 61

    [quote=11954]the hotkeys do not work for mame, as mame still uses its own config it seems, so if i have my keyboard plugged in i just do the whole “tab” thing and go from there. But i don’t want to use a keyboard every time i want to configure a game for mame, also it doesn’t save any changes i make. how can i get mame to use the same settings as everything else?[/quote]

    The mame emulator cannot save the config since you’re running mame as pi user. The config folder in the mame emulator belongs to the root user, so you’re not allowed to make any changes to that folder. The easiest thing would be to run mame one time by hand as root user
    /opt/retropie/emulators/mame4all-pi/mame
    configure your controls by pressing [tab] and then restart emulationstation. The pi should now have your new controls saved. The other solution would be to change the ownership of the config file but that is a bit more complicated.

    smatticus
    Participant
    Post count: 51

    the hotkeys do not work for mame, as mame still uses its own config it seems, so if i have my keyboard plugged in i just do the whole “tab” thing and go from there. But i don’t want to use a keyboard every time i want to configure a game for mame, also it doesn’t save any changes i make. how can i get mame to use the same settings as everything else?

    zSprawl
    Guest
    Post count: 908

    At the end of the retroarch.cfg file, it is a good idea to add the following to allow you to press select+start to exit the game.

    input_enable_hotkey_btn = “6”
    input_exit_emulator_btn = “7”

    I also like to take advantage of the save and load states in emulation, which some people consider cheating. Add the following lines to enable these buttons on your joypad.

    input_save_state_btn = “8”
    input_load_state_btn = “10”

    Keep in mind, you must hold the “input_enable_hotkey_btn” to trigger the other functions. In other words, using save state would require you to press button 6, and hold it while pressing button 8.

    hulkhaugen
    Participant
    Post count: 4

    Ok, i had the 1.9.1 version up and running a while back, but hit quite a few problems, got busy doing other stuff and forgot most about it. So yesterday i installed the new 2.1 version, and what an improvement. I’m impressed ;) NES, SNES, SMS and SMD working great. Mame4all, got MK1 running, but not joystick only keyboard works, but not start, and analog stick instead of d-pad. N64 not working at all. So to list the challenges:

    1. N64 games doesn’t start. I can see the roms start to load, and everything seems ok, the resolution changes, but then it quits and goes back to ES2. If i quit right after, i can still read the loading sequence.

    Core: Starting emulation 1945
    Core: Starting R3400 emulator: Dynamic Recompiler
    Core: Init new dynarec
    Core Status: Stopping emulation.
    Core: R4300 emulator finished.
    Core: Stopping emulation at 3200
    Core Status: Rom closed.
    Powering on HDMI with preferred settings
    

    2. /opt/retropie/configs/all/retroarch.cfg, this seems to be set up only for keyboard, but it does work with joystick also. Well, except for Mame4all. And i want to configure a hotkey combination to exit games. Is there another config file i’m missing?

    3. The Mame roms (this is thin ice for me) have several versions. MK1 only has one version and does work. But MK2 has a r14 and a r32 zip-file in addition to the mk2.zip, and also three listings in ES-Mame. None of them work. Same with MK3. EDIT: I’ve now tried several other games that work, and i usually keep the main version, even though there usually are another us and japan version. Is tat correct? Seems like some games needs more than one rom file. They are 0.37b5.

    4. Minor issue, but the scrapper seems to have issues with dashes. for instance pac-man can’t be located, but i do find it when i check online.

    hulkhaugen
    Participant
    Post count: 4

    I still have some problems with this. I did find the retroarch.cfg in the /opt/retropie/configs/all folder, but it seems to only be set up for keyboard, even though i got my controller working in most emulators (not Mame4all yet). I’m also looking to enabling the hotkey exit function.

    kitchuk
    Participant
    Post count: 207

    Mame4all: Press the TAB button on your keyboard and then go to overall input options. You should see a entry for UI Cancel. Press enter on your keyboard, then press the two buttons together at the same time.

    Snes should be:

    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “11”

    Francesco
    Guest
    Post count: 908

    i’m trying to set exit emulators from joystick instead press esc on keyboard but i can’t do that.
    i add on /opt/retropie/configs/all/retroarch.cfg this two lines:

     input_enable_hotkey_btn = "11"
    input_exit_emulator_btn = "8"
    

    but it doesnt work.. (11 and 8 are select and start on my joystick, i also try with another combo but it doesnt work)

    i also try these:

    input_player1_enable_hotkey_btn = "11"
    input_player1_exit_emulator_btn = "8"
    

    but nothing…how can i do that?

    Mutex
    Participant
    Post count: 61

    You can set an exit button in retroarch with:

    input_exit_emulator_btn = "9"
    You have to enter the corresponding number to your L2 button.
    If you want to have an additional hotkey so that you can only exit the emulators if you’re pressing two buttons add:
    input_enable_hotkey_btn = "8"

    For everything that’s not retroarch you have to check the config files if there’s any way to configure the exit button.
    I’m not sure if it’s even possible for mame4all, pifba, pisnes, osmose or gpsp to customize the exit button.

    foob
    Participant
    Post count: 23

    Just insalled 2.0, which i think is fantastic! However, im having a little trouble with the guts of it.

    Basically, i can’t seem to find the config files for the controllers at all. The frontend controls configged perfectly normally which is fine, and ive managed to get controllers working in games by using the setup tool in retropie_setup.sh. There are two things i wish to do

    1) i’d like to get into the config file itself so i can add some basic functionality that you could in 1.9.1 and below, such as the hotkey button that can be assigned to the in-game retroarch config menu andmore importantly, exiting the emulator via the pad.

    2) i can’t seem to work out where FBA is getting its controls from. FBA automatically detected and set up both my controllers AND seems to have the exit via pad functionality (via holding start + select/coin). However, the buttons themselves are slightly askew and i would like to reconfigure them to fit my pad better (im using dualshock playstation 1 pads via a USB adapter). Id love to be able to get into FBA config file as well to mess about with some shader and resolution settings as im going to be building a CPS1+2+neogeo arcade cabe using a pi and id like to alter it so it looks more realistic to the original arcade versions.

    anyone know how to do this?

    blaxzen
    Participant
    Post count: 57

    Yes its possible to do this, many emulators already use this as a way to exit the emulator, with it generally being hardcoded into the emulator, some others you can configure it in the .cfg files.

    In retroarch.cfg you are looking for the following bindings, adjust them to whichever buttons you need, with mine #8 is select and #9 is start

    input_enable_hotkey_btn = "8"
    input_exit_emulator_btn = "9"

    What other emulators are you using?

    Steve
    Participant
    Post count: 5

    Hey can someone help me with this?

    I can’t seem to get input_toggle_fast_forward_btn to work here’s what I got in my .cfg

    input_player1_joypad_index = 0
    input_player1_b_btn = 5
    input_player1_a_btn = 4
    input_player1_y_btn = 7
    input_player1_x_btn = 6
    input_player1_l_btn = 8
    input_player1_r_btn = 9
    input_player1_start_btn = 13
    input_player1_select_btn = 12
    input_player1_l_y_plus = -1
    input_player1_up_axis = -1
    input_player1_l_y_minus = +1
    input_player1_down_axis = +1
    input_player1_l_x_minus = -0
    input_player1_left_axis = -0
    input_player1_l_x_plus = +0
    input_player1_right_axis = +0

    input_player1_left_btn = 2
    input_player1_right_btn = 3
    input_player1_up_btn = 0
    input_player1_down_btn = 1

    input_toggle_fast_forward_btn = 10

    input_enable_hotkey_btn = 12
    input_exit_emulator_btn = 13
    input_save_state_btn = 8
    input_load_state_btn = 9

    where 10 is my Right trigger on my xbox controller

    I’m thinking maybe the RPi is not powerfull enough to fast forward emulators. tried it for NES SNES but nothing. any help would be great.

    trimmtrabb
    Participant
    Post count: 480

    The hotkey lets you assign multiple functions to one button, e.g. you could set the hotkey as the start button and exit emulator as the select button so the combination of the two will exit the emulator. There are other functions you can access this way too:

    input_save_state_btn =
    input_load_state_btn =
    input_state_slot_increase_btn =
    input_state_slot_decrease_btn =
    input_menu_toggle_btn = (access Retroarch GUI)

    cougar281
    Participant
    Post count: 26

    Well, I wasn’t sure what you meant I should add, so I added ‘input_enable_hotkey_btn = “8”‘ in addition to ‘input_exit_emulator_btn = “8”‘ and that works – I assume that’s what you meant…

    trimmtrabb
    Participant
    Post count: 480

    To use the exit emulator button you need to assign a hotkey with:

    input_enable_hotkey_btn =

    bpowell454
    Participant
    Post count: 2

    Hi,

    I’ve had a good search around but haven’t been able to find an answer, only 1 person with the same problem (http://www.raspberrypi.org/forums/viewtopic.php?t=45723). I’ve setup RetroPie following a guide and can play a game with a keyboard and have tried to get my 2 usb snes controllers working. After multiple deletes of cfg files and redoing the controller setups, I was able to get both controllers running Emulationstation correctly. Now the issue I have is in-game on both controllers, when I press the down key, it also registers a B button press. This first started in Emulationstation and after looking at the .emulationstation/es_input.cfg I found the B key was written as an axis and had the same value as the down axis, I renamed the B as a button and that fixed the problem in Emulationstation but then appeared in the snes emulator itself, even though the /home/pi/RetroPie/configs/all/retroarch.cfg is correct. Is there another .cfg file that may be interfering that I need to change also?

    Here is a dump of my /home/pi/RetroPie/configs/all/retroarch.cfg file.

    system_directory = /home/pi/RetroPie/BIOS
    config_save_on_exit = “false”
    video_threaded = true
    video_smooth = false
    video_aspect_ratio = 1.33
    video_shader_dir = /home/pi/RetroPie/emulators/RetroArch/shader/
    audio_out_rate = 44100
    audio_driver = alsathread
    input_autodetect_enable = “true”
    joypad_autoconfig_dir = /home/pi/RetroPie/emulators/RetroArch/configs/
    input_player1_a = x
    input_player1_b = z
    input_player1_y = a
    input_player1_x = s
    input_player1_start = enter
    input_player1_select = rshift
    input_player1_l = q
    input_player1_r = w
    input_player1_left = left
    input_player1_right = right
    input_player1_up = up
    input_player1_down = down
    input_exit_emulator = escape
    input_shader_next = m
    input_shader_prev = n
    input_rewind = r
    input_enable_hotkey = escape
    rewind_enable = false
    rewind_buffer_size = 10
    rewind_granularity = 2
    video_gpu_screenshot = true
    input_player1_joypad_index = 0
    input_player1_b_btn = 2
    input_player1_a_btn = 1
    input_player1_y_btn = 3
    input_player1_x_btn = 0
    input_player1_l_btn = 4
    input_player1_r_btn = 5
    input_player1_start_btn = 9
    input_player1_select_btn = 8
    input_player1_l_y_plus = -1
    input_player1_up_axis = -1
    input_player1_l_y_minus = +1
    input_player1_down_axis = +1
    input_player1_l_x_minus = -0
    input_player1_left_axis = -0
    input_player1_l_x_plus = +0
    input_player1_right_axis = +0

    input_enable_hotkey_btn = 8
    input_exit_emulator_btn = 9

    input_enable_hotkey_btn = 8
    input_save_state_btn = 4

    input_enable_hotkey_btn = 8
    input_load_state_btn = 5

    input_player2_joypad_index = 1
    input_player2_b_btn = 2
    input_player2_a_btn = 1
    input_player2_y_btn = 3
    input_player2_x_btn = 0
    input_player2_l_btn = 4
    input_player2_r_btn = 5
    input_player2_start_btn = 9
    input_player2_select_btn = 8
    input_player2_l_y_plus = -1
    input_player2_up_axis = -1
    input_player2_l_y_minus = +1
    input_player2_down_axis = +1
    input_player2_l_x_minus = -0
    input_player2_left_axis = -0
    input_player2_l_x_plus = +0
    input_player2_right_axis = +0

    input_enable_hotkey_btn = 8
    input_exit_emulator_btn = 9

    input_enable_hotkey_btn = 8
    input_save_state_btn = 4

    input_enable_hotkey_btn = 8
    input_load_state_btn = 5

    I’m a bit of a noob so any help would be appreciated :)

    johnes
    Participant
    Post count: 28

    Followed guide here:
    http://www.petrockblock.com/2013/12/02/retropie-autoconfig-functionality/

    Having couple issues:
    – My 710 and 310 controllers are detected if I run jstest but not in emulationstation.
    – So I followed the guide here: http://www.petrockblock.com/2013/12/02/retropie-autoconfig-functionality/
    – Step 3 has been running for over 24 hours now… I already had the emulators installed, is it not smart enough to know that? In otherwrds it just downloads, compiles them, etc no matter what?

    Step 1:
    File is not saved at /home/pi/RetroPie/emulators/RetroArch/configs/

    It’s stored here… /home/pi/RetroPie/configs/all/

    But I think there might be something wrong with it.

    Here’s my file:
    system_directory = /home/pi/RetroPie/emulatorcores/
    video_aspect_ratio = 1.33
    video_shader_dir = “/home/pi/RetroPie/shader/”
    video_shader = “/home/pi/RetroPie/shader/*.glslp”
    video_shader_enable = true
    audio_enable = true
    audio_out_rate = 44100
    audio_driver = sdl
    audio_sync = true
    input_player1_a = x
    input_player1_b = z
    input_player1_y = a
    input_player1_x = s
    input_player1_start = enter
    input_player1_select = rshift
    input_player1_l = q
    input_player1_r = w
    input_player1_left = left
    input_player1_right = right
    input_player1_up = up
    input_player1_down = down
    input_player2_a = x
    input_player2_b = z
    input_player2_y = a
    input_player2_x = s
    input_player2_start = enter
    input_player2_select = rshift
    input_player2_l = q
    input_player2_r = w
    input_player2_left = left
    input_player2_right = right
    input_player2_up = up
    input_player2_down = down
    input_player1_joypad_index = 0
    input_player2_joypad_index = 1
    input_enable_hotkey_btn = 8
    input_exit_emulator_btn = 9
    input_enable_hotkey_btn = 8
    input_save_state_btn = 4
    input_enable_hotkey_btn = 8
    input_load_state_btn = 5
    input_player1_left_axis = -0
    input_player1_right_axis = +0
    input_player1_up_axis = -1
    input_player1_down_axis = +1
    input_player2_left_axis = -0
    input_player2_right_axis = +0
    input_player2_up_axis = -1
    input_player2_down_axis = +1
    input_exit_emulator = escape
    input_rewind = r
    rewind_enable = true
    rewind_buffer_size = 10
    rewind_granularity = 2

    2.) I did this, but “Update the input configuration of Emulation Station with the RetroPie Setup Script”

    Finally, I see permissions set like this – why are some pi/pi and some root?
    4 drwxr-xr-x 2 root root 4096 May 24 18:59 cpc4rpi-1.1
    4 drwxrwxr-x 9 pi pi 4096 May 24 18:59 atari800-3.0.0
    4 drwxr-xr-x 6 root root 4096 May 24 19:59 basiliskii
    4 drwxr-xr-x 8 pi 513 4096 May 24 20:10 vice-2.4
    4 drwxr-xr-x 9 root root 4096 May 24 22:21 gpsp
    4 drwxr-xr-x 9 pi users 4096 May 25 07:30 advancemame-0.94.0
    4 drwxr-xr-x 11 pi pi 4096 May 25 09:18 mame4all-pi
    4 drwxr-xr-x 10 root root 4096 May 25 13:33 pifba
    4 drwxr-xr-x 6 pi pi 4096 May 25 13:43 osmose-0.8.1+rpi20121122
    4 drwxr-xr-x 15 root root 4096 May 25 14:18 dgen-sdl
    4 drwxr-xr-x 6 root root 4096 May 25 15:35 gngeo-pi-0.85

    typh0id
    Participant
    Post count: 34

    Thank you so much for that advice! I had to use the entry “input_menu_toggle_btn” but that did the trick! It would certainly be nice to be able to hotkey turning the color on and off since I’d rather play the pre-super Gameboy games in black and white but now that I have the retroarch menu mapped to my gamepad I am plenty happy I can just pop into that whenever I want and make the change manually. Thanks again!

    typh0id
    Participant
    Post count: 34

    I have settled for running the emulator in full screen and then manually flipping my TV over to 4:3. Its not ideal, as I would prefer to have the emulator do it manually so I don’t have to keep switching back and forth, but it’s better than nothing I suppose :)

    I DID manage to get the hotkey function working (though I’m not entirely sure how I did it :P ) but I am having trouble getting the second controller to work properly. I cut and pasted a second copy of the controller mapping in snes9x.cfg for controller 1 (JS0) and renamed it to (JS1) but PiSNES seems to be having trouble understanding my second controller. The face buttons and d-pad seem ok but Start and Select don’t respond at all and some games (such as Super Mario World) don’t seem to recognize there even IS a second controller (SMW auto defaults to 1 controller hotseat mode). Even more oddly, when I have the second controller mapped in the config, the button assignments seem to have changed (in game) on my first controller. I have a feeling the two are conflicting with each other somehow in the cfg file but I’m not sure what exactly the issue is.

    gizmo98
    Participant
    Post count: 452

    You can only save states with one key if no hotkey is selected. Check if “input_hotkey” is set.

    hacha-dorada
    Participant
    Post count: 39

    Regarding the emulators that do not respond to hotkeys: some of the emulators in RetroPie do not use the RetroArch configurations, but exclusive config files (e.g. DGen, Osmose). You will need to check online or in the forums how to customize said emulators, or choose a different one from RetroPie to use with the specific systems you want to emulate.

    Second, I don’t think there is any use in setting such shortcuts by default, as the identities of buttons depend on the controllers you are using. It is easy enough to set up your own combinations in the cfg file.

    IIeBoy
    Participant
    Post count: 28

    Thanks. I added the following and it works from within most emulators. Dev, could you shed any light as to why it won’t work from the Commodore 64, MAME4All, Atari ST…? Is there something overriding them?

    I have the Xbox 360 controllers. This means I press the left joystick button down, then press Y to exit to the EmulationStation menu.

    input_enable_hotkey_btn = 11 
    input_exit_emulator_btn = 3
    
    input_enable_hotkey_btn = 11 
    input_save_state_btn = 0
    
    input_enable_hotkey_btn = 11
    input_load_state_btn = 2

    To the developer, can I suggest you make this standard please, for maximum ease of usage?

    hacha-dorada
    Participant
    Post count: 39

    I am not sure about restarting the Pi (that is something outside the RetroPie capabilities) but if you dig into the RetroPie/configs/all/retroarch.cfg file (or the specific ones for the different systems), you can define buttons for the other functions. A very useful option is to set up a shortcut for the RetroArch menu, that serves to most of your needs.
    You can also map hotkeys on you joy for all these functions too.

Viewing 35 results - 946 through 980 (of 1,077 total)