Tagged: 

Viewing 35 posts - 141 through 175 (of 252 total)
  • Author
    Posts
  • petrockblog
    Keymaster
    Post count: 1828

    you may want to update mupen64-libretro (from binary or source – if from source update retropie-setup first) as that has been updated since the image was made.

    petrockblog
    Keymaster
    Post count: 1828

    and mupen64plus (from source as I can’t update binaries currently due to the retropie site move)

    jrodger
    Participant
    Post count: 11

    Hi Buzz,

    Thanks for the great work.

    Noob question, can i compile the emulators etc myself for the pi2?
    is it just a matter of gcc -march=armv7-a -mfpu=neon-vfpv4 -mfloat-abi=hard
    or is there alot more to it?

    i’ve already upgraded my 2.4 image.

    petrockblog
    Keymaster
    Post count: 1828

    if you mean manually outside of retropie, then yeh those would work, we are using -mcpu=cortex-a7 -mfpu=neon-vfpv4 -mfloat-abi=hard (plus optimisation flags like -O2)

    if you mean compiling retropie components, if you are running it on a pi2 with the latest code, it will automatically do this. You can override the platform manually by doing

    
    sudo __platform=rpi1 ./retropie_packages.sh (or retropie_setup.sh)
    sudo __platform=rpi2 ./retropie_packages.sh (or retropie_setup.sh)
    
    tom4
    Participant
    Post count: 2

    Hi !

    Though I’d share my experience with the RPI 2.

    First I’m a total newbie to raspberrys and linux, in fact I just heard about the RPI 2 when it came out and was very interested in it then learned about Retropie. and I came up with a project of building a retro arcade cofee table.

    I installed retropie from raspbian using the retropie script, it works great !
    Every emulator works but some roms won’t dont know why yet.

    For example Super Mario works fine on N64, but I can’t get Mario Kart to work (I can watch the intro but can’t play).
    Or some roms still have audio issues, even after updating the N64 emulator from source on the retropie setup.

    The best working emulator after my tests was the PSX, I tried many roms, most of them worked fine at normal speed without any image or audio bugs. I was pretty surprised seeing that coming out of the RPI 2

    gizmo98
    Participant
    Post count: 452

    There are two n64 emulators. Each has an own rom dir (n64 and n64-mupen64plus). Both have the video plugins video-n64 and video-rice. Some games run better with the rice plugin, some run better with the n64 plugin. If you use mupen64plus-libretro press F1 and go to core settings. There you can change the default video plugin (needs restart). The default video plugin of mupen64plus can be changed under /opt/retropie/configs/n64/mupen64plus.cfg.

    tom4
    Participant
    Post count: 2

    Yeah I noticed the 2 differents emulators and tried both but didn’t know about the video plugins, I’ll try to change them on libreto thanks !

    cosmos
    Participant
    Post count: 3

    Hi Buzz.

    Thanks for all the effort. Really apreciated :-)

    You got some documentation on how to setup a cross compile environment for retropie ?

    I never cross compiled something like retropie. I did for individual binaries but never for such a project as retropie. I can only assume the building of a new image is not as simple as it would be when building debian live images.

    dk999
    Participant
    Post count: 11

    With RPi2 using ARMv7, will there be two RetroPie-Distributions in the long run, compiled for each architecture?

    chito
    Participant
    Post count: 137

    [quote=86853]With RPi2 using ARMv7, will there be two RetroPie-Distributions in the long run, compiled for each architecture?[/quote]

    Well until everything gets sorted out on the rpi2 maybe. Buts there is no reason to keep your b+ or to support it long term. Just buy the new raspberry 2 Its $35. That’s 10 or so coffees, 3 meals at macers

    petrockblog
    Keymaster
    Post count: 1828

    Well, basically you do this

    http://www.openframeworks.cc/setup/raspberrypi/Raspberry-Pi-Cross-compiling-guide.html

    and once it is working, you just need to make sure all the makefiles and so see the distcc gcc on the pi (or chroot – which is even quicker, since you can have 8 emulated cores on a fast ssd then).

    Something like

    
    sudo PATH="/usr/lib/distcc:$PATH" MAKEFLAGS="-j4 PATH=/usr/lib/distcc:$PATH" __platform=rpi1 ./retropie_setup.sh
    

    I use -j8 or more in my chroot but for a real pi, this will need to be a bit less, due to io speed, and the fact the pi is still doing the preprocessing.

    Note some emulators may fail with -j8 as they don’t have makefiles that play nicely with parallel building. But most will build.

    as an example. I just did

    
    time sudo PATH="/usr/lib/distcc:$PATH" MAKEFLAGS="-j8 PATH=/usr/lib/distcc:$PATH" __platform=rpi1 ./retropie_packages.sh advmame
    

    completes in 8m45s.

    dk999
    Participant
    Post count: 11

    [quote=86854]
    Well until everything gets sorted out on the rpi2 maybe. Buts there is no reason to keep your b+ or to support it long term. Just buy the new raspberry 2 Its $35. That’s 10 or so coffees, 3 meals at macers
    [/quote]
    Was just wondering if there will be two images for the next versions as long as many people claim for it. I’ve ordered my Pi2 yesterday but a statement from the developer(s) would be nice. Do I have to compile everything on my own for maximum speed on my Pi2? Will there be only a Pi1 version because it also runs on the Pi2?

    moothead2
    Participant
    Post count: 4

    I’ve been messing around with shaders on Retroarch’s PSX emulator and I found #33 I think it was to look best but performance tanks hard. Do you reckon they can improve performance with the new hardware in time or is it just too much for the current hardware?

    doraemon
    Participant
    Post count: 3

    i’ve tryed the last pi2 image from googledrive.
    with this image no n64 games will work for me, the emu crashes with a sound error message.
    the problem exist with both n64 emus.
    with the imageversion before there is no crash.

    HoZy
    Participant
    Post count: 2

    Latest source compile mupen64plus emulator black screen with audio, Through latest retropie-setup.

    neighbourhoodnerd
    Participant
    Post count: 111

    New version is working well for me.

    Using only default settings:

    Working emulators:

      GB
      GBC
      GBA
      N64
      PSX
      SNES
      Genesis

    Not working:

      MAME
      MAME-Libretro

    I still get random crashes though. I’ve only had two so far since installing the latest image, but it makes me nervous. Think my unit is faulty, or should I try a different SD card?

    petrockblog
    Keymaster
    Post count: 1828

    None of the main devs have a rpi2 yet afaik, so please wait until we have ours and can look into this further. I built the optimised versions in an emulated environment so have not been able to test anything properly yet.

    franky
    Participant
    Post count: 2

    I just got my RPi2 yesterday and have had limited time to try things out, but MAME worked fine for me using buzz’ latest image. I did only try one game though, 1942.

    Anonymous
    Inactive
    Post count: 4

    Hi everyone.

    I’ve done something really wrong, I’m completely new to this so go easy one me and please forgive me if I’ve posted in the wrong section.

    I’ll run through what I did yesterday and if someone would be kind enough to tell me what I did wrong I would be very grateful.

    So I bought a 32GB Micro SD card along with one of those USB adapters so I could use it in my Mac. I downloaded the RetroPie image, extracted it and used the RPI-sd card builder software to write the image to my SD card. All good so far.

    I put the SD card in my Raspberry Pi and followed a tutorial to get it up and running. I ended up doing something wrong and messing it up so I thought I would format my SD Card, write the image again and start over.

    I put the SD card back in my mac and go to disk utility. I notice on the left hand side it says ‘2.2 TB USB2.0 CARD-READER Media’ but didn’t think anything of it and went ahead and clicked the ‘erase’ tab (formatting it as MS DOS FAT). It got half way through and then it just froze. I quit disk utility and went to try again but when I put my SD card in now it says ‘The disk you inserted was not readable by this computer.’ It still shows up on disk utility though. I tried it in my phone as well and it’s not recognising it.

    Is my SD card broke? Did I do something wrong?

    Any help would be greatly appreciated. Thanks.

    pmurch
    Participant
    Post count: 26

    Did you buy your sd card on eBay? There are a LOT of cards where they mislabel the size and use firmware tricks to fake it to the OS sold on there. This causes odd behaviour like you describe.

    adcooney
    Participant
    Post count: 52

    I’ve also just got my Rpi2 and used Buzz initial image on page 2 as I saw some people had some issues with the latest and wanted to test it first. Only tried a few things so far and have not overclocked but appears to run OK. Going to try further tonight and see if the N64 and PS1 emulators work. Cheers for the images Buzz makes life much much easier.

    gloob
    Participant
    Post count: 2

    Hello,

    Thanks for the great work so far. Everything is running quite smoothly at the moment but I have two question:

    • What settings should be used for the memory split?
    • I can exit every emulator with a combination of “Select” and “Start” on my controller. Only for the N64 games I have to use the keyboard and press “ESC”. It would be really cool to exit N64 games also via gamepad, because then I can completely remove the keyboard from the raspberry. Is this possible?
    robertybob
    Participant
    Post count: 219

    Has anyone tried Sega CD and/or Sega32x? These weren’t running all that well before – has the Pi 2 improved their emulation speeds?

    doraemon
    Participant
    Post count: 3

    @dannyjrendall

    Try ‘sd formatter’ from sdcard.org to format your sd-card under osx.
    For writing the images to sd-card ‘ApplePi-Baker’ works fine for me.

    fqpl
    Participant
    Post count: 2

    Out of any weird reason i ve a black frame around the ui of the emulationstation. I ve set the value on 4 instead of 0, but didnt work. Also some n64 games are not working. Does someone have any ideas?

    adcooney
    Participant
    Post count: 52

    I’ve tried testing n64 and psx. PSX segmentation faults when loading games – if I recall there is a jar you need to put somewhere but cannot recall where. I will check my old pi I guess to find it.

    N64 I have found:
    * Diddy kong racing gets to the ‘rumble pak’ screen and wont go further no matter what I press
    * Mario 64 works perfectly fine
    * Banjo Kazooie – works but the text and health areas are pixelated. Viewing the menu also shows a pixelated screen
    * Star wars pod racer – Doesn’t work. The video is not positioned correctly with respect to the screen and it is very slow in both video and audio
    * Smash bros works 1v1 but when there are multiple opponents (i.e. second level) then it throttles
    * Mario Tennis – Doesn’t even boot. No error given.
    Mame:
    * Tried one game, worked perfectly
    Genesis
    * Tried several games, all worked perfectly

    This is with a pi2 set on high, xbox wired controller, overclocked to ‘pi2’ setting (not sure what default is) using the image on page2.
    Sound quality through a 3.5mm jack also has some background static that is quieter than the game audio but constant.

    pmurch
    Participant
    Post count: 26

    That audio noise is typical for the pi. A lot of places suggest replacing the built in analogue out with a cheapo usb sound card off ebay for around $2-5.

    herbfargus
    Member
    Post count: 1858

    @fqpl

    You might want to uncomment disable_overscan=1 in /boot/config.txt and that should solve the black border issue.

    fqpl
    Participant
    Post count: 2

    Should I just set it on 0 ?

    herbfargus
    Member
    Post count: 1858

    I just left it at 1 and it worked for me but it may be different for different monitors. The TV I’m using is vizio 42″ 1080p. The only thing I changed was deleting the “#” right before disable_overscan=1 and it solved the black border issue. You can mess around with the overscan settings as well if that doesn’t fix it.
    Floob made some great videos discussing video settings that may be useful to you: http://m.youtube.com/watch?v=AYB6r7q9JkU

    petrockblog
    Keymaster
    Post count: 1828

    Mupen64plus (romdir n64-mupen64plus) now has working video out on the rpi2 builds (need to update from binary or source from menu 5)

    pmurch
    Participant
    Post count: 26

    Does the config menu now grab optimized builds of the emulators then?

    petrockblog
    Keymaster
    Post count: 1828

    yep (make sure you update it first of course)

    HoZy
    Participant
    Post count: 2

    Interestingly enough, I get more hitching/lag/stutter on n64 with the latest builds than I did with an older build that I ran when I did the Mk64 video.

    pi2 overclock 1000/500/500/+2 with 384mb memory split, force_turbo=1.
    With heatsinks & fan @ 3.3v.

    tpm1999
    Participant
    Post count: 2

    Hello all,

    My pi 2 is in the mail and I noticed there are a few builds floating around for retropie. Which build currently works best with mame4all , specifically with CPS2 games (my favorite games)?

    I know the landscape is moving fast and I fully understand I will have to download updates but I just want to start from somewhere usable for now.

    Thanks!

Viewing 35 posts - 141 through 175 (of 252 total)
  • The topic ‘Raspberry-pi 2 compatibility’ is closed to new replies.