Forum Replies Created

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • Jara
    Participant
    Post count: 14

    This is what I came up with a few months ago.

    Edit: it’s h0right. horight typo on image

    Tupadre has X and B buttons reversed compared to what I have.

    Jara
    Participant
    Post count: 14

    That should be it.
    I had the same issue and when I changed the emulator it recognized all my saved games.

    Jara
    Participant
    Post count: 14

    1) I had the same issue with my controllers. All the button configs were messed up. Turns out the system detected my controller and used a predefined config file for it. Problem was solved editing retroarch.cfg and changing “input_autodetect_enable = true” to false. Other solution is simply removing the config file that the system is autodetecting ( /opt/retropie/emulators/retroarch/configs). Don’t know if it’s the problem you’re having, but it’s worth a try.

    2) If the solution above worked, it should fix that issue as well. The predefined config file had rewritten the exit emulator buttons (in my case ESC key didn’t work).

    3) Also tried Maro Kart 64 and I didn’t have any of the issues you had (using default emulator) and not configuring anything else

    4) With 3.0 GBA emulator works fine for me (default emulator, not onfiguring anything). I just put the gba_bios.bin in home/pi/RetrOpie/BIOS and nothing more.
    3 and 4 are not solutions, but just to let you know how it was for me.

    Jara
    Participant
    Post count: 14

    I removed the cfg file for my joypad and that did the trick (see previous post edit).

    Chack if that works for you laundromat.
    Remove the CFG (or I guess you could change the line “input_autodetect_enable” from true to false in retroarch.cfg.

    Now I just have to check the issue with SNESDev’s reset/shutdown button (which hopefully is the same as the one I had before).

    Jara
    Participant
    Post count: 14

    Yeah. That’s my next step as well. Weeding out cfg files. It’s a hassle because I have to give writing permissions, but it has to be tried.

    In the emulators where the start+select combo is enabled, you can’t use escape to exit (which is most of them). In NeoGeo the combo doesn’t work, but hitting escape does. I already had trouble some months ago with “enable_hotkey” overriding other configs so I don’t use it anymore.

    Edit: /opt/retropie/emulators/retroarch/configs has cfg files that override whatever is in retroarch.cfg (as this file draws configs from that folder). There is a config file for my joypad (logitech F310). I’ll try removing or editing that file to see if problem persists.

    There is also a config for Wiimote, so you should check there as well. I’ll post again if it works.

    Jara
    Participant
    Post count: 14

    I’m having some issues with the controllers.
    I do the retroarch config like usual, but the retroarch.cfg remains unchanged. Could be something about permissions, will check that later.
    SNES controllers are all messed up.

    So far I’ve liked the changes made. I’ll just have to try each of the emulators and options to find the most optimal one for each system.

    Jara
    Participant
    Post count: 14
    input_enable_hotkey_btn = "X"
    input_exit_emulator_btn = "Y"

    (source https://supernintendopi.wordpress.com/ )
    X and Y select and start buttons.

    I used this lines and it worked fine on most emulators. Did you have it in a different way?

    Jara
    Participant
    Post count: 14

    I was too lazy to do it before, but solved the problem rather quickly.

    The issue presents itself when adding these two lines to retroarch.cfg (/opt/retropie/configs/all/)

    input_enable_hotkey_btn = "X"
    input_exit_emulator_btn = "Y"

    With X and Y buttons on the controller. It’s a button combination to exit the emulator. Taken from this guide https://supernintendopi.wordpress.com/

    I guess that adding that option to exit emulators with a controller button combination somehow prevents SNESDev from using it’s button (in pin 11) to do the same thing.

    But like I said before, in RetroPie 2.3 that problem doesn’t happen. I can exit with both the controller button combination and the SNESDev button in Pin 11 (with the same configuration).

    It would be good to know if someone who is using the GPIO adapter has this same problem when adding those lines to retroarch.cfg.

    I’ll contact the person that wrote that guide in case he wants to add a warning about this issue.

    Jara
    Participant
    Post count: 14

    Hi

    Thanks for your reply.
    Haven’t had time to go back to the problem in the past week.
    I’m not using a Pi2, so I don’t know if the update you mention should make any difference (on my Pi B).

    I’ll try a fresh “installation” of the retropie image and only configure snesdev to see if it works fine. If it does, I’ll start configuring things one by one and checking if the button works each time. This in case somehow something I configured is what caused the issues with snesdev (seems unlikely, but I’ll try anyways).

    I’ll keep you guys posted.

    Edit:
    Ok. With a clean image installation it works fine.
    I’ll still check if it keeps working after every different configuration I do in case the issue arises again.

    Jara
    Participant
    Post count: 14

    Mine’s in Xinput as well.
    For controller configuration I followed this guide (on a Pi B).
    Nothing else.

    Jara
    Participant
    Post count: 14

    I have the same controller and haven’t had any problems with it so far (on any popular console emulators). Didn’t install any kind of drivers either.

    I can’t check now if it’s set with Direct or X input (I’m traveling tonight and it’s a the bottom of my bag).

    I’ll be able to tell you tomorrow. It’s a great controller and hopefully you can solve the issue.

    Jara
    Participant
    Post count: 14
Viewing 12 posts - 1 through 12 (of 12 total)