Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • wesyork
    Participant
    Post count: 4

    I’ve downloaded the RetroPie image and everything seems to be working ok except for one issue: games that use the Genesis/Megadrive 6-button controller. For example, Street Fighter 2 or Spiderman: Maximum Carnage. I’m starting to think I’m going to have to choose a different emulator but I want to make sure first.

    I’ve read that the default emulator for the Genesis/Megadrive is Retroarch using the picodrive core. However, when I look at the retroarch.cfg file under /home/pi/RetroPie/configs/megadrive there is no “c” or “z” keys, there is only a,b,y,and x keys. The A,B, and C buttons on the controller are mapped to “input_player1_b_btn”, “input_player1_a_btn”, and “input_player1_y_btn” respectively in the retroarch.cfg file.

    I figured that maybe the input_player1_l_btn, input_player1_r_btn, and input_player1_x_btn inputs were being used for the X, Y, and Z buttons on the controller, so I mapped them out in the cfg file:

    input_player1_x_btn = 3
    input_player1_l_btn = 4
    input_player1_r_btn = 5

    That doesn’t work. I’ve also tried the R2, L2, R3, L3 inputs as well. Does anyone know the name of the input needed for the 3 X,Y,Z top buttons for Genesis controllers for RetroArch?

    trimmtrabb
    Participant
    Post count: 480
    wesyork
    Participant
    Post count: 4

    Yes, I’ve seen that link. Unfortunately when I tried to do that and selected “Core Options” there was nothing there. Even after selecting the picodrive core. Any idea on why I’m unable to see the core options in RetroArch?

    trimmtrabb
    Participant
    Post count: 480

    are you loading a game that supports 6 buttons?

    wesyork
    Participant
    Post count: 4

    Yes. I downloaded a couple of games that support it (Street Fighter 2, Spider-man: Maximum Carnage, etc.). I tested them out in a Windows emulator (gens) and all 6 buttons work fine. I then copied the games over to the raspberry pi and put them in the appropriate directories. Please note that I’m using the exact same controller to play it on Windows and the pi. I just unplugged it from my PC and plugged it into the pi. I know the controller isn’t the problem because if I re-assign the b,a,y keys to the top 3 buttons of the controller in retroarch.cfg like this:

    input_player1_b_btn = 3
    input_player1_a_btn = 4
    input_player1_y_btn = 5

    Then the top 3 buttons (x,y,z) work fine and the bottom 3 buttons (the A, B, and C) don’t do anything.

    The problem is that I don’t know the names of the inputs in retroarch.cfg for the other 3 inputs.

    I found this forum post from one of the main contributors to RetroArch that says, “Note that every console projects its own controller onto the RetroPad, which we have defined to be essentially the SNES controller + PS1 DualAnalog extensions (L2, L3, R2, R3 and two analog sticks). I don’t remember what C and Z buttons map to, but it’s probably L/R or something.”

    The problem is that I’ve attempted to use L and R, and they are not working. This page (http://picodrive.acornarcade.com/picodrive/info.html) makes it appear that the x,y,z buttons do not work with picodrive. If that’s the case, then what is the process for getting RetroArch to use a different emulator core other than picodrive?

    trimmtrabb
    Participant
    Post count: 480

    Picodrive is the fastest/most compatible emulator to use, the other option is DGEN which you can install via the setup script, you then need to edit es_systems with the correct paths. Not used DGEN much so no idea if it supports 6 buttons sorry.

    hacha-dorada
    Participant
    Post count: 39

    I have a 6 button USB joystick that I successfully configured for Megadrive. As I am not using it anymore (in favour of two PS2 joysticks), I cannot try to do it again. I am pretty sure DGen can definitely take 6 buttons. Have you checked this: https://www.petrockblock.com/forums/topic/sega-mega-drive-genesis-controlls-setup/ ?

    wesyork
    Participant
    Post count: 4

    Thank you trimmtrabb and hacha for the help. I will attempt to get DGen working tomorrow. I’m pretty sure that will fix the problem.

    chito
    Participant
    Post count: 137

    How did u go with this? Im having a similar problem

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.