Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • blackvyse
    Participant
    Post count: 6

    I’m trying to get retroarch (picodrive, I believe) to recognize a 6-button genesis controller setup using an Xbox 360 controller; at the moment, it defaults to 3-button on every tested game. I’ve been looking fruitlessly for a few days for a fix, but I’ve come up completely empty. :(

    Any assistance will be greatly appreciated. :)

    trimmtrabb
    Participant
    Post count: 480

    have a look through the Retroarch GUI, i’m sure i’ve seen an option in there to change controller type

    blackvyse
    Participant
    Post count: 6

    hmm, how would I access the Retroarch GUI?

    Can I go about that through emulationstation?

    I may not be correct, but I believe RetroPie uses the emulationstation frontend, which leverages the configurations set in retroarch to launch the picodrive emulator.

    trimmtrabb
    Participant
    Post count: 480

    You can access the Retroarch GUI by adding the following to your retroarch.cfg:

    input_enable_hotkey_btn = 
    input_menu_toggle_btn = 

    You can also create specific controls for Picodrive by placing another retroarch.cfg in /home/pi/RetroPie/configs/megadrive/ which will override the default retroarch.cfg

    blackvyse
    Participant
    Post count: 6

    Thanks man. :)

    I found the option to use a 6-button controller under the “Core Options…” menu.

    trimmtrabb
    Participant
    Post count: 480

    cool, glad you sorted it :-)

    metzger
    Participant
    Post count: 15

    Was looking at this post as I am trying to get my 360 controller to work as a 6 button genesis. Where do you find “core options?” Is this something you have to go into a text file and change or where do you find it? I want to play my Montana sports talk football but it requires 6 buttons.

    Marco
    Guest
    Post count: 908

    Hi Metzger,

    To access the core options you need to enable it on the retroarch.cfg file, under the retropie 2.3 image this can be found here:

    /opt/retropie/configs/all/retroarch.cfg

    The lines you need to change are: (Thanks Trimmtrab)

    input_enable_hotkey_btn =
    input_menu_toggle_btn =

    The “input_menu_toggle_btn =” is your button joypad number

    You will also find there a commented line

    # Toggles Menu
    # input_menu_toggle = f1

    Uncomment this one too.

    Please remember:
    These are the paths for the 2.3 image, the old image has different paths

    For this to work make sure you are using the latest image 2.3
    http://www.petrockblock.com/retropie/retropie-downloads/

    Please let us know if this has helped you.

    chrisdem
    Guest
    Post count: 908

    I need to do this stuff but I need move explanation

    I tried adding input_enable_hotkey_btn =
    input_menu_toggle_btn = to the very top of my retroarch.cfg file, now what

    spanner
    Participant
    Post count: 17

    How do you control the menu with your joypad at the moment i have to put in a keyboard to move with the arrow keys…??

    merichards
    Participant
    Post count: 3

    Hi chrisdem,

    After the = you need to add the numbers for the buttons you want to use. They will be the ones you set up using retroarch-joyconfig

    Then you need to hold the button you setup as input_enable_hotkey_btn and press the button you setup as input_menu_toggle_btn at the same time.

    If you use some controllers you’ll find the button maps differ depending on the drivers, this happens with the Xbox 360 controllers depending on whether you use the image 2.3 native xpad drivers or the xboxdrv drivers to avoid the flashing lights.

    Hope that helps.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.