Forum Replies Created

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • slayer612
    Post count: 4

    [quote=121744]FYI – the wiki needs to be updated. Specifically Step 5. In RetroPie 3.6, there is no more “Configure joystick/controller for use with RetroArch” option.


    That’s why the section you are referring to reads “This section is for Wheezy based RetroPie (pre version 3.4)” in the title.

    There is no step 5 in the section “This section is for Jessie based RetroPie (version 3.4 and later)”, which would be the right section for setting up your controller in RetroPie 3.6.

    Post count: 4

    I got my 8Bitdo NES30 Pro to work by following Floob’s video tutorial step-by-step. The only thing I did differently was to bind the controller using “power + R1” instead of “power”, so it runs in Joystick mode and lets you bind L2 and R2 (which did not work in the video tutorial).

    Following this video and once you configured the controller in emulation station, the controller should be set up for all emulators, except for Megadrive/Genesis. This is also mentioned in the video. You’ll need to switch to 6 button controller and configure your button mappings manually for Megadrive.

    There’s another problem regarding the hotkey mappings in mupen64plus (N64 emulator). I found a quick and dirty solution for that one by digging through the forums, but it seems there is also a way to do that using the Configuration Editor – I haven’t found that setting yet, but I will have a look at it as soon as I’m home again. However, here’s the thread where I describe the problem.

    On a side-note:
    Downgrading your conrtoller firmware will add problems rather than solving yours. The Joystick mode has just been added with version 1.69, so you will be stuck with your shoulder buttons (L2 and R2) not working.

    Post count: 4

    With some further research I found a “solution” to the problem described above in THIS THREAD (which I didn’t see earlier, unfortunately). So in case anyone encounters the same problem:

    The cause for the hotkeys not working is indeed the “wrong” button IDs, which are being written into mupen64plus.cfg automatically.

    I disabled this feature in the /opt/retropie/emulators/mupen64plus/bin/ by commenting out the following lines:

    # write hotkey to mupen64plus.cfg
     # iniConfig " = " "\"" "$configdir/n64/mupen64plus.cfg"
     # iniSet "${hotkeys_m64p[$i]}" "$bind"

    Then I manually made my settings in /opt/retropie/configs/n64/mupen64plus.cfg by adding the button IDs shown by jstest:

    # Joystick event string for stopping the emulator
    Joy Mapping Stop = "J0B10/B11"
    # Joystick event string for switching between fullscreen/windowed modes
    Joy Mapping Fullscreen = ""
    # Joystick event string for saving the emulator state
    Joy Mapping Save State = "J0B10/B7"
    # Joystick event string for loading the emulator state
    Joy Mapping Load State = "J0B10/B6"

    This fixed my problem – the hotkeys are working now.

    I still don’t understand where those other button IDs retroarch uses are coming from though…

Viewing 3 posts - 1 through 3 (of 3 total)