Tagged: 

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • theroamer
    Participant
    Post count: 23

    I just got an 8bitdo nes30 pro and did a fresh retropie 3.6 install. The controller connects easily over bluetooth and works in emulationstation and mame (after configuring the bindings in mame). When I try to use an nes game however, nothing works.

    The game launches and “8Bitdo NES30 Pro Joystick configured in port #0.” appears in yellow, but everything is dead.

    The only thing that seems to work is enter on the keyboard for start/pause, but nothing else. I have to reboot the pi to get out of it.

    Tried adding stuff to /opt/retropie/configs/all/retroarch.cfg but that didn’t help.

    I’m sure it’s a messed up config file, just don’t know which one or where it is. Any ideas?

    auswear
    Participant
    Post count: 65

    It sounds like you’ve paired the pad in keyboard mode. Try re-pairing it in joystick mode:

    1) Reset controller by holding start for 15 seconds
    2) Put controller in correct sync mode by holding START + R1

    theroamer
    Participant
    Post count: 23

    Tried that and it didn’t seem to change anything. I set it up originally with start + R1 so I think it already was in joystick mode. Any way to tell for sure?

    king0fk0ng
    Participant
    Post count: 4

    I’m also having this issue, along with many more. I posted this issue on Reddit but got down voted.

    BTW, you know you’re in Joystick mode because you’ll see “Joystick” in “8Bitdo NES30 Pro Joystick”. If you we’re in Joystick mode, the name wouldn’t have “Joystick” in it.

    theroamer
    Participant
    Post count: 23

    yeah, I’ve tried both keyboard mode and joystick and same issue. The dpad does seem to work though. It leads me to believe that retroarch is pulling the bindings from some other config file rather than the one in /opt/retropie/configs/all/retroarch-joypads since changing settings in there seems to make no difference.

    FWIW I’m also on the latest version of the 8bitdo firmware 1.69

    theroamer
    Participant
    Post count: 23

    I posted in your thread as well. (my guess is it got downvoted because of the title) Retropie is constantly evolving and there are always little issues like this. I’m sure this one will get figured out. Not a reason not to buy this controller as it’s pretty sweet otherwise.

    [quote=121746]I’m also having this issue, along with many more. I posted this issue on Reddit but got down voted.

    https://www.reddit.com/r/RetroPie/comments/4c29pr/do_not_buy_the_8bitdo_nes30_pro_controller_for/

    BTW, you know you’re in Joystick mode because you’ll see “Joystick” in “8Bitdo NES30 Pro Joystick”. If you we’re in Joystick mode, the name wouldn’t have “Joystick” in it.

    [/quote]

    king0fk0ng
    Participant
    Post count: 4

    @theroamer, we’re in the exact same boat and I agree with your theory on the controller config file not being read/updated.

    I actually download RetroArch 3.4 and downgraded my controller to firmware 1.68 to see if I can reproduce a working setup.

    slayer612
    Participant
    Post count: 4

    I got my 8Bitdo NES30 Pro to work by following Floob’s video tutorial step-by-step. The only thing I did differently was to bind the controller using “power + R1” instead of “power”, so it runs in Joystick mode and lets you bind L2 and R2 (which did not work in the video tutorial).

    Following this video and once you configured the controller in emulation station, the controller should be set up for all emulators, except for Megadrive/Genesis. This is also mentioned in the video. You’ll need to switch to 6 button controller and configure your button mappings manually for Megadrive.

    There’s another problem regarding the hotkey mappings in mupen64plus (N64 emulator). I found a quick and dirty solution for that one by digging through the forums, but it seems there is also a way to do that using the Configuration Editor – I haven’t found that setting yet, but I will have a look at it as soon as I’m home again. However, here’s the thread where I describe the problem.

    On a side-note:
    Downgrading your conrtoller firmware will add problems rather than solving yours. The Joystick mode has just been added with version 1.69, so you will be stuck with your shoulder buttons (L2 and R2) not working.

Viewing 8 posts - 1 through 8 (of 8 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.