Homepage Forums RetroPie Project Everything else related to the RetroPie Project Something not right with the 1.10 image

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #7239

    So I have been trying to set up RetroPie as outlined in a few threads I started. I have had several problems along the line – first, xboxdrv won’t work – in order to run it manually, I must run ‘rmmod xpad’ – then xboxdrv will start. The controller works without xboxdrv, but it never stops flashing the LEDs. When trying to set up the service, it kept complaining that a file was missing.

    Probably the biggest problem – simply having my USB hub connected to the RPi will cause a Kernel Debug every time – It’ll just hang at the splash screen. I know know it’s crashing because I caught it once by switching to a second terminal screen while it was booting (Alt+F2). I ended up with a <kdb> and a lot of debug info.

    I then loaded Raspian and started from there – it didn’t crash with my hub attached, I was able to get xboxdrv installed and ran properly as a service on boot – I then grabbed the RetroPie installer and ran that – the problem there is it seems a bunch of packages can’t be authenticated so they fail to install. I got the following message when trying to run emulationstation after installing all of the emulators: ‘/home/pi/RetroPie/supplementary/EmulationStation/emulationstation: error while loading shared libraries: libboost_filesystem.so.1.49.0: cannot open shared object file: No such file or directory’. Still got the message after installing ‘libboost-system-dev’ (which required that it either be run without the -y switch and be prompted to install, or use the –force-yes command to override the wanting about the packages that couldn’t be verified.

    You probably should update the script to use the ‘–force-yes’ switch instead of the ‘-y’ switch so that required packages that can’t be verified still get installed…


    An update:
    I re-imaged the card with Raspian again, ran ‘apt-get update’, ‘apt-get install xboxdrv’, ‘apt-get upgrade’, then configured the xboxdrv service – it tagged up fine, after rebooting the Pi, it still tagged up properly. I then grabbed ‘RetroPie-Setup’ and edited all of the scripts in ‘/RetroPie-Setup/scriptmodules’ and added ‘–force-yes’ everywhere there was an ‘apt-get install -y’. I then re-ran the retro-pie setup.

    The good:
    Emulation station works. The first time I ran the setup (previous image of Raspian earlier in the evening), it would not start because it couldn’t access a shared component (libboost) – even after installing that package, it still didn’t work. So it would seem more than one set of components failed to install due to not being able to be verified – adding the ‘–force-yes’ took care of that and allowed everything to get installed. The XBox controller still works right. I was able to map the buttons and load a NES game and play it for a short time (Haven’t tried SNES or Atari yet).

    The Bad:
    The music is ‘crackly’ and sounds a bit like a record that’s turning slower than it’s supposed to. I’m running audio through HDMI, not analogue (I had read that ‘crackly’ audio was to be expected from analogue). I’m not entirely sure if the game is playing as smooth as it should or if it’s just the audio that’s making it seem ‘off’. With the 1.10 SD image, the games ran pretty close to perfect, audio and all (although my wife complained that the controller ‘wasn’t responding fast enough’ *shrug*), but a bunch of other things didn’t work.

    Any thoughts on how I can fix the performance?


    No one has any thoughts on fixing the audio? I increased the OC two steps and that seems to have fixed the overall performance, but the Audio is still not ‘crackly’.


    Shouldn’t be performance issues with the NES emulator. Complete guess but the usb hub could be feeding power back to the Pi and causing problems, check it’s on the list of verified hubs here: http://elinux.org/RPi_Powered_USB_Hubs

    This is the usb hub I have been using for a year and a half with no issues: https://www.modmypi.com/New-Link-4-Port-USB-Hub-(USB-2.0-with-Mains-Adaptor)

    (Also available from other retailers)


    I am having similar issues. I recently upgraded to 1.10 image and the games play is sluggish and audio sounds sluggish, and the screen looks pixilated. I wish I could download and install a older version because I did not have any if these issues before.

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.