Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
  • Anonymous
    Post count: 5

    I’ve installed the latest version of Raspbian “wheezy” from here…

    Once it was imaged I Resize the filesystem and Setup 128MB memory split.

    I’ve went through the instructions on how to setup RetroPie from here…

    I’ve gone through the binary-based installation.

    After all that I setup my USB NES Controller, FTP’d in some NES and SNES games into their respected roms folders, rebooted and when I go to choose a game I get a quick flash to the command line that shows two lines of = “Equals signs” and it kicks me back to EmulationStation. I have tried a variety of different roms (i.e. Super Mario Bros, Contra III, Super Metroid, BattleToads, ect…) for both the NES (.nes) and SNES (.smc) but only came back with equal signs…

    I’ve seen these roms work with the RetroPie image Version 1.5 from…

    …but they aren’t working with the updated version of RetroPie.

    If I could get some help as to why I’m getting lines of “================” instead of lines of retro beauty that would be most appreciated.

    Post count: 1827

    Please give some more details that might help others to understand what exactly lead to this error (chosen emulator, ROM name, hardware setup, your interaction with the RPi, etc)

    Post count: 5

    WOW! Thanks for replying!

    The only emulators I’ve tried to use are the NES and SNES ones.

    SNES Games I’ve tried
    Contra III – The Alien Wars.smc
    Kirby’s Avalanche.smc
    Kirby’s Dream Course.smc
    Mario Paint.smc
    Super Mario RPG – Legend of the Seven Stars.smc
    Super Metroid.smc

    NES Games I’ve tried
    Contra Force.nes
    Super Mario Bros. 3.nes
    Super Mario Bros..nes

    512MB Raspberry Pi Project Board Model B
    Tomee NES USB Controller
    Dell USB Keyboard
    5V 1A Raspberry Pi Power Supply

    All straight from a USB Keyboard/NES Controller.

    Post count: 5

    Include Transcend 16GB Class 10 SDHC Flash Memory Card (TS16GSDHC10E)

    Post count: 1827

    Did you use the source-based or binaries-based installation?

    I would suggest to disconnect the USB game pad to exclude this possible source of errors.

    Post count: 5

    First Try:
    I used the source-based installation at first and I received a message saying something like… EmulationStation has started but there are no systems. or something like that. So I ran and went through the binaries-based installation. Once I rebooted, emulationstation booted right up. At this point I FTP’d in some roms and tried to start them. This is where I first saw the lines of equal signs. I figured I did something wrong so I started from base one and put the image of Raspbian “wheezy”.

    Second Try:
    After going through the writing the image of Raspbian and following the RetroPie setup instructions I got to the point on whether to do a binaries-based or source-based. I just did the binaries-based. Once the binaries-based installation was complete I imported some roms and tried again. I still received the lines of equal signs. At this point I posted the thread.

    Third Try:
    Since you said the gamepad might be causing some errors I tried unplugging and rebooting to run another binaries-based install. Still didn’t work.

    Fourth Try:
    I completely removed the gamepad from the equation so the only things that are connected to the Raspberry Pi are…

    Dell USB Keyboard
    Micro USB Power
    Ethernet cable

    As soon as I disconnected everything except the listed I inserted my fresh copy of Raspbian “wheezy” and went through the installation process and only doing the binaries-based installation. After that was all said and done it still doesn’t run. After that I tried the source-based installation and it still doesn’t open.

    Any other suggestions would be much appreciated.

    Post count: 21

    Things to check:
    SD Card: Has it been tried before or verified?

    Keyboard: Try plugging in another keyboard to see if something may be stuck

    Power Supply: RasPi can be touchy with power supplies.

    Graphics Memory Split: What are you set at?

    Command line attempts: Go into the EmulationStation systems config and try to manually input the commands to start a ROM through it’s specific emulator.

    EG: The command line syntax I am attempting from the Osmose directory is:
    ./osmose /home/pi/RetroPie/roms/mastersystem/A.sms -fs (where A.sms is the ROM name… it may help to rename the ROM to something w/o spaces or special characters)

    Post count: 1827

    Ok, I just found a bug in the script.

    Please use the updated version ( and replace the one at /home/pi/RetroPie/supplementary/runcommand/

    Post count: 5


    I re-installed RetroPie like I have been and it works perfectly now. (I had the image of RetroPie installed to double check the rom files).

    Thanks petrockblog! =D

    Also thanks Idris_Arslanian for suggesting things to check/try.

    Just to answer…

    – My SD card has been verified.
    – I have not attempted a different keyboard.
    – I used a suggested PSU from MCM.
    – I set my memory split to 128.
    – I haven’t tried to launch the rom from the command line interface.

    Post count: 5

    Hey guys,

    I have to admit that I am at a complete standstill with this project. After spending a couple hours getting through a learning curve, I am up to 6 hours with this exact same issue. My ROM’s show up fine, but as soon as you try to start any of them, it exits to the terminal only to immediately go back to the ROM list.

    When I found this page, I thought I had found the answer, but unfortunately I still face the problem. :(

    I replaced the text with the updated one listed, and I tried this on the 1.5 and 1.6.1 versions. I simply cannot get it to work.

    Now whenever I load up to RPI it doesn’t even load the emulator any more. It just sys “Run Entry Level:” which makes me think I have to reimage the SD Card for the 15th or so time.

    Any thoughts? Am I not saving the new correctly? I just take it into Notepad and copy the new text over the old text and save it.

    It’s really frustrating because I see so many people making elaborate projects and posting videos on YouTube about how easy this is to setup, and I haven’t even seen one game yet.

    Please help. :(

    Post count: 1

    Hi smoothgummi, not sure it’ll fix your problem but windows text files have different line endings to linux files so you may be better using nano as an editor directly within the raspberry pi console instead of pulling to windows and using notepad. Just exit emulationstation from the menu, change to the folder containing and type “nano” If you make your changes there and it still fails you can at least rule out the windows line endings problem.

    Post count: 1

    Just to add to the discussion, I’m having the =========== issue as well. Everything works fine but the actual launching of the roms. I’ve replaced the file with one I made via copy-pasting the fix code into Notepad++ and saving as a .sh file through the built in options. However, now when I attempt to start a rom I get the ======== as well as a line about permission being denied for I figure that the way I put in the file (WinSCP straight into the directory overwriting the initial file) must have messed things up, but I’m pretty new to the Pi and Unix/Linux so I’m a bit stumped as what to do.

    Also, I did go in via vi and look as the existing file in my Pi’s memory and as best I can tell, it’s exactly the same as the fix file’s text. I could be wrong though. I also haven’t attempted to launch any roms directly as I’m not terribly sure how to. Any suggestions would be greatly appreciated, I really want to start playing some retro games soon!

    Post count: 6

    I’m having a similar issue. I can start and play SNES games perfectly fine but can’t play NES games. When I start an NES game from the menu the screen flashes for a second and returns immediately to the splash screen. The suggestions here have not helped.

    Post count: 6

    I forgot to post the error I’m getting:

    /home/pi/RetroPie/supplementary/runcommand/ line 13: 2335 Segmentation fault retroarch -L /home/pi/RetroPie/emulatorcores/fceu-next/fceumm-code/ –config /home/pi/RetroPie/configs/all/retroarch.cfg –appendconfig /home/pi/RetroPie/configs/nes/retroarch.cfg /home/pi/RetroPie/roms/nes/Legend\ of\ Zelda.nes

    Post count: 5


    Thanks for the assistance, but as I went into the Nano editior, I realized that the file that is in version 1.6.1 is exactly the same as what he says to change it to above. Every character. Maybe he updated it when he went from 1.5 to 1.6.1 because he knew it was bad?

    Basically that leaves me back at the standstill. I have tried to get down to the absolute barebones for troubleshooting purposes. Nothing extra. Just the following:

    1. Fresh Image on the SD Card
    2. Loads automatically into RetroPie, I configure the buttons on a keyboard (removing the possibility of the controller causing any sort of weird issue).
    3. Exit RetroPie
    4. Load a single rom into the NES folder using Flash FXP. (I’ve tried 10 different ones)
    5. Restarting the Raspberry Pi, automatically loading into RetroPie
    6. Go to the NES page and try to load the rom that shows up just fine.
    6. Audible Chime heard, black screen, reloads the NES rom page.

    I just have no idea. I’m not trying to do anything fancy. I haven’t even configured the buttons for the actual NES emulator, though I’ve done that before and it did the same thing.

    Help :(

    Post count: 5

    Just wanted to give an update:

    I am almost at the 1 month mark, and I still can’t get passed this problem. I’ve used 1.5.1 and 1.6, used RCA and HDMI, used every emulator, tried using Keyboard vs Controller, and anything else I can think of.

    I simply do not understand how people get this to work so easily. I am doing the absolute bare bones necessary to get the image on the card and loading a ROM.

    All of the hardware I’m using has been confirmed to always work on the Raspberry Pi Wiki (SD Card, controller, etc).

    Does anyone have any new answers? The people that get this to work so easily must be doing something that I’m overlooking. I’m at the point where I feel like I’ve wasted $75 on this project, and that’s frustrating. :(

    Post count: 2

    A couple of things that might help folks.

    1. I had to change my memory split to 192 to get NES to work.

    2. If you are copying the file over from windows avoid editing the file in notepad and either retrieve the file from the pi or just copy it over to the pi unedited.

    3. Make sure the script is executable after copying it over. sudo chmod 755 <filename>

    Post count: 39


    My guess would be that the ROM you are trying to start is bad or at least not loading correctly. Have you tried a variety of ROMs? I have some in my list that do not load, but most load fine.

    Post count: 3

    I’m having the same issues as above.

    This is a fresh install and everything worked just fine. All my ROMS launched and worked as they were expecting. However I followed the steps to “pretty” up emulation station by scraping for box art etc as outlined in the A-Z guide that is available on the internet. I let that run overnight as it took it a long time to scrape through all the ROMS.

    When i came back everything looked great but all of a sudden the ROMs wouldnt launch. Everything else works great. The USB SNES controller I have used to work in the ROMs, it works in the menus, etc.

    I’m capable of reading error logs and general troubleshooting in linux and with scripts and other components of emulationstation / retropie however i’m honestly stumped as to where to even start the investigation … i’m not seeing log files in /var/log that look relevant .. i’ve searched a few directories but i’m not sure where to start looking for error messages as to why the ROM’s and or Emulators are not launching.
    When i select a ROM the screen fades away as I would expect prior to launching the ROM but then you see some terminal activity in the background and then it dumps you back to emulation station.

    any help to get me started troubleshooting would be great.

    Post count: 480

    hi, could you post the contents of your es_systems.cfg located in /.emulationstation/

    also are you using the latest RetroPie 1.9.1 image or installed via the setup script?

    Post count: 3

    I first downloaded the “all in one” image a month or so ago … i did however use the or whatever it was to update the bianaries, firmware, etc. I assume i’ll be current… that was just updated this morning.

    Here is the config file.

    pi@RetroPie ~/.emulationstation $ cat es_systems.cfg
    #DESCNAME=Apple ][
    #DESCNAME=Atari 800
    #EXTENSION=.xex .XEX
    #COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/atari800-3.0.0/installdir/bin/atari800 %ROM%"
    #DESCNAME=Atari 2600
    #EXTENSION=.a26 .A26 .bin .BIN .rom .ROM .zip .ZIP .gz .GZ
    ##alternatively: COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "stella %ROM%"
    #COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/stella-libretro/ --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/atari2600/retroarch.cfg  %ROM%"
    #DESCNAME=Atari ST/STE/Falcon
    #PATH=/home/pi/RetroPie/roms/atariStSteFalcon .ST .img .IMG .rom .ROM
    #COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "hatari %ROM%"
    #DESCNAME=Basilisk II
    #COMMAND=sudo modprobe snd_pcm_oss && xinit /home/pi/RetroPie/emulators/basiliskii/installdir/bin/BasiliskII
    # Or possibly just COMMAND=xinit /home/pi/RetroPie/emulators/basiliskii/installdir/bin/BasiliskII
    #DESCNAME=Cave Story
    #COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/nxengine-libretro/ --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/cavestory/retroarch.cfg /home/pi/RetroPie/emulatorcores/nxengine-libretro/datafiles/Doukutsu.exe"
    #EXTENSION=.crt .CRT .d64 .D64 .g64 .G64 .t64 .T64 .tap .TAP .x64 .X64 .zip .ZIP
    #COMMAND=/home/pi/RetroPie/emulators/vice-2.3.dfsg/installdir/bin/x64 %ROM%
    #EXTENSION=.WAD .wad
    #COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/libretro-prboom/ --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/doom/retroarch.cfg %ROM%"
    #DESCNAME=Duke Nukem 3D
    #EXTENSION=.grp .GRP
    #COMMAND=eduke32 -g %ROM% -gamegrp %ROM%
    DESCNAME=Game Boy
    PATH=/home/pi/RetroPie/roms/gb .GB
    COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/gambatte-libretro/libgambatte/ --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/gb/retroarch.cfg %ROM%"
    DESCNAME=Game Boy Advance
    COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/gpsp/raspberrypi/gpsp %ROM%"
    DESCNAME=Game Boy Color
    COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/gambatte-libretro/libgambatte/ --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/gbc/retroarch.cfg %ROM%"
    DESCNAME=Sega Game Gear
    PATH=/home/pi/RetroPie/roms/gamegear .GG
    COMMAND=/home/pi/RetroPie/emulators/osmose-0.8.1+rpi20121122/osmose %ROM% -joy -tv -fs
    #PATH=/home/pi/RetroPie/roms/intellivision .INT .bin .BIN
    #COMMAND=/home/pi/RetroPie/emulators/jzintv-1.0-beta4/bin/jzintv -z1 -f1 -q %ROM%
    PATH=/home/pi/RetroPie/roms/mame .ZIP
    COMMAND=/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/imame4all-libretro/ --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/mame/retroarch.cfg %ROM%
    # alternatively: COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/pifba/fba2x %ROM%"
    #DESCNAME=FinalBurn Alpha
    #PATH=/home/pi/RetroPie/roms/fba .ZIP
    COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/fba-libretro/ --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/fba/retroarch.cfg  %ROM%"
    # alternatively: COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/pifba/fba2x %ROM%"
    #DESCNAME=PC (x86)
    #EXTENSION=.exe .EXE
    DESCNAME=Sega Master System II
    COMMAND=/home/pi/RetroPie/emulators/osmose-0.8.1+rpi20121122/osmose %ROM% -joy -tv -fs
    DESCNAME=Sega Mega Drive / Genesis
    EXTENSION=.smd .SMD .bin .BIN
    COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/picodrive/ --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/megadrive/retroarch.cfg  %ROM%"
    # alternatively: COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/dgen-sdl/dgen -f -r /home/pi/RetroPie/configs/all/dgenrc %ROM%"
    # alternatively: COMMAND=export LD_LIBRARY_PATH="/home/pi/RetroPie/supplementary/dispmanx/SDL12-kms-dispmanx/build/.libs"; /home/pi/RetroPie/emulators/dgen-sdl/dgen %ROM%
    #PATH=/home/pi/RetroPie/roms/neogeo .ZIP
    #COMMAND=/home/pi/RetroPie/emulators/gngeo-pi-0.85/installdir/bin/arm-linux-gngeo -i /home/pi/RetroPie/roms/neogeo -B /home/pi/RetroPie/emulators/gngeo-pi-0.85/neogeobios %ROM%
    ## alternatively: COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/pifba/fba2x %ROM%"
    DESCNAME=Nintendo Entertainment System
    COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/fceu-next/fceumm-code/ --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/nes/retroarch.cfg  %ROM%"
    #DESCNAME=Nintendo 64
    #EXTENSION=.z64 .Z64 .n64 .N64
    #COMMAND=cd /home/pi/RetroPie/emulators/mupen64plus-rpi/test/ && ./mupen64plus %ROM%
    #DESCNAME=PC Engine/TurboGrafx 16
    #COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/mednafen-pce-libretro/ --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/pcengine/retroarch.cfg %ROM%"
    #DESCNAME=Sony Playstation 1
    #EXTENSION=.img .IMG .7z .7Z .pbp .PBP .bin .BIN
    #COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/pcsx_rearmed/ --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/psx/retroarch.cfg %ROM%"
    #DESCNAME=Playstation Portable
    #EXTENSION=.iso .ISO .cso .CSO
    #COMMAND=/home/pi/RetroPie/emulators/ppsspp/PPSSPPSDL %ROM% en
    DESCNAME=Super Nintendo
    EXTENSION=.smc .sfc .fig .swc .SMC .SFC .FIG .SWC
    COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 1 "/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/pocketsnes-libretro/ --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/snes/retroarch.cfg  %ROM%"
    # alternatively: COMMAND=/home/pi/RetroPie/emulators/snes9x-rpi/snes9x %ROM%
    # alternatively: COMMAND=/home/pi/RetroPie/emulators/pisnes/snes9x %ROM%
    #DESCNAME=ZX Spectrum
    #EXTENSION=.z80 .Z80
    #COMMAND=xinit fuse
    ## alternatively: COMMAND=/home/pi/RetroPie/emulators/fbzx-2.10.0/fbzx %ROM%
    #DESCNAME=Input Configuration
    #PATH=/home/pi/RetroPie/roms/esconfig .SH

    I’ve commented out several emulators and whatnot as you can tell.

    Post count: 3

    as an update .. i went into the setup script and ran the option to regenerate all the configs and now everything works again. Not sure what the es-scraper script does but there is a flaw in it somewhere i guess or i did something wrong?

Viewing 22 posts - 1 through 22 (of 22 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.