Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • krazedj
    Participant
    Post count: 5

    Hey guys,

    I am a n00b. I got it up and running and edited retroarch.cfh, and sftp it to the raspberry pi. It shows up a normal file size until I reboot the pi. After reboot, it shows up as 0kb and blank. I have to upload it over 10 times for it to finally stay.
    If I have to make a change… it almost never takes.
    Any ideas on how to fix this?

    RetroMarine
    Participant
    Post count: 153

    Try making a separate copy of retroarch.cfg and saving it on your desktop, then drag it into the folder via SFTP and overwrite. That always works for me.

    krazedj
    Participant
    Post count: 5

    Same issue. It overrides the file and works until I reboot the device, then it has a blank file instead of the one I copied over.

    RetroMarine
    Participant
    Post count: 153

    You got me, I guess just try and rewrite the image or try another sd card!

    krazedj
    Participant
    Post count: 5

    so, I reformated the card and started over.
    Same issue. I tried another SD Card… same issue.
    Issue only occurs if I manually make any changes to the retroarch.cfg file (any of them). It happens if I over-write the file with another, or just edit the existing file. If I run the controller config screen, it works fine even after reboot. The only adjustment I really want to make is to exit out of the game using the Select + Start button.
    It won’t let me… erases the whole file (blank) after reboot. I can use the emulators for now, but I always have to have a keyboard connected in order to exit out of the game.

    Any help would be much appreciated.

    timsmule
    Participant
    Post count: 2

    Same exact thing happens to me.

    Don’t understand it. It really, really sucks not being able to exit the game.

    Could anyone reading this please let me know if there’s something strnage about my retroArch.cfg? it contains :

    input_player1_joypad_index = 0
    input_player1_b_btn = 2
    input_player1_a_btn = 1
    input_player1_y_btn = 3
    input_player1_x_btn = 0
    input_player1_l_btn = 4
    input_player1_r_btn = 5
    input_player1_start_btn = 9
    input_player1_select_btn = 8
    input_player1_l_y_plus = -1
    input_player1_up_axis = -1
    input_player1_l_y_minus = +1
    input_player1_down_axis = +1
    input_player1_l_x_minus = -0
    input_player1_left_axis = -0
    input_player1_l_x_plus = +0
    input_player1_right_axis = +0
    input_player2_joypad_index = 1
    input_player2_b_btn = 2
    input_player2_a_btn = 1
    input_player2_y_btn = 3
    input_player2_x_btn = 0
    input_player2_l_btn = 4
    input_player2_r_btn = 5
    input_player2_start_btn = 9
    input_player2_select_btn = 8
    input_player2_l_y_plus = -1
    input_player2_up_axis = -1
    input_player2_l_y_minus = +1
    input_player2_down_axis = +1
    input_player2_l_x_minus = -0
    input_player2_left_axis = -0

    If I add the two lines for exiting the emulator :

    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”

    Anywhere in the code, I get the issue.

    Thanks

    trimmtrabb
    Participant
    Post count: 480

    Not sure what’s going here but if you place your modified retroarch.cfg in the emulator directory it will override the default retroarch.cfg

    So for megadrive you would place the retroarch.cfg in /home/pi/RetroPie/configs/megadrive/

    Hope this helps

    timsmule
    Participant
    Post count: 2

    Hey! Good news! I got it to work.

    Previously I was modifying the retroArch.cfg through cyberduck and using notepad.

    Instead I followed a guide found at :

    Which shows how to modify the file inside the raspberry pi using their text editor.

    Everything works now. Issue gone and can exit with controller.

    Give that a go mate.

    trimmtrabb
    Participant
    Post count: 480

    glad you got it working

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.