Forum Replies Created

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • roverius
    Participant
    Post count: 9

    @xflesk

    Try to use AOMEI Partition tools to format the disk before use in the PI
    http://www.disk-partition.com/free-partition-manager.html

    Its a free tool and you can format the USB drive into Ext3.

    roverius
    Participant
    Post count: 9

    Update:

    1: I have made my USB Harddisk into ext4 filesystem.
    2: i checked whit: sudo fdisk -l what drive i had (i this case it was sda5)
    3: i did a mount sudo mount /dec/sda5 /mnt/sda
    4: I created a folder “retropie” inside the /mnt/sda
    midnight commander is a good tool to browse and/or edit files (sudo mc)
    5: i reboot the pie and let the drive populate the rom foldes
    6: in fstab i made a line to mount the drive
    7: changed the permissions on the retropie folder (sudo chmod -R 777 retropie)
    8: opened Filezilla and copied some roms to the drive (example: to /mnt/sda/retropie/roms/atari2600)
    9: changed the path inside etc/es_systems.cfg into:
    <path>/mnt/sda/retropie/atari2600</path>

    all seems to be working fine now and nothing copies to the SDCard.

    game started good and i was able to play
    Still need some control configuring to exit the game back into menu.

    Thanks for some helpfull advice and i hope some others can use this information also to play roms from a USB harddrive.

    roverius
    Participant
    Post count: 9

    mine is set to fat32, but i will change to ext4 (or ext3) and see what hapens.

    I keep you informed of the progress.

    Thanks for the helpfull information so far.

    roverius
    Participant
    Post count: 9

    OK,

    now i am getting somewhere:

    I added a line in fstab to mount my drive like
    mount /dev/sda1 /mnt/sda

    i see the roms now and they do not copy anymore to my SD card.
    BUT: they don’t start up, probably due to permissions on that mount point.
    so, i have changed the permissions (chmod – R 777 on the romsfolder)
    trying to transfer files over FTP does not work (it does copy to the SD card folder)

    roverius
    Participant
    Post count: 9

    my files are located for example atari2600 in:
    R:\retropie\roms\atari2600\ (windows point of view)

    the path location is set to:
    <path>/dev/sda/retropie/roms/atari2600</path>

    still the files are copied.

    folder names do not have capital letters.

    roverius
    Participant
    Post count: 9

    Ok,

    I checked the drive list and i assume the HD is on sda1

    Weird thing is, if i point to a wrong path, why does it still copy the files to SD?
    Shouldn’t there be some error because of the path not correct in the es_config file?

    roverius
    Participant
    Post count: 9

    i see youre foldername says “Retropen”, so i guess u use a USB Thumbdrive

    I use a USB HARDDRIVE (500G disk).
    Could it be possible that the path to the disk is not /media/usb, but somthing like /dev/hda or sda or anything like this.

    The USB harddrive did populate the romsfolders, but when i enter ls -l /media/usb* i dont see any folders (* = usb0 to usb7)

    the harddrive is recognized by the system, but i cant find where it is mounted.

    roverius
    Participant
    Post count: 9

    Thanks for reply,

    Did not work, files are still copied to internal SD drive

    see attachment file for settings.

    roverius
    Participant
    Post count: 9

    Hi,

    i have edited the es_systems.cfg file and changed the path line to point to the USB drive.

    I copied some files to the roms folder, but somehow, the roms are still copied to the SD drive.

    example:
    <path>/media/usb0/retropie/emulatorname</path>

    How can i prevent the copying to the SD drive

    Regards,
    Roverius

Viewing 9 posts - 1 through 9 (of 9 total)