Viewing 22 posts - 36 through 57 (of 57 total)
  • Author
    Posts
  • haris1977
    Participant
    Post count: 101

    1) How do i burn the retropie image to my HDD/USB? Through Win32 Disk imager?

    2) Is there any sd-card corruption prevention with this method? Thus meaning we can overclock the pi?

    3) Where do we “add” games? In sd card or in usb?

    Thanks

    smartroad
    Participant
    Post count: 76

    Tried this but the system load times are awful. About 42 seconds to load on SD, well over a minute and a half on my USB stick. And the sticks read speed is twice that of the SD on my PC :(

    roverius
    Participant
    Post count: 9

    Hi,

    i have edited the es_systems.cfg file and changed the path line to point to the USB drive.

    I copied some files to the roms folder, but somehow, the roms are still copied to the SD drive.

    example:
    <path>/media/usb0/retropie/emulatorname</path>

    How can i prevent the copying to the SD drive

    Regards,
    Roverius

    polluxpt
    Participant
    Post count: 28

    Change /media/usb0/ to /media/usb/
    Your problem is that zero.

    cheers!

    roverius
    Participant
    Post count: 9

    Thanks for reply,

    Did not work, files are still copied to internal SD drive

    see attachment file for settings.

    polluxpt
    Participant
    Post count: 28

    Seems like a path mismatch problem.

    What is your full path to roms?

    I give you my example:

    <path>/media/usb/Retropen/retropie/amiga</path>

    I got my Amiga roms in this:

    MEDIA -> USB -> Retropen (folder in root) -> retropie (emulator roms folder) -> amiga (roms folder)

    I guess something is missing between USB and RETROPIE

    If you browse your system you can check if your paths are correct.

    roverius
    Participant
    Post count: 9

    i see youre foldername says “Retropen”, so i guess u use a USB Thumbdrive

    I use a USB HARDDRIVE (500G disk).
    Could it be possible that the path to the disk is not /media/usb, but somthing like /dev/hda or sda or anything like this.

    The USB harddrive did populate the romsfolders, but when i enter ls -l /media/usb* i dont see any folders (* = usb0 to usb7)

    the harddrive is recognized by the system, but i cant find where it is mounted.

    polluxpt
    Participant
    Post count: 28

    That is your problem.

    Try to get your roms destination under DEV or so.
    Once you get your folders your are able to set your path.
    I’m using a 64GB usb drive.

    Type this command to list your drives:

    sudo fdisk -l

    roverius
    Participant
    Post count: 9

    Ok,

    I checked the drive list and i assume the HD is on sda1

    Weird thing is, if i point to a wrong path, why does it still copy the files to SD?
    Shouldn’t there be some error because of the path not correct in the es_config file?

    polluxpt
    Participant
    Post count: 28

    Default is to SD. If wrong path is set it uses default one.

    Try
    <path>/dev/sda/retropie/*</path>

    * emulator folders

    and give us your feeedback if everything ok.

    roverius
    Participant
    Post count: 9

    my files are located for example atari2600 in:
    R:\retropie\roms\atari2600\ (windows point of view)

    the path location is set to:
    <path>/dev/sda/retropie/roms/atari2600</path>

    still the files are copied.

    folder names do not have capital letters.

    polluxpt
    Participant
    Post count: 28

    You have to set your Windows point of view into Linux.

    Try to browse into your drive like DOS.
    When you get your roms folder you get your path.

    roverius
    Participant
    Post count: 9

    OK,

    now i am getting somewhere:

    I added a line in fstab to mount my drive like
    mount /dev/sda1 /mnt/sda

    i see the roms now and they do not copy anymore to my SD card.
    BUT: they don’t start up, probably due to permissions on that mount point.
    so, i have changed the permissions (chmod – R 777 on the romsfolder)
    trying to transfer files over FTP does not work (it does copy to the SD card folder)

    polluxpt
    Participant
    Post count: 28

    I had issues with filesystem in my usb drive.
    Once I changed to ext4 I got it fixed.
    What about yours?

    roverius
    Participant
    Post count: 9

    mine is set to fat32, but i will change to ext4 (or ext3) and see what hapens.

    I keep you informed of the progress.

    Thanks for the helpfull information so far.

    roverius
    Participant
    Post count: 9

    Update:

    1: I have made my USB Harddisk into ext4 filesystem.
    2: i checked whit: sudo fdisk -l what drive i had (i this case it was sda5)
    3: i did a mount sudo mount /dec/sda5 /mnt/sda
    4: I created a folder “retropie” inside the /mnt/sda
    midnight commander is a good tool to browse and/or edit files (sudo mc)
    5: i reboot the pie and let the drive populate the rom foldes
    6: in fstab i made a line to mount the drive
    7: changed the permissions on the retropie folder (sudo chmod -R 777 retropie)
    8: opened Filezilla and copied some roms to the drive (example: to /mnt/sda/retropie/roms/atari2600)
    9: changed the path inside etc/es_systems.cfg into:
    <path>/mnt/sda/retropie/atari2600</path>

    all seems to be working fine now and nothing copies to the SDCard.

    game started good and i was able to play
    Still need some control configuring to exit the game back into menu.

    Thanks for some helpfull advice and i hope some others can use this information also to play roms from a USB harddrive.

    polluxpt
    Participant
    Post count: 28

    Glad you make it and thank you for sharing this info!

    For controls I suggest fba topics as they are pretty useful.

    Just one final note:
    some problems solved by ext4 were related to save states in my case.

    Cheers!

    Localhorst86
    Participant
    Post count: 4

    I just set retropie up as well, I am using a regular 8Gb SD Card to boot the system. Obviously, that is way too little to store all the systems I want, so I decided to use a spare 32Gb Pendrive i had lying around.

    I found the most simple way to do this would be to simply let the folder “roms” point to my usb stick instead using a soft link. This has the advantage of the default es_systems.cfg being left untouched, when you update retropie using the setup script it’ll revert to the default cfg file, forcing you to manually edit your cfg again. but by soft linking /media/usb to ~/RetroPie/roms, the roms are now in the correct place for RetroPie to find them.

    For me, I simply formated the pen drive to use the ext4 filesystem (Retropie would not load roms from the drive if it was formated as FAT32) using the command ‘sudo mkfs.ext4 /dev/sda’ and correcting the permisions afterwards (sudo chmod -R 777 /media/usb). I then moved the folder ~/RetroPie/roms to /media/usb (sudo mv ~/RetroPie/roms /media/usb) and created a soft link to the correct place (sudo ln -s /media/usb/roms ~/RetroPie) and tested a few games. Everything works just fine.

    polluxpt
    Participant
    Post count: 28

    Thanks for sharing this method.
    This link way will help a lot of people since it’s easier to do.

    kimberly2000
    Participant
    Post count: 8

    Need update under 3.6

    3.1 allowed for this to work: http://www.petrockblock.com/wp-content/uploads/2015/07/Getting-strated-with-Retropie.pdf

    However it isn’t working under 3.6

    Have all my roms on USB HDD, just want to be able to play them again, from the HDD.

    xflesk
    Participant
    Post count: 1

    hello, i have used the method mentioned by localhorst86 and i simply can not format my usb stick via raspberry pi. it said that the usb device is in use and cannot be completed. any help ?
    regards

    ps
    im using raspberry pi 3 model b, retropie 3.6

    roverius
    Participant
    Post count: 9

    @xflesk

    Try to use AOMEI Partition tools to format the disk before use in the PI
    http://www.disk-partition.com/free-partition-manager.html

    Its a free tool and you can format the USB drive into Ext3.

Viewing 22 posts - 36 through 57 (of 57 total)
  • You must be logged in to reply to this topic.