Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • monkeyangst
    Participant
    Post count: 9

    Hi everyone! I’m a newcomer to RetroPie and the Raspberry Pi in general — just got mine last week, and have managed to get some of my favorite games up and running with two controllers — a USB SNES-knockoff controller and a Saitek which I got at Goodwill. I’ve gotten both working in most places — NES, SNES and MAME — but on the first PlayStation game I tried (Bushido Blade) could not get the second controller recognized.

    I’m a bit confused — the PlayStation emulator is RetroArch, right? Same one as NES and SNES? Controller setup should be the same, am I wrong?

    Oh, also: I haven’t figured out the whole BIOS thing yet for PS games. The game plays fine, but complains that there’s no BIOS when booted. Perhaps that’s part of the issue? If anyone could point me in the right direction towards making sense of BIOS, that would probably help a great deal. Thanks!

    EDIT: As a testament to my noobness, I had thought “PSX” was shorthand for Playstation, but have learned that it is a separate product that I’d never heard of. Doh.

    trimmtrabb
    Participant
    Post count: 480

    So both pads work in MAME/NES/SNES?

    monkeyangst
    Participant
    Post count: 9

    Yeah, mostly, although now that I think about it, there is at least one game in SNES — Super Mario World — that the second controller doesn’t seem to be recognized in. When playing 2-player mode, we have to pass the first controller back and forth.

    trimmtrabb
    Participant
    Post count: 480

    Can you post the contents of your retroarch.cfg?

    monkeyangst
    Participant
    Post count: 9

    Sure. The following is the contents of /opt/retropie/configs/all/retroarch.cfg:

    system_directory = /home/pi/RetroPie/BIOS
    config_save_on_exit = false
    video_aspect_ratio = 1.33
    video_smooth = false
    video_threaded = true
    input_enable_hotkey = escape
    input_exit_emulator = escape
    rewind_enable = false
    rewind_buffer_size = 10
    rewind_granularity = 2
    input_rewind = r
    video_gpu_screenshot = true
    input_shader_next = m
    input_shader_prev = n
    video_shader_dir = /opt/retropie/emulators/RetroArch/shader/
    
    input_enable_hotkey_btn = "8"
    input_exit_emulator_btn = "9"
    input_player1_joypad_index = "0"
    input_player1_b_btn = "2"
    input_player1_y_btn = "3"
    input_player1_select_btn = "8"
    input_player1_start_btn = "9"
    input_player1_up_axis = "-1"
    input_player1_down_axis = "+1"
    input_player1_left_axis = "-0"
    input_player1_right_axis = "+0"
    input_player1_a_btn = "1"
    input_player1_x_btn = "0"
    input_player1_l_btn = "4"
    input_player1_r_btn = "5"
    
    input_player2_joypad_index = "1"
    input_player2_b_btn = "1"
    input_player2_y_btn = "4"
    input_player2_select_btn = "5"
    input_player2_start_btn = "2"
    input_player2_up_axis = "-1"
    input_player2_down_axis = "+1"
    input_player2_left_axis = "-0"
    input_player2_right_axis = "+0"
    input_player2_a_btn = "0"
    input_player2_x_btn = "3"
    input_player2_l_btn = "6"
    input_player2_r_btn = "7"
    
    trimmtrabb
    Participant
    Post count: 480

    Hmm, so all p1 controls work in the Playstation emulator? Double check all p2 buttons are functioning:

    jstest /dev/input/js1

    I haven’t played any 2 player Playstation games but check there isn’t an option to enable 2 player in the Retroarch GUI, add this to retroarch.cfg:

    input_menu_toggle =

    (enabled via hotkey)

    monkeyangst
    Participant
    Post count: 9

    [quote=18791]Hmm, so all p1 controls work in the Playstation emulator? Double check all p2 buttons are functioning:

    jstest /dev/input/js1

    I haven’t played any 2 player Playstation games but check there isn’t an option to enable 2 player in the Retroarch GUI, add this to retroarch.cfg:

    input_menu_toggle =

    (enabled via hotkey)
    [/quote]

    Thanks! I have checked it out in jstest, and it comes up fine. I’m interested in the second thing you said, though, can you expand on it a bit?

    trimmtrabb
    Participant
    Post count: 480

    If you bring up the Retroarch GUI have a look through the menus for an option to enable 2 player, can’t remember what’s in the GUI menu off the top of my head but you may find something in there. Also try adding this to player 2 controls:

    input_player2_up_btn = “h0up”
    input_player2_down_btn = “h0down”
    input_player2_left_btn = “h0left”
    input_player2_right_btn = “h0right”

    I’m guessing p2 is the Saitek pad?
    Are there any other 2 player games you can try to rule out the rom being the issue?

    monkeyangst
    Participant
    Post count: 9

    OK. The Retroarch GUI I haven’t seen. Do I get it by pressing TAB on the keyboard, like in MAME?

    And I will try a different two-player game tonight, to see if it might indeed be the ROM.

    trimmtrabb
    Participant
    Post count: 480

    To access the GUI you need to add this to retroarch.cfg:

    input_menu_toggle = *

    Where * is the button you wish to use. Then it is accessed by holding down the hotkey like the other buttons etc

    monkeyangst
    Participant
    Post count: 9

    Well, I just don’t know. Now it’s working. Tried a second game, Marvel vs. Capcom, and the second controller worked fine. Went back to Bushido Blade, and it worked there as well. No idea what, if anything, I did differently.

    Thanks for all the responses. I will go ahead and add those lines to retroarch.cfg anyway, then poke around the menus.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.