Homepage Forums RetroPie Project New to RetroPie? Start Here! Scraper Not Working


Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #115379

    Hi all;

    New to Retropie and I have a problem. This all started when I upgraded to the newest version. I had everything sraped by Sselph’s Scraper. When I upgraded I ended up with a white screen of death so I formatted the card, copied the image to the card and added all of my roms again. Once it was all up and running I decided to use the scraper again and that is where my problems began.

    I ran the script; making sure that Emulation Station was shut down and when I rebooted Retropie none of the images or metadata was there. I have tried a few times and Ssephs scraper runs but none of it shows up.

    I don’t know if this will help but I was able to scrape a few of the games from the one in Emulation Station but the Times Played and Last Played register while Emulation Station/Retropie is running but it is all gone when I reboot.

    Pi Model: 2
    RetroPie Version Used: 3.3.1
    Built From: SD Image
    USB Devices connected: Wifi Dongle, Wireless keyboard
    Controller used:Wired X-Box controller
    Guide used: https://github.com/sselph/scraper
    File: (File with issue (with FULL path))
    Attachment of config files: (or use pastebin.com)
    How to replicate the problem: Run the scraper…runs through and no photos/metadata is saved


    As the scraper was scanning your roms did you happen to notice if the text on the screen was displaying errors? Tonight was the first time I ran sselphs’s scraper since upgrading to 3.4 and I noticed it returned an error for each and every game stating that the hash was not found. This occurred even with games that I have never had a problem scraping before. I wonder if we might be having a similar issue?


    The first several times it was not returning errors. Today it was returning errors (Hash not found) but that is because http://thegamesdb.net/ is not up.


    I was trying to scrap some games yesterday and got same error reported here.

    Right now the problem still the same.

    More than 24 hours downtime is strange.

    Maybe they change their code, so the scraper script will need an update?


    Thegamesdb is down. Scrapers won’t work until its back up.


    Herbfargus The problem is the scraper script ran when thegamesdb was up would not save any of the data. I was not getting the “no hash found” error. It ran just fine and then when I restarted EmulationStation there has been no images or metadata saved for any of the games.


    I just ran Sselph scraper now that gamesdb is back up. All of the game info that was scraped is not showing up in ES. I made sure to killall ES before I ran the scraper. The scraper worked fine before I upgraded to 3.4. Has anyone else been having this issue?


    Same here with Sselph’s scraper. The scraper within ES is working though, and is way faster than is used to be.


    Ill have to check that out. Only problem with the built in scraper is that I have to babysit it otherwise it will mislabel things.


    For the main systems it works pretty well. Where you start running into problems is on the older systems, and especially ones that aren’t officially supported by the scraper.

    If you are willing to babysit it though, you can actually scrape some of the older and lesser known systems. I wouldn’t recommend it for more than around 100 games, since picking the art manually is a real pain. I have managed to scrape a decent amount of art that way for TRS-80 though.

    I’m probably crazy for doing this, but for a handful of systems, I’ve manually created the gamelists and added the art; virtual boy, C-128, commodore PET, a prboom section I added, and retropie config scripts. ;P Any scraper is better than that. lol

Viewing 10 posts - 1 through 10 (of 10 total)
  • The forum ‘New to RetroPie? Start Here!’ is closed to new topics and replies.