Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • whoistk
    Post count: 1

    Hello all

    I am trying to build a NES emulator out of a Raspberry Pi Model B that I have had since 2012. I downloaded the RetroPie

    image from the Download Page (retropie-v2.6.0-rpi1.img.gz). So far this is what I have done.

    1. Wrote RetroPie image to SD
    2. Expanded the File System
    3. Update the Raspberry Pi by running the following commands
    – Sudo rpi-update
    – Sudo apt-get update && sudo apt-get upgrade -y
    – Run Raspberry Pi Scripts
    • CD RetroPie-Setup
    • Sudo ./
    • “Update RetroPie Setup script”
    4. Used FileZilla to copy my NES ROMS to /home/pi/RetroPie/roms/NES

    The problem I am having is that when I try to start up the ROMS on the Raspberry Pi I get the error below for about 5

    seconds then it goes back to my list of ROMS.

    Press ‘x’ or ‘m’ to configure launch options for emulator/port (neslibertro)
    Powering on HDMI with explicit settings (Cea mode 4)
    Frontend supports RGB565 – will use that instead of XRGB1555.
    RetroArch [WARN] :: load_content :: Tried extracting to extraction directory, but extraction directory was not set or found. Setting extraction directory derived by basename…
    RetroArch [ERROR] :: load_content :: Failed to load content
    Powering on HDMI with preferred settings

    Does anyone know what I can do to fix this? I have already tried to flash the SD card again however I still get the same error. I also tried just flashing the SD card with the RetroPie image then copying 1 NES ROM onto the SD card without running any updates and I still get the same error. I have tested the ROMS on an emulator on my computer and they all work fine.

    I am thinking that maybe the version of the image I downloaded might not be compatible with my older Raspberry Pi.

    Any help is greatly appreciated.


    Post count: 526

    The only thing I can think of is a permissions issue. What are the permissions set to on the rom itself? can the PI user read and execute it?

    Post count: 61

    Are you using zip archives? I don’t know if every retroarch core supports playing zipped roms.

    If that doesn’t help you could tell us which core you are using. You can find that out by pressing x or m before the emulator starts.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.