Homepage Forums RetroPie Project New to RetroPie? Start Here! RetroPie USB Audio causing Mame to fail

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #113632

    Hi all,
    I’m having an issue where if I setup my USB audio card correctly then I get sound effects in the emulation station front end, I get audio from other emulators like Doom, but all my MAME roms fail to load. They all give the following error:

    lvl0: VolumeControl::init() – Failed to find mixer elements!

    I believe this error is definitely related, because if I change my audio card in /etc/asound.conf to use internal (and this causes the device names visible through “amixer” to change) then all the same exact MAME roms load perfectly (but of course have no sound). In this case also the emulation station front end audio gets lost.

    I’ve also seen others with I think the same problem on the raspberry pi forum. I’ve replied there below.



    I have the same issue. Sound works in games etc. because I have configured the defaults to point to my USB hardware, but volume level changes fail and related errors persist. I think it’s because of calls to the simple channel element “PCM” which is no longer available when I enable my USB audio as the default. In my case, it’s a C-Media adapter that responds to the channel element named “Headphone”.

    One promising I idea I was trying was to setup an ALSA plugin that makes my USB hardware mirror everything sent to the built-in audio. This requires undoing the USB default settings so the built-in audio becomes the default again and the “PCM” named element is available. That eliminated the errors, but not every emulator had audio. If we could make this audio syncing work with some ALSA expertise, that would solve the issue for everyone, regardless of their USB card’s channel element names. It’s beyond my knowledge of ALSA setup–the trial and error takes so long because I don’t know what exactly I am doing!


    New to this site, just registered hoping to find an answer as I’m having the same issue.

    Browsed various sites/forums online and can’t seem to find a solution, any help would be appreciated. New to working with Raspberry, love the device and possibilities but Raspberry’s audio out quality is not good.

    Raspberry Pi 2 Model B
    RetroPie/Emulation Station
    USB Adapter: Syba SD-CM-UAUD USB Stereo Audio Adapter, C-Media Chipset, RoHS



    I just popped in to say good luck. Sorting out audio issues has been the bane of my linux experience. It’s not an easy nut to crack.

    I’ve been messing around with adding background music to ES. I have to do some funky workaround with MAME. I’m not exactly sure why, so all I can really do here is confirm that MAME is in fact handling audio differently than most of the other emulators.

    I do believe that caver01 is on the right track though. The secret sauce is in fixing the Alsa issues. Maybe remove Alsa completely, if possible, and try to set it up fresh?

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘New to RetroPie? Start Here!’ is closed to new topics and replies.