Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • lama
    Post count: 1

    Hey guys I managed to get my 360 wireless controller going with this guide this guide and everything was working perfect, I managed to play the first level of Super Mario Bros but then found the blinking light in the middle of controller to annoying so I looked around for a way to get it to stop blinking. This is what I did, blacklist xpad and repeat the steps in the first guide. Now however a strange thing is happening when I tried to configure the controller with ./retroarch-joyconfig -o /opt/retropie/configs/all/p1.cfg -p 1 -j 0. The button I press are not the buttons the Pi thinks I pressed, for example the select/start buttons are supposed to be 12 and 13 but the PI insists I press 8 and 9. When I run jstest /dev/input/js0 it shows the correct buttons being pressed but not during ./retroarch-joyconfig . I tried to manually remove the wrong mapping in retroarch.cfg and replace it with a button configuration found in Advanced Configuration at wiki but it did nothing. The weird configuration is still in effect even though I deleted It from retroarch.cfg
    Advanced Configuration I got from wiki:
    i`nput_player1_joypad_index = 0
    input_player1_b_btn = 6
    input_player1_a_btn = 4
    input_player1_y_btn = 7
    input_player1_x_btn = 5
    input_player1_l_btn = 10
    input_player1_r_btn = 11
    input_player1_start_btn = 13
    input_player1_select_btn = 12
    input_player1_up_btn = 0
    input_player1_down_btn = 1
    input_player1_left_btn = 2
    input_player1_right_btn = 3
    input_exit_emulator_btn = 15
    input_menu_toggle_btn = 16`

    Post count: 2

    I am a newbie, but have you check snes9x.cfg in pisnes folder ?
    Settings in this cfg overrun retroarch .cfg.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.