Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • dudleydes
    Participant
    Post count: 139

    Hi

    I successfully configured a PS3 controller to work over wired USB for the SNES, NES, Megadrive (RetroArch) and MAME (mame4all-pi) emulators.

    I bought the Bluetooth dongle from ModMyPi (https://www.modmypi.com/nano-bluethooth-dongle) and followed dhoium3009’s guide in setting up the PS3 controller via Bluetooth.

    MAME works fine but the PS3 controller behaves differently in RetroArch wired and over Bluetooth even though I have not altered any config files. Over Bluetooth, the following occurs:

    • the X button now resets the game.
    • the circle button now acts the action/enter button which should be the X button.
    • the triangle button now brings up the RetroArch RGUI.
    • Left and right on the D-pad changes the state slot though they still move left and right as they should.

    Any help would be appreciated.

    gizmo98
    Participant
    Post count: 452

    The newest Retropie-Setup-Script contains auto config files for PS3 controllers. The described behavior should only occur if the hotkey button “select” is pressed. If no hotkey button is defined the described problem occurs.

    Please check if /RetroPie/configs/all/retroarch.cfg has the setting
    input_enable_hotkey_btn = “0”

    PS3 retroarch controller settings:
    https://github.com/retropie/RetroPie-Setup/blob/master/supplementary/RetroArchConfigs/PS3ControllerUSB.cfg

    dudleydes
    Participant
    Post count: 139

    Hi

    The setting input_enable_hotkey_btn was indeed missing from my retroarch.cfg file. I’ve added it and everything is working as intended. Many thanks.

    tomhyde
    Participant
    Post count: 1

    How did you access the retroarch.cfg file

    Many thanks

    Tom

    dudleydes
    Participant
    Post count: 139

    You can run the following command from a terminal.

    sudo nano RetroPie/configs/all/retroarch.cfg

    The lines I needed were

    input_enable_hotkey_btn = 16
    input_exit_emulator_btn = 16

    This lets me use the PS button to exit a game and return to EmulationStation.

    hodd
    Participant
    Post count: 5

    Hey there my problem is a little different. I’ve got my DualShock working completely in the Retroarch menus, but when I fire up a game I can’t do anything only the keyboard will get me out of the games. I’ve tried many different setups in /RetroPie/configs/all/retroarch.cfg but nothing seems to work when I’m in an emulator (I’m only using SNES and MAME)

    What could I be missing?

    hodd
    Participant
    Post count: 5

    Ah ha! I actually found that going into each emulators config folder (e.g. ~/RetroPie/configs/nes) and editing the retroarch.cfg there, made things work!

    hodd
    Participant
    Post count: 5

    Hrrrrm not working for MAME though…

    dudleydes
    Participant
    Post count: 139

    I have posted a solution for using the PS3 controller with Mame4all-pi in another thread (link below).

    …mame4all-pi-with-ps3-controller

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.