Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • tune
    Participant
    Post count: 4

    I have some quite weird problems with resolution. When I start raspberry pi retropie loads nicely with correct resolution (800×600) that I set in config.txt but when I start NES or SNES game resolution is higher (returns to correct resolution if I exit the game). But if I press F4 in the EmulationStation and type “sudo reboot” I notice that after reboot ES and game resolution is good (800×600).

    I have added/modified this to /boot/config.txt :
    hdmi_force_hotplug=1
    hdmi_group=2
    hdmi_mode=9
    hdmi_force_mode=9

    I have also tried modifying config.txt lines regarding display settings but the lines above seems to be about the only configuration that I can get correct resolution after reboot.

    When I start a game without rebooting I get a text saying (this goes away if I reboot before running a game):
    “Powering on HDMI with explicit settings (CEA mode 4)”

    How to make this work? That resolution might otherwise be ok but I have a old flat screen display with maximum resolution of 800×600 (I have no image with that HDMI setup that game normally starts) connected with HDMI to VGA adapter.

    I have tried modifying a lot of settings and files to try to make it run correctly but so far this is the best setting I have found and it is not good enough to have to manually reboot every time.

    Thanks for the help!

    trimmtrabb
    Participant
    Post count: 480

    Edit es_systems.cfg:

    sudo nano /etc/emulationstation/es_systems.cfg

    Navigate to the emulator you wish to modify and change runcommand.sh to 2. This will preserve the resolution you have set.

    tune
    Participant
    Post count: 4

    Thank you! That worked perfectly.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.