Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • retrorednek
    Participant
    Post count: 2

    I just received my Mausberry Shutdown circuit (use your own switch, direct-plug, micro-USB), but I’m having troubles to get it work with my NesPi project. As I press NES power button, the Raspberry Pi will power ok, but if I press power again, nothing happens. If the power button is engaged and I press reset, the Pi will perform hard reset. If the Pi is on, and I press the power button off and then press reset, the Pi will shutdown.

    I have wired power to Mausberry (brown +, red -), then reset also goes to Mausberry (yellow +, orange -). With led I cut the other lug and put it to 3.3v GPIO. For led GND I used the white wire from Nes power/reset circuit.

    Did I happen to buy the wrong circuit from Mausberry – was the momentary the one that I should have bought? Or maybe there’s something I’m missing..?

    I appreciate all your help!

    saegiru
    Participant
    Post count: 2

    I wired mine as you can see in the picture. The difference is that for the led, I wired it I soldered a 330 ohm resistor in and have it connected to a 3.3v gpio and ground gpio. It isn’t connected to the mausberry at all. Power, reset and led all work perfectly for me like this.

    http://m.imgur.com/uSqphwV,AjDAVoG

    h0llow
    Participant
    Post count: 6

    From what I read, you need to install a script from mausberry. I have the same thing but I had no luck installing their script.. It won’t allow me to edit the “switch.sh” file even though the script is trying to change permissions to allow that. Power turns on my raspberry and my reset does a hard shut off (instant) which obviously isn’t too great.. My workaround is shutdown Pi from emulationstation’s menu then I hit reset to actually turn it all off after.. Here is the link though to the script I’m talking about. Please post your findings if it works :)

    http://mausberry-circuits.myshopify.com/pages/setup

    scroll down a little and you’ll see “Installing the script”
    and I assume it is Arch since a ton of folders I see is Arch related lol but I was told from a friend maybe its DEB. I’m lost on all that jazz..

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.