Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • sn00wman86
    Participant
    Post count: 16

    I was at my work when i set me Keyboard settings (up/down/left/right/etc)

    And i get something wrong when i set this keys so now i can move Up/donw/left/right and i need to set this key settings again. How do i reset them so i get like it was from the first time i start Retropie. (Only what/need to reset the keyboard choose. )

    trimmtrabb
    Participant
    Post count: 480

    Hi, from terminal (f4) run:

    rm ~/.emulationstation/es_input.cfg

    then reboot to reset ES controls

    sn00wman86
    Participant
    Post count: 16

    Thanks and my next question is how can i make my Keyboard to be swedish, Right now i have us in the program :( Were hard to find the right key :P and wish key is ~ i only find that one but it’s on the top not middle :P

    sn00wman86
    Participant
    Post count: 16

    I fix that problem with the keys :) How to fix the problem like the pics shows ?

    When i test it everyting works but cant not sve :(

    trimmtrabb
    Participant
    Post count: 480

    Make sure /home/pi/RetroPie/configs/all/retroarch.cfg exists then type this:

    # cp /home/pi/RetroPie-Setup/supplementary/settings.xml /home/pi/supplementary/supplementary/ES-config/

    And try joypad config again

    sn00wman86
    Participant
    Post count: 16

    how do i write to come to /home/pi/RetroPie/configs/all/retroarch.cfg right now i am in pi@raspberrypi ~$

    Write like you do to a noob. never work with dos or what it call :P

    sn00wman86
    Participant
    Post count: 16

    and i write like this in the file # cp /home/pi/RetroPie-Setup/supplementary/settings.xml /home/pi/supplementary/supplementary/ES-config/ ? Is it some special place i need to write it on ?

    trimmtrabb
    Participant
    Post count: 480

    yes just type it in the terminal after pi@raspberrypi ~$

    sn00wman86
    Participant
    Post count: 16

    so in pi@raspberrypi ~$ i type /home/pi/RetroPie/configs/all/retroarch.cfg and ENTER to see if it exists and after in the file i type:

    # cp /home/pi/RetroPie-Setup/supplementary/settings.xml /home/pi/supplementary/supplementary/ES-config/

    and save and after try the controll ?

    But what do i do if that file not exist ? :S

    sn00wman86
    Participant
    Post count: 16

    When i write: /home/pi/RetroPie/configs/all/retroarch.cfg
    in pi@raspberrypi ~$’
    I get a messenger like :
    -bash: /home/pi/RetroPie/configs/all/retroarch.cfg: Permission denied

    trimmtrabb
    Participant
    Post count: 480

    to create retroarch.cfg type in terminal (after pi@raspberrypi ~$):

    nano /home/pi/RetroPie/configs/all/retroarch.cfg

    Then press ctrl x and save. Then type:

    # cp /home/pi/RetroPie-Setup/supplementary/settings.xml /home/pi/supplementary/supplementary/ES-config/

    then run joypad config again

    sn00wman86
    Participant
    Post count: 16

    # cp /home/pi/RetroPie-Setup/supplementary/settings.xml /home/pi/supplementary/supplementary/ES-config/

    Is it Space between xml and /home ?

    trimmtrabb
    Participant
    Post count: 480

    yes

    sn00wman86
    Participant
    Post count: 16

    I get [ Error Writing /home/pi/RetroPie/configs/all/retroarch.cfg: No such file or directory ] when i save it ^^ So guess i have no Permission so save it ^^

    trimmtrabb
    Participant
    Post count: 480

    you get that error after running joypad config?

    sn00wman86
    Participant
    Post count: 16

    after i have write it on the doc. and try to save it. that say like i write.

    trimmtrabb
    Participant
    Post count: 480

    you need to place a retroarch.cfg in /home/pi/RetroPie/configs/all/retroarch.cfg

    Use nano:

    nano /home/pi/RetroPie/configs/all/retroarch.cfg

    Type a random character and ctrl x and press y to save.

    sn00wman86
    Participant
    Post count: 16

    So now i have make a new directory <strong (/home/pi/RetroPie/configs/all/)

    Have Create retroarch.cfg and have write # cp /home/pi/RetroPie-Setup/supplementary/settings.xml /home/pi/supplementary/supplementary/ES-config/

    And I press ctrl + X to save it and the program ask my if i want to save it and i press Y and after that i get a messenger like this: [ Error writing /home/pi/RetroPie/configs/all/retroarch.cfg: Permission Denied

    Okey Now i have fix so i can save it. and after i save and reboot the system i try to config the controll but i get Script Error!!!

    trimmtrabb
    Participant
    Post count: 480

    Ok I have no idea why this isn’t working, the other way to set your pad up is to edit retroarch.cfg manually.

    See this thread for instructions: http://www.petrockblock.com/forums/topic/input-configuration-script-fails-bindings-are-off/

    sn00wman86
    Participant
    Post count: 16

    ok :) Thanks :) I have reinstall Retropie know so will put that inside :)

    And everything i not find in the lite i add to it ?

    like this for a exemple :
    input_player1_l_x_plus_axis = “+0”
    input_player1_l_x_minus_axis = “-0”
    input_player1_l_y_plus_axis = “+1”
    input_player1_l_y_minus_axis = “-1”
    input_player1_r_x_plus_axis = “+2”
    input_player1_r_x_minus_axis = “-2”
    input_player1_r_y_plus_axis = “+3”
    input_player1_r_y_minus_axis = “-3”

    only find without _axis in the list.

    input_player1_l_x_plus

    sn00wman86
    Participant
    Post count: 16

    This have i done now.
    1. cd RetroPie-Setup and go to sudo ./retropie_setup.sh
    2. Take Choose 2. Source-based INSTALLATION (16-20 hours)
    3. Choose 4. UPDATE RetroPie Setup script
    4. Go in to Choose 3. SETUP.
    5. Choose 16. Install drivers for Xbox3600 Wired Controll
    6. Choose 19. Register Controll for RetroArch emulation

    And i Reboot some times from 1 – 6. After all this was finnish I Config the control for the Emulationstation Meny, and it’s working.

    And next step i did was go to Input Configuration in emulationstation. And set all keys and this time i can save the the keys i choose with the Xbox360 Controll. and after I have save it I Exit. And reboot. and after that i try to start Snes Emulation. But when i start a game only the keyboard works not the Xbox360 Control.

    Can i use that instructions for this problems to or do i need some other instructions?

    trimmtrabb
    Participant
    Post count: 480

    Unzip and place this retroarch.cfg I have attached in /home/pi/RetroPie/configs/all/

    To do this:

    Download Filezilla: https://filezilla-project.org/

    Connect your Pi to your network via ethernet. In terminal on Pi type: sudo ifconfig

    Note the IP address of the Pi starting 192.168 after ‘inet addr’

    Open Filezilla, in top left box ‘host’ type the IP address you just noted.
    Then in ‘username’ box type pi
    In ‘password’ box type raspberry
    In ‘port’ box type 22

    Press ‘quickconnect’
    In ‘remote site’ box on right side navigate to: home/pi/RetroPie/configs/all/

    Drag the retroarch.cfg into the ‘remote site’ box to copy over.

    Start your emulator and the controls should work, they’re set up for a xbox 360 pad. If they don’t work run:

    nano /home/pi/RetroPie/configs/all/retroarch.cfg

    and change input_player1_joypad_index = “0” to input_player1_joypad_index = “1” (or possibly 2)

    You can also modify the controls if you wish by changing the button numbers.

    I have set the ‘hotkey’ button to the ‘back’ button on the pad. This means that if you press the back button and specific buttons you can access different options:

    back & start = emulator exit
    back & home button = Retroarch GUI (useful for setting frameskip)
    back & left shoulder button = load save file
    back & right shoulder button = save file
    back & left trigger = select save state decrease
    back & right trigger = select save state increase

    Hope this helps

Viewing 22 posts - 1 through 22 (of 22 total)
  • You must be logged in to reply to this topic.