Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • venkatrl
    Post count: 8


    So far, I’ve had good luck with keyboard controls (both within the emulationstation interface and of the SNES, Sega, and NES games I have tried)–

    Unfortunately, though, even after following all of the suggested steps multiple times, I have had no luck having my 360 controller work for any of my ROMS — although the 360 controller works fine for moving around the menus in emulationstation.

    This is my first raspberrypi project, and I was hoping I could get some advice based on the steps I took to configure my 360 controller. I will try to be as thorough as possible, but I am happy to clarify anything that is unclear.

    I first started off by exiting emulationstation for the bash shell after a fresh install, then executing within the Retropie-Setup folder. I used the built-in utility to “Install drivers for Xbox 360 Wired Controllers” (task #16 under “Setup”).

    I double-checked that this procedure worked against the one described on petrockblog and, as suggested, went through the additional step of running:
    “./retroarch-joyconfig -o p2.cfg -p 2 -j 1”
    “sudo cat p*.cfg >> ~/RetroPie/configs/all/retroarch.cfg”

    Next, to get the input configuration for Retroarch up and running, I followed the steps descripted on a second petrockblog entry.

    Finally, I rebooted back into emulationstation and (after completing the initial joypad setup) headed over to “Input Configuration.” I had a few new options listed: “Disable / Enable RetroArch Autoconfig, Open RGUI, Show current IP address, Start, Start basic input configuration, and Start ES-Config.”

    I selected “Start ES-Config,” and then, I encountered something t puzzling: I was able to properly click through the button setup for “RetroArch” and save it, but NOT for “GnGeo” or “DGen” (instead, it would give me a “script error!” message). Not sure why this would be, or whether it would impact my NES or SNES controls.

    After all of this, none of my ROMs still respond in any way to my 360 controller – only emulationstation seems to recognize it. Is there something further I need to do with my retroarch.cfg files to share them with each emulator? I would be grateful for any suggestions!

    Thanks in advance,


    Post count: 480

    In terminal type

    ls /dev/input/

    Note the number after ‘js’ (joystick) This is the index your pad is assigned.

    Edit retroarch.cfg:

    nano /home/pi/RetroPie/configs/all/retroarch.cfg

    Check ‘input_player1_joypad_index’ is the same number as listed for js under /dev/input/

    e.g. if your pad is assigned js0 it needs to be:

    input_player1_joypad_index = "0"

    I have attached my retroarch.cfg for reference

    Post count: 8


    Thank you so much – that was very helpful. Nearly all of my emulators now recognize the 360 pad.

    The only remaining issues are with the Duke Nukem Emulator (which starts but only allows joystick control for menus but not gameplay). I will search the forums to see if this is a known issue.

    Additionally, there are a few remaining issues that may or may not be related to joypad conflicts (Game Gear works flawlessly for a few games but then later fails to open those same games… Additionally, the only N64 games that boot only make it to the opening screen). Again, I will look for the appropriate forum to search / post these issues (unless you can direct me off the top of your head).

    I appreciate your help!



    The Game Gear emulator (which used to work) now produces a black screen

    Post count: 480

    Cool, glad you got it working :-) A lot of the emulators are Libretro cores which can be configured through the Retroarch frontend with retroarch.cfg

    You may want to create custom controls for each emulator, place a modified retroarch.cfg in the respective emulator folder, e.g. for Megadrive/Genesis place in /home/pi/RetroPie/configs/Megadrive/ this will override the default retroarch.cfg in /home/pi/RetroPie/configs/all/

    To determine buttons you can run jtest which should be installed already, if not:

    sudo apt-get install joystick

    Then run:

    jstest /dev/input/js*

    (replace * with the index your pad is assigned)

    Other emulators have their own config files.

    As for Duke Nukem and Game Gear emulators I don’t use either, so you’ll have to search that one. I’m sure you can run Game Gear roms through the Megadrive emulator though?

    The N64 emulator requires the Pi to be overclocked and will only run a few roms at a decent speed.

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.