Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • typh0id
    Participant
    Post count: 34

    Hey there!

    I was wondering if anyone had any input on some issues I’ve been having with the PCEngine (TG16) emulator in RetroPie. Namely, it seems like a large number of ROMs don’t work and for various reasons. I believe the ROMs I have are of solid quality since I got them from a place that is pretty reliable for releasing clean ROMs with GoodCodes and such. Here are some examples of the problems I’ve seen:

    1) Some ROMs , when I select them, flash to the terminal to load (as normal) but then the screen goes black and nothing else happens. I can still use the controller so I am able to start/select back to EmulationStation, but the game never shows up.

    Some games that do this are: Ballistix, Double Dungeon, and Pacland.

    2) Some ROMs go to the terminal screen and a short message I can’t read repeats itself many times very quickly down the screen before the screen goes black. In these cases, the whole program freezes up and I can’t use the keyboard or gamepad and have to simply unplug the Pi and reboot.

    Some games that do this are: Cadash and Dungeon Explorer.

    3) The game Order of the Griffen loads up and gets all the way to menu screen. The options are “Start a New Game” and “Continue a saved Game” but there is no highlight bar to indicate one has been selected and nothing at all happens when I push the buttons or DPad on my gamepad (I can still start/select out though).

    These are a few problems I’ve had. Is there a way to fix these or is it just a general compatibility issue with the emulator? Thanks for the advice!

    Mutex
    Participant
    Post count: 61

    Tried those games:
    Cadash: no problems at all
    Double Dungeons – W: also no problems
    Pac-Land: Got into the game but the controls are really wierd
    Ballistix: Game loaded but i couldn’t select anything in the menu
    Order of the Griffon: same as Ballistix (just as you described)
    Dungeon Explorer: Got to a tavern view with some text telling me to select the numbers of players. At that point the game got really slow and didn’t take any inputs

    typh0id
    Participant
    Post count: 34

    After reading your reply, I went and found copies of the afore-mentioned ROMs from a different source (ridiculously I hadn’t thought of trying this before…) and all of new ROMs for the problem games worked just fine.

    Ballistix seemed to controller swap on me (had to use controller 2 to select anything from the menu) but once the game started the controllers seemed to swap back so I’m calling it a win…

    Didn’t have your issue with Dungeon Explorer at all but I agree the controls on Pac-Land are quite wonky…Seems as though that is how they are supposed to be…

    Anyway, thanks for checking those for me…It got me to think of what should have been obvious from the start :P

    caseyjames
    Participant
    Post count: 15

    yep change the video driver to sd1

    robbyb20
    Participant
    Post count: 1

    I am having this same issue. I know this was marked as resolved by getting a new rom but i have tested the rom with Magic Engine on the PC and it works perfectly. The one i tested that works with Magic Engine but not Retropie pc engine is Bloody Wolf.

    Any suggestions?

    Thank you,
    Rob

    labelwhore
    Participant
    Post count: 526

    I’m having this issue with the latest image. My roms worked previously (on 2.6), so I don’t think it’s a rom or BIOS issue.

    Sorry for the necro post, but I want to help keep the forums clean. :P

    labelwhore
    Participant
    Post count: 526

    ^^ it ended up being my roms. I don’t know what happened, but new roms fixed it.

    barny80
    Participant
    Post count: 2

    Hello

    I have an issue with a PC engine CD game, Akumajou_Dracula_X_-_Chi_no_Rinne_(NTSC-J)_[KMCD3005]. I have placed the syscard3.pce in the BIOS folder and also in the ROMS folder, the game still doesn’t start up, it just returns to the game selection.
    In what format has the image have to be in order to run or does anyone have an idea what might be wrong?

    simillarian
    Participant
    Post count: 27

    You might have the same issue I was having. Try renaming the ROM to exclude underscores. I renamed the files to…
    Akumajou Dracula X - Chi no Rinne.iso
    and
    Akumajou Dracula X - Chi no Rinne.cue.

    Don’t forget to update the filename in the .cue file with notepad. In my case the first line needed to change to
    FILE "Akumajou Dracula X - Chi no Rinne.iso" BINARY
    Just make sure the file name is the same as your .iso file.

    Also, make sure you have SYSCARD3.PCE capitalized in the bios folder. This seems to not be true as of v3.3

    barny80
    Participant
    Post count: 2

    Thank you very much for your help simillarian.
    I go it running following your suggestions, but it didn’t start until i renamed the syscard3.pce with lowercase letters again.
    Anyway, thank you once again and have a great 2016 :)

    simillarian
    Participant
    Post count: 27

    Ah! So that is why it wasn’t working after I upgraded to 3.3. I didn’t have the time to figure it out so I was just going to do it later. Thanks for mentioning it! Saved some of my free time this weekend :)

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.