Homepage Forums RetroPie Project Everything else related to the RetroPie Project Has anyone used the Raphnet 4x SNES/NES USB adapter circuit?

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #2472


    I have a couple of these laying around from a previous project. I’m looking at starting my NES Pi project and was wondering if anyone has used these under Pi.

    Their docs state: Under Linux, 1 controller with 8 axis and 32 buttons appears.

    Anyone know if this means I will only be able to use 1 controller under Pi with this adapter?


    I used the nes2usb circuit (http://www.raphnet-tech.com/products/AnodeNES_circuit/index.php) within my project.

    I managed to get it working in my NESpi-Mod.

    As described by raphnet the controller is recognised as 1 controller with 4 axis and 16 buttons (as it can also used with two snes controllers).

    Within the retropie menu i can only use the first controller.


    <?xml version="1.0"?>
    	<inputConfig type="keyboard" />
    	<inputConfig type="joystick" deviceName="raphnet.net nes2usb">
    		<input name="a" type="button" id="7" value="1" />
    		<input name="b" type="button" id="6" value="1" />
    		<input name="down" type="axis" id="1" value="1" />
    		<input name="left" type="axis" id="0" value="-1" />
    		<input name="menu" type="button" id="4" value="1" />
    		<input name="right" type="axis" id="0" value="1" />
    		<input name="select" type="button" id="5" value="1" />
    		<input name="up" type="axis" id="1" value="-1" />

    Input config in retroarch.cfg:

    input_player1_joypad_index = "0"
    input_player1_a_btn = "7"
    input_player1_b_btn = "6"
    input_player1_y_btn = ""
    input_player1_x_btn = ""
    input_player1_select_btn = "5"
    input_player1_start_btn = "4"
    input_player1_l_btn = ""
    input_player1_r_btn = ""
    input_player1_up_axis = "-1"
    input_player1_down_axis = "+1"
    input_player1_left_axis = "-0"
    input_player1_right_axis = "+0"
    input_player2_joypad_index = "0"
    input_player2_a_btn = "15"
    input_player2_b_btn = "14"
    input_player2_y_btn = ""
    input_player2_x_btn = ""
    input_player2_select_btn = "13"
    input_player2_start_btn = "12"
    input_player2_l_btn = ""
    input_player2_r_btn = ""
    input_player2_up_axis = "-3"
    input_player2_down_axis = "+3"
    input_player2_left_axis = "-2"
    input_player2_right_axis = "+2"

    I think the raphnet 4x SNES / NES should work similar to mine ;)


    yeah should be fine the only issue you will face is trying to find 4 nes or snes connectors because you will only get the bare board with that.


    I used this board as well. It took some time soldering it together.

    On one end you solder on the usb-connector and on the other either a SNES/NES controller or a connector (also available at raphnet) –> http://www.raphnet-tech.com/products/snes_controller_connector/index.php

    The Configuration is very similar to the one I used with the nes2usb circuit.


    	<inputConfig type="joystick" deviceName="raphnet.net 4nes4snes" deviceGUID="030000009b2800000300000001010000">
    		<input name="a" type="button" id="4" value="1" />
    		<input name="b" type="button" id="0" value="1" />
    		<input name="down" type="axis" id="1" value="1" />
    		<input name="left" type="axis" id="0" value="-1" />
    		<input name="pagedown" type="button" id="6" value="1" />
    		<input name="pageup" type="button" id="7" value="1" />
    		<input name="right" type="axis" id="0" value="1" />
    		<input name="select" type="button" id="2" value="1" />
    		<input name="start" type="button" id="3" value="1" />
    		<input name="up" type="axis" id="1" value="-1" />


    input_player1_joypad_index = 0
    input_player2_joypad_index = 0
    input_player1_a_btn = 4
    input_player1_b_btn = 0
    input_player1_y_btn = 1
    input_player1_x_btn = 5
    input_player1_start_btn = 3
    input_player1_select_btn = 2
    input_player1_l_btn = 6
    input_player1_r_btn = 7
    input_player2_a_btn = 12
    input_player2_b_btn = 8
    input_player2_y_btn = 9
    input_player2_x_btn = 13
    input_player2_start_btn = 11
    input_player2_select_btn = 10
    input_player2_l_btn = 14
    input_player2_r_btn = 15
    input_player1_up_axis = -1
    input_player1_down_axis = +1
    input_player1_left_axis = -0
    input_player1_right_axis = +0
    input_player2_up_axis = -3
    input_player2_down_axis = +3
    input_player2_left_axis = -2
    input_player2_right_axis = +2
    input_enable_hotkey_btn = 2
    input_exit_emulator_btn = 3
    input_save_state_axis = -1
    input_load_state_axis = +1

    I only configured two connectors, as I just needed two.

    My only problem left is: when quitting an emulator –> controlls point up and left till I press any button.


    I hate to reopen an old thread, but I have been trying to get the darn raphnet nes2usb adapter player 2 working and for the life of me I can’t figure out what I am doing wrong. I have all my inputs inserted correctly and have uncommented all lines that are to be used. also uncommented auto detect and and made it false. is there something I am missing or is there additional steps in getting the second player controller to work. by the way i am use to NES controllers.


    Hi there,
    I had the same problem with the d-pad thingy, I looked up controller issues on this forum and found a similar issue with an other controller. This issue was fixed with a custom kernel, I tried this method and it worked flawlessly, even 4 player bomberman on pce works great. If you search on my name on this forum you should find this topic. I don’t have much posts so it shouldn’t be that hard to find ;)


    Thanks for the quick response Koffieleut, but I also tried the custom kernel provided by freechains. that fixed he issue with not showing all available axis. so that issues was fixed. I add the second controller by configuring the retroarch.cfg file but I’m not sure if I did it right or not as the second controller is still not working. In emulation station it is possible to config controller 2 and it will work to navigate Emulation station but when I open a 2 player game like contra, only the first player controller works. Is there anywhere where I can find a walk-through on how to configure the retroarch.cfg file so that the second controller works. thank you very much for any help you may offer, I truly appreciate it.


    It works with usb quirks on retropie 3.3 (no longer required custom kernel) :

Viewing 8 posts - 1 through 8 (of 8 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.