Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • domnewell1
    Participant
    Post count: 6

    Hi,

    Every time I update the retropie script to allow retroarch autoconfig, my gameboy advance emulator and roms stop working. They were fine before. Does anyone have any ideas as to how I could solve this?

    trimmtrabb
    Participant
    Post count: 480

    I’m not sure why that is happening, the GBA emulator isn’t configured via Retroarch. Try backing up your es_systems.cfg and gpsp.cfg before running the auto config and then restore afterwards

    domnewell1
    Participant
    Post count: 6

    How do I do this, just copy to my computer, run auto config and then copy it back across?
    Sorry, complete newbie

    Thanks for the reply

    trimmtrabb
    Participant
    Post count: 480

    yes copy them off with a ftp client, I use Filezilla. When you say stop working, you can’t run the emulator at all?

    domnewell1
    Participant
    Post count: 6

    When I click the rom, it starts running code, but after a few seconds it blacks out and returns to the rom menu

    I use cyberduck at the moment, so I will give it a try

    trimmtrabb
    Participant
    Post count: 480

    if you press f4 after attempting to run the emulator what errors do you see?

    domnewell1
    Participant
    Post count: 6

    Before I copied the old gpsp file over I got

    “/home/pi/RetroPie/emulators/gpsp/raspberrypi/gpsp: No such file of directory”

    But now that I have copied over the version of the emulator when it worked, I get

    “/home/pi/RetroPie/emulators/gpsp/raspberrypi/gpsp: Permission denied”

    That’s the only part that causes error

    trimmtrabb
    Participant
    Post count: 480

    try reinstalling GPSP via the setup script, it’s in ‘source based installation’

    domnewell1
    Participant
    Post count: 6

    No, that hasn’t worked. This the the code I get now:

    performance
     powering on HDMI with explicit settings (CEA mode 4)
     /home/pi/RetroPie/supplementary/runcommand/runcommand.sh: line 32:   /home/pi/RetroPie/emulators/gpsp/raspberrypi/gpsp: No such file or directory
     Powering on HDMI with preferred settings
     ondemand

    That’s it

    Mutex
    Participant
    Post count: 61

    Have you tried to start the emulator from command line? It seems the runcommand script doesn’t find the path/binary that you are trying to execute.
    You can start the emulator from commandline with:
    /home/pi/RetroPie/emulators/gpsp/raspberrypi/gpsp

    See if theres something in that specific folder with:
    ls -l /home/pi/RetroPie/emulators/gpsp

    domnewell1
    Participant
    Post count: 6

    When I try to see if there is something in the folder it comes up with:

    ls: cannot access /home/pi/RetroPie/emulators/gpsp: No such file or directory

    When I try to run the emulator from command line:

    -bash: /home/pi/RetroPie/emulators/gpsp/raspberrypi/gpsp: No such file or directory

    Thanks for the reply though

    EDIT: the gpsp emulator had been deleted, so I copied it back across. Now, it says permission denied instead of no such file or directory when I try to run from command line, but when I try to see if there is anything in it it says

    total 4
    drwxr-xp-x 3 pi_pi 4096 Apr 25 11:55 raspberrypi
Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.