Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • savage702
    Participant
    Post count: 3

    Hi All,

    New here, just installed the latest RetroPie, loving it so far. Having some issues with SNES & Genesis games looking rather pixelated. I’ve been trawling through the forums and messages trying different things, and have made a little progress, but still feel I’m missing something.

    Using a Rev 2 Pi, HDMI to a Samsung 32″ 720p TV. Got my old Rumblepad controllers working nicely.

    No shaders/standard settings or with an alternate shader that was suggested:
    [URL=http://www.directupload.net][IMG]http://s14.directupload.net/images/140728/g5tqcuc2.jpg[/IMG][/URL]

    With default shader enabled… looks much better, but dark colors, and still not really right.
    [URL=http://www.directupload.net][IMG]http://s14.directupload.net/images/140728/hll8ikob.jpg[/IMG][/URL]

    Default shader enabled still, you can see it still looks pretty distracting ingame.
    [URL=http://www.directupload.net][IMG]http://s14.directupload.net/images/140728/a7eo337c.jpg[/IMG][/URL]

    Sega Genesis with default shader enabled… looks much better, but those vertical lines:
    [URL=http://www.directupload.net][IMG]http://s7.directupload.net/images/140728/aixf92ob.jpg[/IMG][/URL]

    morias
    Participant
    Post count: 28

    Keep trying more shaders. I like hq2x.

    kitchuk
    Participant
    Post count: 207

    I find the lcd3x shader with bilinear filtering looks good.

    savage702
    Participant
    Post count: 3

    Thanks guys, I thought maybe there was a setting I’m missing or something I’m doing wrong vs trying to use more different shaders. I’m at work right now, and can’t check it out, but are the suggested ones included in RetroPie, or do I need to install them from somewhere?

    Does this all look different depending on TV/Monitor/Hardware? If these default shaders look like crap for everyone, how come they’re there as the default, or does it vary?

    Also, I keep seeing a lot about forcing/changing modes in config.txt, does that have anything to do with how the emulators display?
    I tried:
    hdmi_group=1
    hdmi_mode=1
    overscan_scale=1

    But had to change it to hdmi_mode=4 to display EmulationStation right. Then saw something about this if you’d updated recently, which I had:
    hdmi_force_mode=1

    I’m not sure this helped/changed or fixed anything after each reboot.

    K-Project
    Participant
    Post count: 12

    Dunno if this helps, but changing the runcommand.sh for your emulators can help. I changed a number of mine to runcommand.sh 2 in order to get a better display on my Samsung LCD. You can change this in es_systems.cfg in /etc/emulationstation. I still use shaders too, and the whole thing looks better to me.

    Hope this is useful, and the right thing to be doing! Please post up if this is not correct. Thanks all.

    savage702
    Participant
    Post count: 3

    So far, I feel much more satisfied with:
    hq4x_lcd3x.glslp shaders for Sega Megadrive/Genesis Games.
    snes_lcd3x.glslp for SNES was a huge improvement.

    So far I’ve been satisfied with the way Super Mario Bros looks on NES, but maybe I’ll try some different shaders there too.

    I tried a few others, and they were marginally better, or worse. There’s a lot to try, and I’m not sure what would make me choose one over another besides just guess work… which is what I did above.

    I’d love for anyone to share individual shaders that they’ve found work best for them. Lots of old threads laying around with dead ends where people stop helping/giving suggestions, and the OP’s seem to vanish (maybe give up, or not post their favored results?).

    trimmtrabb
    Participant
    Post count: 480

    I use video_smooth = true to soften the pixelation

    jwjacobs
    Participant
    Post count: 1

    Hey I am having the same problem and a Retropie noob. Where exactly do you change all these setting to improve the video quality? Thanks for your help.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.