Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • polluxpt
    Post count: 28

    I’m using 2.6 RPi2 Version of RetroPie and I have all my systems running as I want except one: FBAlibretro.

    If I use PiFBA I can setup my controls just fine but I cannot get my screen to 4:3.
    If I use FBAlibreto I get my screen 4:3 but I get weird controller setup so my journey begins here.
    After reading a lot and trying a lot a things I got my controller to work but I cannot change my buttons to my own set.
    I got into retroarch, configured my controller and saved into fb_alpha_libretro.cfg file.
    Then I copied that file into FBA config folder and changed my ES_Systems.cfg file to get it to work.
    At this point I got my controller working in FBAlibretro but got no hotkeys working so I setup a retroarch.cfg inside FBA folder to override configurations. After doing this I got a mixed configuration and got hotkeys.
    However my problem was not solved since I could saw lines in terminal changing my controller into Retropad.
    Trying to change my input buttons data I set one to “nswitch.ncode: 6” and I got everything working but my “Coin” buttons was my controller Y button (I wanted Select button).

    Since I’m really confused and I cannot find doubtless information about this, can anyone tell me the best/right way to do it?

    Thanks a lot!

    PS: FBAlibretro runs games that PiFBA doesn’t so I stick to FBAlibretro.

    Post count: 43

    I had the same issue with my gamepad (F310), and this thread helped me to fix it:

    Even though you don’t have the same controller, I think the most important is to clean everything up in the opt/retropie/configs/all/retroarch.cfg file (after doing a backup of course) and copy the lines that ‘neighbourhoodnerd’ proposes to use, then you can change the buttons IDs to match your controller mapping.

    For your other problem, I am somehow “glad” that you are pointing it out since I also have the exact same problem too, I don’t manage to get a 4:3 ratio in PiFBA (except with the neo-geo games), while there is no problem to get it in FBAlibretro.
    It’s a huge problem because in my case, FBAlibretro runs only about 10% of what I manage to run in PiFBA (using the same FBA romset).
    It’s like there was no connection between the retroarch.cfg files and PiFBA, no matter what I change, nothing change in the emulator.

    Post count: 28

    Thank you for your answer but I got that already.
    I don’t have my Retropie with today but I’ll try another thing tomorrow: I will try to create a “CONTROLER_NAMED.cfg” file and put it in “/opt/retropie/emulators/retroarch/configs” folder and set up everything to point to it in “retroarch.cfg” main file.
    As far as I’m seeing I’m in the right way and I’ve done everything like others except this.
    What I’ve done this far was writing all my inputs in “retroarch.cfg” main file and everything was working fine for the other emulators (including SCUMMVM and GPSP).
    I’ll give my feedback tomorrow about this step.

    By the way, what is FBA best emulator? PiFBA, FBAlibretro or other?

    I’m new to RetroPie but I’m in touch with emulation since Dingoo, got a PC with Hyperspin and a Minix X7 Mini running Mamedroid and others just fine. Retropie took me a lot of time this far only with FBA… I think as much as I took with Dingoo FBA emulator.

    PS: I’ve attachded my original “fb_alpha_libretro.cfg” the one I saved from Retroarch and make somethings work. Please note that what matters is just input buttons because other settings like video ones are running from “retroarch.cfg” file.

    Post count: 28


    After creating my file as done in the other topic I got the same results.
    I attached my error log to see what I’m seeing as a problem.

    Any help I will apreciate a lot.

    Post count: 28

    After several tries I got it fixed.

    As I think this will be usefull for other people I write my solution:

    1st – I made a fresh new install and put fb_alpha_libretro.cfg in my fba config folder.
    This config folder was edited by me, starting from the original one (post above) which I got directly from Retroarch;

    2nd – I edited es_systems.cfg file from /opt/retropie/supplementary/runcommand/ 1 "/opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/fbalibretro/ --config /opt/retropie/configs/all/retroarch.cfg --appendconfig /opt/retropie/configs/fba/retroarch.cfg %ROM%" "fbalibretro" to /opt/retropie/supplementary/runcommand/ 1 "/opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/fbalibretro/ --config /opt/retropie/configs/all/retroarch.cfg --appendconfig /opt/retropie/configs/fba/fb_alpha_libretro.cfg %ROM%" "fbalibretro".
    I tried a copy-paste solution into retroarch.cfg but somehow it messed things up so I prefered to add this fb_alpha_libretro.cfg file;

    3rd – After previously edited my fb_alpha_libretro.cfg file I checked my button configuration running some games and figured out that they need to be ajusted (I got a ShanWan Usb WirelessController, LINK: ).
    I edited my controls in fb_alpha_libretro.cfg file (inside fba config folder) and got my general controllers set up in retroarch.cfg (inside all config folder) so they both work with hotkeys, save/load states, etc, not messing each other.
    Just one quick note: Somehow in some games Select button don’t work as Coin and hotkey. So I changed Coin from Select to another button and it works great (and I can live with that).

    I tried just 3 games this far (Pang, The Punisher and Cadillacs & Dinosaurs) and all of them worked great, with 4:3 resolution. I’m waiting for a 64GB mini pen so I probably will find issues in the future and I will update this post later (if needed).

    In case someone needs them I attached my cfg files (renamed to TXT) here.

    fb_alpha_libretro.txt exists already in this post so please rename fb_alpha_libretro1.txt to fb_alpha_libretro.cfg in order to use it.

    Post count: 20

    thank you!

    This is a GREAT config file for fba!
    I only changed a button and put false on video smooth!

    Post count: 28

    Glad it helped someone!

    Post count: 1

    Thank you very much , has been very good to me congifurar fba with Remote Control xbox360.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.