Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • mikaaville
    Participant
    Post count: 9

    So, it took a clean install of RetroPie but I finally got my USB controller to work, except…I can’t seem to map my escape rom hotkey right, when I do it, everything seems right but when I am in game and I just press X it exits the game, not even what I mapped to escape. Maybe I am missing something, I’m sort of a noob with this.

    input_device = “USB Gamepad ”
    input_driver = “udev”
    input_b_btn = “2”
    input_y_btn = “3”
    input_select_btn = “8”
    input_start_btn = “9”
    input_up_axis = “-1”
    input_down_axis = “+1”
    input_left_axis = “-0”
    input_right_axis = “+0”
    input_a_btn = “1”
    input_x_btn = “0”
    input_l_btn = “4”
    input_r_btn = “5”
    input_enable_hotkey_btn = “9”
    input_exit_emulator_btn = “8”
    input_enable_hotkey_btn = “9”
    input_save_state_btn = “4”
    input_enable_hotkey_btn = “9”
    input_load_state_btn = “5”

    Floob
    Member
    Post count: 1629

    This may help you setup hotkeys

    mikaaville
    Participant
    Post count: 9

    Ok, I tried to go to setup and I didn’t see the option to enable hotkeys.

    Floob
    Member
    Post count: 1629

    Have you updated your retropie script?

    Maybe run with the 2.4.2 image?

    mikaaville
    Participant
    Post count: 9

    I just don’t want to mess up anything that would make the controller not work. lol, I was being paranoid with updating.

    Floob
    Member
    Post count: 1629

    Feel free to check out my other videos (link in signature) to see how to easily setup USB controllers.

    mikaaville
    Participant
    Post count: 9

    So, I pressed option 2 to enable the hotkeys, I made sure the ALT was set for the keyboard, I put input_enable_hotkey_btn = “9” in my controller config file and it is still escaping on a X button press. :(

    Floob
    Member
    Post count: 1629

    Could you post your controller file and /opt/retropie/configs/all/retroarch.cfg file here as attachments?

    You would need to rename them .txt

    mikaaville
    Participant
    Post count: 9

    There you go. Thanks for trying to help me!

    Roo
    Participant
    Post count: 211

    Those files are incomplete. If you’re going to log it from the Pi, try cat /opt/retropie/configs/all/retroarch.cfg instead of nano

    mikaaville
    Participant
    Post count: 9

    This work?

    Floob
    Member
    Post count: 1629

    Yep thats better. That file looks ok to be honest.
    Can you do your controller file in the same way?

    It should be
    cat /opt/retropie/emulators/RetroArch/configs/USBconfig.cfg
    and
    cat /opt/retropie/configs/{the system you are using}/retroarch.cfg

    mikaaville
    Participant
    Post count: 9

    There you go. :)

    Floob
    Member
    Post count: 1629

    This bit looks really screwed in your USBconfig.cfg file

    input_enable_hotkey_btn = “9”
    input_exit_emulator_btn = “8”
    input_save_state_btn = “4”
    input_load_state_btn = “5”

    My first thought is that you havent used the correct ” symbol – try copying it from one of the other lines.

    mikaaville
    Participant
    Post count: 9

    That was it! as soon as I typed it out using the other symbols it worked! thanks so much!

Viewing 15 posts - 1 through 15 (of 15 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.