Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • jdroberto
    Participant
    Post count: 8

    [sort of a report but with proper details this time]
    Hi there and thanks, advance, if anyone can help. Here’s my problem:

    I’ve built a bartop arcade cabinet for my two kids to enjoy the games of my youth. It uses only AdvMame and about 15 oooooold school arcade games.

    It’s built on a RaspberyPie 2 B running RetroPie and Emulation Station. I have 5 buttons (insert coin, player 1, fire/jump, alt action, quit) and a 4-direction joystick from Adafruit all direct wired into the GPIO pins on the Raspberry Pie board. The joystick is mapped to ARROW UP, ARROW DOWN, etc etc and the buttons are mapped to various keys (5,6,enter,etc) to send commands to the emulator so the user can both navigate and play the games

    It all works flawlessly – EXCEPT for this:

    When I am in the MAME menu of ES and I launch a game, there’s a brief moment between selecting the game and when it comes up on screen (while the ROM itself is loading). If, during that time, you move the joystick at all, the ROM stops loading and a configuration screen pops up (one with emulator specific configs – Select default emulator for MameAdv, Select default emulator for ROM, etc)

    Because my kids are…well, kids…when they pick a game they are very likely to get anxious and touch the joystick or a button, etc. When they do so, the ROM stops loading and I have to dig up a USB keyboard to exit out of the config menu and get back into ES.

    Is there anyway to either a) disable this or b) re-map what keys call up this menu so that the joystick/buttons cannot do so.

    Thanks for any thoughts on solving this!

    lilbud
    Participant
    Post count: 118

    That is the runcommand menu, it appears, to my knowledge, when you hit a keyboard key. By wiring the buttons and joystick directly to GPIO, they will read as keyboard keys.

    adid4s
    Participant
    Post count: 94

    In the newest version of retropie there’s a fix for that, you can disable that menu altogether very easily , not sure if it’s officially released but stay tuned for it

    jdroberto
    Participant
    Post count: 8

    Thanks for the info. Two questions:

    lilbud – I know that the buttons/joystick are indistinguishable from keystrokes as far as the Raspberry Pie is concerned (which is good, that’s how I get them to work) but I am wondering if there’s a way to surpress the runcommand menu.

    adid4s – Could you suggest to (this linux newb) how I might check what version of RetroPie I am running and where/how I can update when possible?

    Thanks!

    herbfargus
    Member
    Post count: 1858

    You can see it in action here:

    See this page on updating:

    https://github.com/RetroPie/RetroPie-Setup/wiki/Updating-RetroPie

    You’ll either want to do a full binary install or just start from a fresh 3.5 image.

    https://github.com/RetroPie/RetroPie-Setup/wiki/First-Installation

    jdroberto
    Participant
    Post count: 8

    Thank you! Could you suggest where I might find the config in 3.5 to shut off the runcommand menu?

    herbfargus
    Member
    Post count: 1858

    It’s on the video.

    jdroberto
    Participant
    Post count: 8

    Thanks but i just updated RetroPie and the ‘Configure Runcommand Launch Script’ choice doesn’t appear on my RetroPie menu in Emulation Station. Hmmm….

    herbfargus
    Member
    Post count: 1858

    Did you update your setup script and do a full binary install?

    https://github.com/retropie/RetroPie-Setup/wiki/Updating-RetroPie

    Make a backup first.

    Also any of the menu options in emulationstation can be accessed from the setup script. So you don’t necessarily even technically need the retropie menu in emulationstation. It’s just there for convenience.

    jdroberto
    Participant
    Post count: 8

    Thanks, it’s fixed now. I had no updated the update script. Now 3.5 is installed and I was about to disable the runcommand menu and alls well! Really appreciate the help.

Viewing 10 posts - 1 through 10 (of 10 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.