Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • thejbone
    Participant
    Post count: 4

    When I launch any games on the emulators it will show a thing about launch options, I never use these options and it seems when people use my RetroPie setup they click it and causes issues and turns them away from the game system. How can I disable the option to go into Launch Options?

    Exact quote: “Press a key (or joystick button 0) to configure launch options for emulator/port (mame4all). Errors will be logged to /tmp/runcommand.log
    Pac-Man (Midway) (pacmanm) …” for when I run the mame pacmanm.

    herbfargus
    Member
    Post count: 1858

    You’ll have to recode es_systems.cfg manually to call each emulator from retroarch and it will also keep you from being able to switch emulators easily. It would be something similar to this:

    retroarch -L /opt/retropie/libretrocores/lr-pocketsnes/libretro.so

    Might be a bit different with some more direct paths and a few append configs here and there..

    The menu you speak of is called the runcommand menu. It might also be possible to disable it from the retropie setup script somewhere but I haven’t looked into it too much.

    LodanZark
    Participant
    Post count: 69

    go to /opt/retropie/supplementary/runcommand.sh

    find this code:

    # check for x/m key pressed to choose a screenmode (x included as it is useful on the picade)
    clear
    echo "Press a key (or joypad button 0) to configure launch options for emulator/port ($emulator). Errors will be logged to /tmp/runcommand.log"
    IFS= read -s -t 1 -N 1 key </dev/tty
    if [[ -n "$key" ]]; then
        get_all_modes
        main_menu
        dont_launch=$?
        clear
    fi

    reduce the time to zero by switching this line IFS= read -s -t 1 -N 1 key </dev/tty to IFS= read -s -t 0 -N 1 key </dev/tty

    supernovadk
    Member
    Post count: 1

    Hello !

    Thx for the help – But for me it’s impossible to write over this file…! Permission is denied…
    Could you please explain me how to do it ?

    Thx a lot ! I’m totally upset with this menu !

    herbfargus
    Member
    Post count: 1858

    sudo nano /opt/retropie/supplementary/runcommand

    Ctrl+x

    Y

    Enter.

    footwo
    Participant
    Post count: 28

    [quote=108823]go to /opt/retropie/supplementary/runcommand.sh

    find this code:

    # check for x/m key pressed to choose a screenmode (x included as it is useful on the picade)
    clear
    echo "Press a key (or joypad button 0) to configure launch options for emulator/port ($emulator). Errors will be logged to /tmp/runcommand.log"
    IFS= read -s -t 1 -N 1 key </dev/tty
    if [[ -n "$key" ]]; then
        get_all_modes
        main_menu
        dont_launch=$?
        clear
    fi

    reduce the time to zero by switching this line IFS= read -s -t 1 -N 1 key </dev/tty to IFS= read -s -t 0 -N 1 key </dev/tty

    [/quote]

    Note that this does nothing.

    I’m also trying to disable the launch options menu from being accessible, but only via joypad presses. Basically I only want access to the launch options menu as long as a keyboard is connected (on older version of retropie you could only use a keyboard at this point to enter the menu).

    I’m convinced the solution is in the runcommand script I just don’t know what it is. I tried changing the -t time switch to 0 but I still see the message each time.

    labelwhore
    Participant
    Post count: 526

    Have you tried just commenting this section out? it seems like it may disable that message completely, but it’s a start.

    # check for x/m key pressed to choose a screenmode (x included as it is useful on the picade)
    clear
    echo "Press a key (or joypad button 0) to configure launch options for emulator/port ($emulator). Errors will be logged to /tmp/runcommand.log"
    IFS= read -s -t 1 -N 1 key </dev/tty
    if [[ -n "$key" ]]; then
        get_all_modes
        main_menu
        dont_launch=$?
        clear
    fi
    footwo
    Participant
    Post count: 28

    Yes that completely disables the feature. I’m not sure if that has any other side effects, I would think not since the runcommand.sh script is quite well commented and that all seems to be a self contained section for allowing the user to enter the launch options.

    Ideally I’d rather it just didn’t respond to joypad presses. I want a closed system when a joypad is used, so debug features like the launch options requires a keyboard.

    I’m going to try just commenting out what LOOKS like the hook for the joypad button press but im not sure:

    if [[ -n $__joy2key_pid ]]; then
        kill -INT $__joy2key_pid
    fi
    footwo
    Participant
    Post count: 28

    nope, that doesn’t work.

    wilstorm
    Participant
    Post count: 5

    I am having different issue related to the same option:

    “Press a key (or joypad button 0) to configure launch options for emulator/port ($emulator).”

    What I am using is an XBOX 360 wireless dongle as per these instructions:

    https://github.com/RetroPie/RetroPie-Setup/wiki/setting-up-the-xbox360-controller

    It works perfectly except for one small issue. Usually buttons A, B, C & D map to 0, 1, 2 & 3 on the XBOX 360 controller. When using wireless controller as per the instructions buttons A, B, C & D map to values 4,5,6 & 7.

    I tried pressing all buttons on the controller but none of them will let me select/change the emulator. The keyboard works fine but I’m trying to access this feature via the controller so I don’t need a keyboard plugged in. Is there a way to change the button from 0 to 4 so it works with the wireless setup to change the emulator?

    I see the code area you pointed out in the /opt/retropie/supplementry/runcommand/runcommand.sh file but I don’t quite understand what to change.

    check for x/m key pressed to choose a screenmode (x included as it is useful on the picade)
    clear
    echo “Press a key (or joypad button 0) to configure launch options for emulator/port ($emulator). Errors will be logged to /tmp/runcommand.log”
    IFS= read -s -t 1 -N 1 key </dev/tty
    if [[ -n “$key” ]]; then
    get_all_modes
    main_menu
    dont_launch=$?
    clear
    fi

    if [[ -n $__joy2key_pid ]]; then
    kill -INT $__joy2key_pid
    fi

    if [[ $dont_launch -eq 1 ]]; then
    exit 0
    fi

    switch_mode “$mode_new_id”
    switched=$?

    [[ -n “$fb_new” ]] && switch_fb_res “$fb_new”

    config_dispmanx “$save_emu”

    Any help would be greatly appreciated.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.