Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • ausnick
    Participant
    Post count: 2

    Hi guys,

    The obligatory “new to linux and raspberry pi, retropie” etc.

    I’m trying to set up my SNES controller using the Mayflash SNES to USB converter. I followed the set up guides here (https://www.youtube.com/watch?v=ySoTQhQqZdI around the 9:30 mark), here (https://www.youtube.com/watch?v=OBloKEbBRAU) and here (https://www.youtube.com/watch?v=Z0FT4i2CQVI). The set up seems to go off without a hitch and JSTEST shows all the buttons registering as they should. However when I go to load a SNES game, none of the buttons are configured correctly, the R button is the start button for some reason and the start button closes the emulation. Then when I press f4, I can see some text at the top, after a few lines that start with “Dispmanx:”, that says;

    “Could not find joystick mapping forHuiJia USB GamePad, use default
    Could not find joystick mapping forHuiJia USB GamePad, use default
    No ROM file header found”

    This is despite the fact that when I set it up it was recognized as a HuiJia USB Gamepad and config files for it have been configured and are present. What could be going wrong?

    I’m using the Raspberry Pi 2, RetroPie 2.6, installed from an SD card image.

    I have even tried copying other peoples config settings, such as here: https://www.petrockblock.com/forums/topic/mayflash-usb-with-snes-controllers-second-controller-not-working/

    Thanks!

    ausnick
    Participant
    Post count: 2

    Ok, so after getting desperate I did a completely fresh image install/upgrade to Retropie 3.0, configured the controller and sure enough now it works! The second port even functions as player 2 without any set up. No idea what changed but that seemed to fix it!

    dronnen
    Participant
    Post count: 3

    But how do you configure the controller ??? I have the exact same setup – Mayflash 2x SNES to USB adapter. I can get it to work in the menu of EmulationStation, but NOT when I launch a emulator.

    I have NOT configured anything for the SNES emulator, because I do NOT know where I configure it!??

    Please help me.

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.