Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • labelwhore
    Participant
    Post count: 526

    I’m not really sure what happened, but controls in lr-mame2003 completely quit working. I’ve tried reinstalling that emulator, but that didn’t help at all. I can bring up the emulator menu just fine with a keyboard, but when I go to remap the controller, the input from the controller is not recognized by lr-mame2003, so it’s impossible to map from there. I tried editing /opt/retropie/configs/retroarch.cfg, there were a ton of controller lines in there that all had null for the button value. That didn’t look right so I replaced them with the correct values for my xbox controller, but still nothing. What am I missing here? how can I get lr-mame2003 to recognize my controller again?

    labelwhore
    Participant
    Post count: 526

    I’ve just found that if I point to the psx retroarch.cfg file I can mostly get my controls to work.

    So whatever the problem is, it exists in the retroarch.cfg file. Could somebody using an xbox360 controller share the contents of their /opt/retropie/configs/mame-libretro/retroarch.cfg file?

    labelwhore
    Participant
    Post count: 526

    I got this figured out. not working yet, but I figured out what happened which will allow me to unscrew my control situation. It was a cascade of errors that led me to using the correct set of roms in an emulator that did not have controls properly set up. Which was different from the one I had previously used. It’s more or less sorted now though.

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.