Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #3548

    Hi All

    I really need some help getting a controller working I have tried two avenues with no luck!

    First I’ve tried a standard unbranded pc usb controller – which is recognised by the pie and lets me setup through the input configuration no problem. However when I come to save the input settings I just get ‘Script Error’. If I just select the Retro Arch emulator it does say done but then the controller won’t work in game.

    I’ve also tried setting this up through the updated setup script it says controller is recognised but when it asked me to configure I just get time out when pressing buttons on the pad?

    Secondly I’ve tried a wired xbox 360 controller – I’ve installed the xboxdrivers and enterered this code ‘xboxdrv -D i 0 –next-controller -i 1 –next-controller -i 2 –next-controller -i 3 –deadzone 4000 –dbus disabled’

    This appears to set the controller up as the xbox light stops flashing and the player 1 light is on. However after pressing enter on the above command I get the message about the software being free to redistribute etc. but then just a flashing cursor no command prompt – when i reboot the xbox controller is no longer recognised!-( would using a powered usb hub solve this problem?

    Sorry for the long post but if anyone can offer any assistance in getting either controller working it would be very much appreciated.

    Many Thanks


    I think I’m having the same issue as you, jayce.

    I’ve tried going through the controller configuration a few times. I got the “script error” before both when only RetroArch was checked, but also when others are checked.

    If I only check the RetroArch option, I can go through the complete configuration and save it and test it. But it only kind of works in-game. In a couple games, the A, B, X, Y buttons work, but not the direction pad. But the direction pads work when navigating the Emulatorstation menu, for example, I’m using the direction pads to select which game to start. Once the game starts, the direction pad doesn’t register.

    I’m using Logitech Cordless rumble pad 2, but I have another generic brand coreless controller and a similar thing happens.

    On my RPi, I’m using the latest (as of last night) SD card image.

    I’m not sure if this helps, but it seems this exact some question has been posed several times before:

    No luck getting any controllers to work with emulators.

    Controller not working. Help?

    I don’t see any straight forward solutions in those posts. Some of the suggestions I just don’t understand – like “You need to use retroarch-joystick and put its output into ~/RetroPie/configs/all/retroarch.cfg”

    Hoping for some responses that would clarify this.


    I had some controller woes, as well, but I was able to fix my issues. I have a Logitech Dual Action USB controller.

    Here is my post if you find it useful.

    [Solved] Issues with retroarch.cfg configuration for joypads – exit emulator

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.