Homepage Forums RetroPie Project GPIO Adapter, ControlBlock etc. ControlBlock: Everything working but the SNES controllers, Please Help!

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #116517


    I am very new to RetroPie, command line, and the whole raspberrypie thing, but I have carefully followed all of the installation instruction and coding that I can find. I have looked over my wiring many times and everything appears to be in order (Please see attached pics)

    My build is in a SNES mini, i have retained the original controller ports and on-off switch, and have soldered onto the bottom side of the board at those points. I had to retain the main original SNES board, because the ports and the rear panel are connected to the main board. I simply hacked everything off of the original SNES bard to make room for the Rp2.

    I went through all of the online instructions and everything seemed to go okay as I received no errors. Retropie and ES boot up without issues and run smoothly, a USB SNES controller is connected via USB and is working as it should, a usb wifi dongle is plugged in and working as it should and is connected to my network. A wireless USB keyboard dongle is also working as it should.

    The ControBlock Power switch function works as it should and powers the system up and down completely without issue.

    Here is where things go wrong, when I boot up, I can see that 3 controllers are recognized, but only the usb controller is active, I am never asked, nor am i able to configure the two controllers connected to the original SNES ports. I have scoured the internet and this blog looking for answers and have tried everything that i can find, but still no working controllers besides the USB one. Here is what i can tell you about my system:

    – Raspberrypie 2
    – latest retropie sd image installed and working properly (from what i can see)
    – controlblock rev 2.1 (wired for SNES) on off switch working properly
    – System is not over clocked
    – device tree is enabled
    – 12c is enabled and set to load as default
    – SNESdev is disabled
    – Input gamepad type at: (sudo nano /etc/controlblockconfig.cfg) is set to “snes”

    That’s really all I know to do and look for…
    With everything else working as it should, I can only assume that I am missing something simple here…

    As I said earlier, I am (very) new to raspberryPie and command line, so anything that you need me to do to investigate this needs to be spelled out very clearly.

    For instance, I see basic commands on the blog like “jstest /dev/input/js1” for testing basic functions, but… when i simply type “jstest /dev/input/js1” into the command line, I get the error: (-bash: jstest: command not found)
    So I assume that I am missing something… I really need full (new user) instructions please.

    Any help in this is greatly appreciated. Thank you in advance!


    Here is a pic of the diagram noting my wiring colors for this build.


    Even though we had contact via email, I just add the following information so that others also get these information:

    I updated the description of the command-line installation procedure in the ControlBlock article. You can find it at: https://www.petrockblock.com/2014/12/29/controlblock-power-switch-and-io-for-the-raspberry-pi/#Command-Line_Installation


    Florian, thank you but I have done fresh installs twice now using your updated command line install procedure, Everything installs without error and the two controllers show up in the controller configuration menu, but can not actually be configured.

    If I unplug a controller and plug it back in, it will register as a control block controller and enter the configuration screen for that controller, but the controller does not respond and can not be configured. I have tried several OEM SNES controllers, rewired several times and tried 3 different control blocks, all with the same result, no SNES support vie the control block.

    It looks like others are having this same issue as well, any ideas as to what might be causing this?



    I have uploaded a video that shows the setup and configuration of the ControlBlock together with SNES controllers:

    You can find it here.

    When you watch that video, do you see a difference to your setup or configuration?


    thank you for the video and link, Went through every step and it is all exactly the same as what I have done, several times since you sent the step by step instructions, when jstest the controllers, all buttons register “on” and no changes are seen when pressing buttons or d pad, what is our next step here to get this resolved?



    image of controller test showing all switches as “on”
    button presses on the controller cause nothing to happen as they are already showing as “on”, d pad also has no change when pushing different directions.

    What is causing this?
    This happens with several OEM SNES controllers connected directly to the SNES “mini” system console.

    [attachment file=”IMG_1499.JPG”]


    Another reason that I can think of might be that the SNES sockets are still connected to the original SNES main board (at least it seems so from the pictures). The ICs on the main board could interfere with the signals from the ControlBlock.

    You could test that by changing the configuration of the ControlBlock to arcade, using a GND connected wire to simulate button presses by momentarily connecting it with an arbitrary pin of the ControlBlock that is currently not connected with the SNES main board. You should see that simulated button press as “ON” in with the tool jstest. That is also another way for confirming the correct functionality of the ControlBlock BTW.

    Or you could just disconnect the SNES sockets from the SNES main board.


    Wiring the controlBlock to the system controller ports actually was a concern of mine from the beginning, for this exact reason. The SNES controller port photo diagram on the site led me to believe that it would not be an issue, but with the SNES mini, it actually is an issue.

    After another (seemingly) failed attempt at the driver installation, I began to hack the board and made cuts to separate the system controller ports from the SNES main board thinking that this would sever the traces to the SNES IC’s. Unfortunately this did not help.

    I then separated the system controller ports completely from the SNES man in board by cutting the pins from the board and soldering directly to the pins. This isolated the controller ports from the SNES system case and main board board, and indeed cured the issue of all switches being activated at once and not allowing configuration or use of the controllers via the ControlBlock.

    The construction on the SNES Mini differs in that the controller port is part of the main board, the pins that connect with the controller cables are soldered directly to the main board, there are no ribbons or wires that can be disconnected to isolate the controller ports.

    With this discovery, it should be noted in the ControlBlock installation instructions that: if a second generation SNES (SNES Mini) is the system being used to connect directly to, the controller ports need to be “completely” separated from the SNES board. Controller wires from the ControlBlock must be connected to an SNES mini controller port that is isolated from the SNES main board.

    My retropie SNES Mini system is fully operational now! Below is a photo of the SNES mini controller port isolated from the SNES main board. I will also post a few photos of the finished working system.

    Thank you for all of your help!

    [attachment file=”IMG_1500.JPG”]


    finished project pics:


    finished project pics 2:


    finished project pics 3:

Viewing 12 posts - 1 through 12 (of 12 total)
  • The forum ‘GPIO Adapter, ControlBlock etc.’ is closed to new topics and replies.