Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • doctorpenguin
    Post count: 5

    I have tried editing the script and using the auto script to get the controller to work. I have additonally tried different wires and different controllers. I have tried switching from 1.x to 2.2. I have tried using a blue-tooth usb with the ps3 controllers. I have attempted to follow just about every guide on github for retropi and linux. Yet the Xbox360 controller works every time and does not even have to be configured to work in the emulationstation ui or in GBA or MAME4All. Does anyone have any suggestions? Correction, got it to work with USB now b/c I had the bluetooth USB plugged in and it as the sole controller. Going to try to register it as bluetooth now. Just tried to register it on bluetooth and got the error,
    pi@raspberrypi ~ $ sudo ./sixpair
    usb_claim_interface: Device or resource busy
    pi@raspberrypi ~ $

    Where is the default install of sixpair on retropi? and is this the reason for that error?

    I have tried just about every guide on github.

    My 2nd issue is Mupen64Plus that comes on retropie by default. It was giving me consistent errors and segmentation faults even when I recompiled or used a different version (earlier) of retropie. The specific issue I get upon trying to build is (standard input):87427: Error: undefined local label ‘/16959’
    Please submit a full bug report, with preprocessed source if appropriate.

    make *** [_obj/r4300/new_dynarec.o] Error 4

    My 3rd issue is how can I add themes to retropie? I tried adding them to the theme folder @ /etc/emulationstation/themes and even though I have done this the images like backround does not show up…

    A 4th issue is how do I now that I have 2 controllers registered, use two when the config file only has 1 profile?

    Any help would be appreciated.


    Post count: 13

    I got my PS3 controller to work with it being plugged in by going to RetroPie-Setup location from the command line and then running the
    sudo ./

    From there I chose option 3 and then ran option 322 to register my retroarch controller.

    Note: I did not chose the option to install the PS3 controller driver just running the register RetroArch controller option worked for me.

    I also didn’t do this with Bluetooth so I always have to have my PS3 controller plugged in.

    I also tested to see if I could play 2 player games with 2 PS3 controllers and I was able to both controllers worked fine and I’m pretty sure both were able to make use of the save state,load state,menu,and reset options I configured.

    As for N64 emulation I know that noone so far has gotten it running on versions 2.x (I don’t know about earlier versions I just started with version 2.1)

    For the themes I haven’t tried getting to set any of my own so I don’t know where to put them but I don’t think anyone has posted any new themes yet for version 2.x.

    Post count: 5


    Post count: 571

    yup the themes do go in /etc/emulationstation/themes but themes need to be remade, to be honest they are not too difficult once you get the hang of them (again) and I think there will be some good ones created,
    I’ll have a look into remaking that one you mentioned in the other thread

    Sent from my iPhone using Tapatalk

    Post count: 5

    Ya, those were just ideas for custom themes. Can you restore some of the old 1.xx themes? I’m debating making a python script to write that bit of xml if I can see a guide on how it has to be organized.


    Doctor P.

    Changing post to resolved b/c it is partially resolved.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.