Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • InsecureSpike
    Participant
    Post count: 571

    is anyone else having this issue? is it serious? is there a fix?

    i’m running;
    h/w: raspberry pi 2 running from flash drive
    s/w: latest version

    edit:
    think I’ll try this later

    audio_out_rate=44100
    audio_driver=sdl
    kitchuk
    Participant
    Post count: 207

    I noticed this error as of recent. Anyone know what causes this?

    sevik
    Participant
    Post count: 1

    I had this problem when running mupen64plus. In addition the sound was extremly loud. I fixed it by changing the audio plugin in “/opt/retropie/configs/n64/mupen64plus.cfg”.

    # AudioPlugin = mupen64plus-audio-omx
    AudioPlugin = “mupen64plus-audio-sdl”

    Note: I’m not an expert and I don’t really understand what I’ve done. But so far it works ;-)

    InsecureSpike
    Participant
    Post count: 571

    ok, so this IS a known issue!

    http://mailman.alsa-project.org/pipermail/alsa-devel/2013-January/058136.html

    i think i’s just a search now of a work around. thats for all systems, as this happens to me with psx, neo geo, sega cd and pce. not sure if any others are effected, i’ll hopefully get to check this out over the next few days.

    but any suggestions, or help would be wonderful,

    thank you sevik

    labelwhore
    Participant
    Post count: 526

    I can speak to this on a high level. I’m somewhat of a digital audio expert. However, I’m a linux noob.

    The problem is, as the error states with the memory buffer for processing audio. Information isn’t being processed from that buffer fast enough to add anything else to it. Theoretically, there are two ways to fix it; increase the amount of memory allocated to the audio buffer, or reduce the amount of data flowing into it. The simple solution is the second option. We can easily do that by cutting the audio bit rate in half.

    instead of this:

    audio_out_rate=44100
    audio_driver=sdl

    do this:

    audio_out_rate=22050
    audio_driver=sdl

    you could also try this:

    audio_out_rate=24000
    audio_driver=sdl

    These are industry standard bit rates, try to stick to them or you may end up with strange audio artifacts or changes in pitch for music and sound effects.

    InsecureSpike
    Participant
    Post count: 571

    this is awesome! thank you! I’ll try these when I get home from work!

    thank you

    labelwhore
    Participant
    Post count: 526

    With those settings, the audio may be a bit “crunchier” but heh, it’ll help add some vintage charm. :)

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.